Sort order still a problem for e-mail

  • Thread starter Bluebonnet
  • Start date Views 1,748
B

Bluebonnet

I am using Outlook 2007. My sort order is set to First Last, and I have

changed it to Last First, restarted Outlook, and changed it back to First

Last and restarted again. Still, when I go to send an e-mail, about 90% of

my contacts are in correct First Last order, but the other 10% is in Last

First. The erroneous info appears to be quite random, as I've looked at the

actual contact records and there is nothing unusual about them. Is there any

way to correct this, besides completely deleting those contacts and

re-entering them?
 
R

Russ Valentine

Sort order for what view?

The address book view has no "Last, First" option.

Russ Valentine

"Bluebonnet" <Bluebonnet> wrote in message

news:FB933A10-68C0-48DE-AD20-B42B420C0407@microsoft.com...
> I am using Outlook 2007. My sort order is set to First Last, and I have
> changed it to Last First, restarted Outlook, and changed it back to First
> Last and restarted again. Still, when I go to send an e-mail, about 90%
> of
> my contacts are in correct First Last order, but the other 10% is in Last
> First. The erroneous info appears to be quite random, as I've looked at
> the
> actual contact records and there is nothing unusual about them. Is there
> any
> way to correct this, besides completely deleting those contacts and
> re-entering them?
 
B

Bluebonnet

Tools>Account Settings>Address Books>Outlook Address Book
The choices are First Last (John Smith) or File As (Smith, John)

So I guess I would have been more correct to say some of them are showing up

in File As format.

"Russ Valentine" wrote:


> Sort order for what view?
> The address book view has no "Last, First" option.
> > Russ Valentine
> "Bluebonnet" <Bluebonnet> wrote in message
> news:FB933A10-68C0-48DE-AD20-B42B420C0407@microsoft.com...
> >I am using Outlook 2007. My sort order is set to First Last, and I have
> > changed it to Last First, restarted Outlook, and changed it back to First
> > Last and restarted again. Still, when I go to send an e-mail, about 90%
> > of
> > my contacts are in correct First Last order, but the other 10% is in Last
> > First. The erroneous info appears to be quite random, as I've looked at
> > the
> > actual contact records and there is nothing unusual about them. Is there
> > any
> > way to correct this, besides completely deleting those contacts and
> > re-entering them?


> .
>
 
R

Russ Valentine

So explain what isn't happening that you think should.

Outlook obeys your settings. Provide an example where it does not. Pay

attention to your File As field if that is the field by which you are

sorting.

Russ Valentine

"Bluebonnet" <Bluebonnet> wrote in message

news:2F5562A2-F532-4732-8C38-BE9AE3409900@microsoft.com...
> Tools>Account Settings>Address Books>Outlook Address Book
> The choices are First Last (John Smith) or File As (Smith, John)

> So I guess I would have been more correct to say some of them are showing
> up
> in File As format.

> "Russ Valentine" wrote:
>
> > Sort order for what view?
> > The address book view has no "Last, First" option.
> > > > Russ Valentine
> > "Bluebonnet" <Bluebonnet> wrote in message
> > news:FB933A10-68C0-48DE-AD20-B42B420C0407@microsoft.com...
> > >I am using Outlook 2007. My sort order is set to First Last, and I have
> > > changed it to Last First, restarted Outlook, and changed it back to
> > > First
> > > Last and restarted again. Still, when I go to send an e-mail, about
> > > 90%
> > > of
> > > my contacts are in correct First Last order, but the other 10% is in
> > > Last
> > > First. The erroneous info appears to be quite random, as I've looked
> > > at
> > > the
> > > actual contact records and there is nothing unusual about them. Is
> > > there
> > > any
> > > way to correct this, besides completely deleting those contacts and
> > > re-entering them?

>

>> .
> >
 
B

Bluebonnet

Okay, here's a specific example...

First, one that is showing up the way I'd like (First Last):

In Contacts, the record for Sue Young has File As: Young, Sue and Display

As: Sue.

When I compose an e-mail and click To: (opening the address list), Sue shows

up as "Sue Young".

Second, Karen Young is entered exactly the same way. File As: Young, Karen

and Display As: Karen.

When I compose an e-mail and click To:, Karen shows up as "Young, Karen".

Since their records appear to be set up identically, I don't understand why

one shows up First Last and the other one shows up Last First. I can't find

anything different between the two records.

I hope this helps clarify what's puzzling me...

"Russ Valentine" wrote:


> So explain what isn't happening that you think should.
> Outlook obeys your settings. Provide an example where it does not. Pay
> attention to your File As field if that is the field by which you are
> sorting.
> > Russ Valentine
> "Bluebonnet" <Bluebonnet> wrote in message
> news:2F5562A2-F532-4732-8C38-BE9AE3409900@microsoft.com...
> > Tools>Account Settings>Address Books>Outlook Address Book
> > The choices are First Last (John Smith) or File As (Smith, John)
> > So I guess I would have been more correct to say some of them are showing
> > up
> > in File As format.
> > "Russ Valentine" wrote:
> >
> >> Sort order for what view?
> >> The address book view has no "Last, First" option.
> >> > >> Russ Valentine
> >> "Bluebonnet" <Bluebonnet> wrote in message
> >> news:FB933A10-68C0-48DE-AD20-B42B420C0407@microsoft.com...
> >> >I am using Outlook 2007. My sort order is set to First Last, and I have
> >> > changed it to Last First, restarted Outlook, and changed it back to
> >> > First
> >> > Last and restarted again. Still, when I go to send an e-mail, about
> >> > 90%
> >> > of
> >> > my contacts are in correct First Last order, but the other 10% is in
> >> > Last
> >> > First. The erroneous info appears to be quite random, as I've looked
> >> > at
> >> > the
> >> > actual contact records and there is nothing unusual about them. Is
> >> > there
> >> > any
> >> > way to correct this, besides completely deleting those contacts and
> >> > re-entering them?
> >
> >> .
> >>


> .
>
 
R

Russ Valentine

Not really. You failed to mention the sort order you specified. Whenever you

change the sort order, you must restart Outlook.

Your "Display As" field is confusing. Did you manually reset it from

Outlook's default?

Russ Valentine

"Bluebonnet" <Bluebonnet> wrote in message

news:C2C58236-CC18-4073-B76C-0D95761B8387@microsoft.com...
> Okay, here's a specific example...

> First, one that is showing up the way I'd like (First Last):
> In Contacts, the record for Sue Young has File As: Young, Sue and Display
> As: Sue.
> When I compose an e-mail and click To: (opening the address list), Sue
> shows
> up as "Sue Young".

> Second, Karen Young is entered exactly the same way. File As: Young, Karen
> and Display As: Karen.

> When I compose an e-mail and click To:, Karen shows up as "Young, Karen".

> Since their records appear to be set up identically, I don't understand
> why
> one shows up First Last and the other one shows up Last First. I can't
> find
> anything different between the two records.

> I hope this helps clarify what's puzzling me...

> "Russ Valentine" wrote:
>
> > So explain what isn't happening that you think should.
> > Outlook obeys your settings. Provide an example where it does not. Pay
> > attention to your File As field if that is the field by which you are
> > sorting.
> > > > Russ Valentine
> > "Bluebonnet" <Bluebonnet> wrote in message
> > news:2F5562A2-F532-4732-8C38-BE9AE3409900@microsoft.com...
> > > Tools>Account Settings>Address Books>Outlook Address Book
>>> > The choices are First Last (John Smith) or File As (Smith, John)
> >> > So I guess I would have been more correct to say some of them are
> > > showing
> > > up
> > > in File As format.
> >> > "Russ Valentine" wrote:
> >> >> Sort order for what view?
> > >> The address book view has no "Last, First" option.
> > >> > > >> Russ Valentine
> > >> "Bluebonnet" <Bluebonnet> wrote in message
> > >> news:FB933A10-68C0-48DE-AD20-B42B420C0407@microsoft.com...
> > >> >I am using Outlook 2007. My sort order is set to First Last, and I
> > >> >have
> > >> > changed it to Last First, restarted Outlook, and changed it back to
> > >> > First
> > >> > Last and restarted again. Still, when I go to send an e-mail, about
> > >> > 90%
> > >> > of
> > >> > my contacts are in correct First Last order, but the other 10% is in
> > >> > Last
> > >> > First. The erroneous info appears to be quite random, as I've
> > >> > looked
> > >> > at
> > >> > the
> > >> > actual contact records and there is nothing unusual about them. Is
> > >> > there
> > >> > any
> > >> > way to correct this, besides completely deleting those contacts and
> > >> > re-entering them?
> > >
>> >> .
> > >>

>

>> .
> >
 
B

Bluebonnet

As I stated in my original post, sort order is First Last. And as I also

stated, I tried chainging it to Last First, restarted Outlook, then changed

it to First Last and restarted Outlook again. (I had already read previous

postings mentiioning the restarts.) And yes, I do manually change the

Display if I don't like Outlook's default. That shouldn't affect the sort

order of the list that pops up when I'm sending an e-mail. Most of the items

in the list are First Last; it's only about 10% that keep coming up Last

First. If I have to delete those and re-enter them, I will, but I was hoping

to isolate the cause.

"Russ Valentine" wrote:


> Not really. You failed to mention the sort order you specified. Whenever you
> change the sort order, you must restart Outlook.
> Your "Display As" field is confusing. Did you manually reset it from
> Outlook's default?
> > Russ Valentine
> "Bluebonnet" <Bluebonnet> wrote in message
> news:C2C58236-CC18-4073-B76C-0D95761B8387@microsoft.com...
> > Okay, here's a specific example...
> > First, one that is showing up the way I'd like (First Last):
> > In Contacts, the record for Sue Young has File As: Young, Sue and Display
> > As: Sue.
> > When I compose an e-mail and click To: (opening the address list), Sue
> > shows
> > up as "Sue Young".
> > Second, Karen Young is entered exactly the same way. File As: Young, Karen
> > and Display As: Karen.
> > When I compose an e-mail and click To:, Karen shows up as "Young, Karen".
> > Since their records appear to be set up identically, I don't understand
> > why
> > one shows up First Last and the other one shows up Last First. I can't
> > find
> > anything different between the two records.
> > I hope this helps clarify what's puzzling me...
> > "Russ Valentine" wrote:
> >
> >> So explain what isn't happening that you think should.
> >> Outlook obeys your settings. Provide an example where it does not. Pay
> >> attention to your File As field if that is the field by which you are
> >> sorting.
> >> > >> Russ Valentine
> >> "Bluebonnet" <Bluebonnet> wrote in message
> >> news:2F5562A2-F532-4732-8C38-BE9AE3409900@microsoft.com...
> >> > Tools>Account Settings>Address Books>Outlook Address Book
> >> >> > The choices are First Last (John Smith) or File As (Smith, John)
> >> >> > So I guess I would have been more correct to say some of them are
> >> > showing
> >> > up
> >> > in File As format.
> >> >> > "Russ Valentine" wrote:
> >> >> >> Sort order for what view?
> >> >> The address book view has no "Last, First" option.
> >> >> > >> >> Russ Valentine
> >> >> "Bluebonnet" <Bluebonnet> wrote in message
> >> >> news:FB933A10-68C0-48DE-AD20-B42B420C0407@microsoft.com...
> >> >> >I am using Outlook 2007. My sort order is set to First Last, and I
> >> >> >have
> >> >> > changed it to Last First, restarted Outlook, and changed it back to
> >> >> > First
> >> >> > Last and restarted again. Still, when I go to send an e-mail, about
> >> >> > 90%
> >> >> > of
> >> >> > my contacts are in correct First Last order, but the other 10% is in
> >> >> > Last
> >> >> > First. The erroneous info appears to be quite random, as I've
> >> >> > looked
> >> >> > at
> >> >> > the
> >> >> > actual contact records and there is nothing unusual about them. Is
> >> >> > there
> >> >> > any
> >> >> > way to correct this, besides completely deleting those contacts and
> >> >> > re-entering them?
> >> >
> >> >> .
> >> >
> >
> >> .
> >>


> .
>
 

Brian Tillman

Senior Member
"Bluebonnet" <Bluebonnet> wrote in message

news:2F5562A2-F532-4732-8C38-BE9AE3409900@microsoft.com...


> Tools>Account Settings>Address Books>Outlook Address Book
> The choices are First Last (John Smith) or File As (Smith, John)

> So I guess I would have been more correct to say some of them are showing up
> in File As format.


Did you import any of these contacts? That tends to mess up the Address Book

display.

--
 
R

Russ Valentine

If you told Outlook to sort by First, Last, then it is.

My suspicion is that you created your Contacts incorrectly and failed to

parse the name elements to their appropriate field. If you enter names into

the Full Name field, for example, there is a very good chance the name

elements didn't parse correctly. Parse them yourself.

Russ Valentine

"Bluebonnet" <Bluebonnet> wrote in message

news:4BCA5210-66F1-4891-B0C0-9F2756828944@microsoft.com...
> As I stated in my original post, sort order is First Last. And as I also
> stated, I tried chainging it to Last First, restarted Outlook, then
> changed
> it to First Last and restarted Outlook again. (I had already read
> previous
> postings mentiioning the restarts.) And yes, I do manually change the
> Display if I don't like Outlook's default. That shouldn't affect the sort
> order of the list that pops up when I'm sending an e-mail. Most of the
> items
> in the list are First Last; it's only about 10% that keep coming up Last
> First. If I have to delete those and re-enter them, I will, but I was
> hoping
> to isolate the cause.

> "Russ Valentine" wrote:
>
> > Not really. You failed to mention the sort order you specified. Whenever
> > you
> > change the sort order, you must restart Outlook.
> > Your "Display As" field is confusing. Did you manually reset it from
> > Outlook's default?
> > > > Russ Valentine
> > "Bluebonnet" <Bluebonnet> wrote in message
> > news:C2C58236-CC18-4073-B76C-0D95761B8387@microsoft.com...
> > > Okay, here's a specific example...
> >> > First, one that is showing up the way I'd like (First Last):
> > > In Contacts, the record for Sue Young has File As: Young, Sue and
> > > Display
> > > As: Sue.
> > > When I compose an e-mail and click To: (opening the address list), Sue
> > > shows
> > > up as "Sue Young".
> >> > Second, Karen Young is entered exactly the same way. File As: Young,
> > > Karen
> > > and Display As: Karen.
> >> > When I compose an e-mail and click To:, Karen shows up as "Young,
> > > Karen".
> >> > Since their records appear to be set up identically, I don't understand
> > > why
> > > one shows up First Last and the other one shows up Last First. I can't
> > > find
> > > anything different between the two records.
> >> > I hope this helps clarify what's puzzling me...
> >>> > "Russ Valentine" wrote:
> >> >> So explain what isn't happening that you think should.
> > >> Outlook obeys your settings. Provide an example where it does not. Pay
> > >> attention to your File As field if that is the field by which you are
> > >> sorting.
> > >> > > >> Russ Valentine
> > >> "Bluebonnet" <Bluebonnet> wrote in message
> > >> news:2F5562A2-F532-4732-8C38-BE9AE3409900@microsoft.com...
> > >> > Tools>Account Settings>Address Books>Outlook Address Book
>> >>> >> > The choices are First Last (John Smith) or File As (Smith, John)
> > >>> >> > So I guess I would have been more correct to say some of them are
> > >> > showing
> > >> > up
> > >> > in File As format.
> > >>> >> > "Russ Valentine" wrote:
> > >>> >> >> Sort order for what view?
> > >> >> The address book view has no "Last, First" option.
> > >> >> > > >> >> Russ Valentine
> > >> >> "Bluebonnet" <Bluebonnet> wrote in
> > >> >> message
> > >> >> news:FB933A10-68C0-48DE-AD20-B42B420C0407@microsoft.com...
> > >> >> >I am using Outlook 2007. My sort order is set to First Last, and
> > >> >> >I
> > >> >> >have
> > >> >> > changed it to Last First, restarted Outlook, and changed it back
> > >> >> > to
> > >> >> > First
> > >> >> > Last and restarted again. Still, when I go to send an e-mail,
> > >> >> > about
> > >> >> > 90%
> > >> >> > of
> > >> >> > my contacts are in correct First Last order, but the other 10% is
> > >> >> > in
> > >> >> > Last
> > >> >> > First. The erroneous info appears to be quite random, as I've
> > >> >> > looked
> > >> >> > at
> > >> >> > the
> > >> >> > actual contact records and there is nothing unusual about them.
> > >> >> > Is
> > >> >> > there
> > >> >> > any
> > >> >> > way to correct this, besides completely deleting those contacts
> > >> >> > and
> > >> >> > re-entering them?
> > >> >
>> >> >> .
> > >> >
>> >
>> >> .
> > >>

>

>> .
> >
 
B

Bluebonnet

Thanks, Brian--That may be the problem. Is there any way to correct it,

short of deleting and re-entering?? That's beginning to look like the most

viable solution... Russ, The parsing is correct--that was one of the first

things I checked.

"" wrote:


> "Bluebonnet" <Bluebonnet> wrote in message
> news:2F5562A2-F532-4732-8C38-BE9AE3409900@microsoft.com...
>
> > Tools>Account Settings>Address Books>Outlook Address Book
> > The choices are First Last (John Smith) or File As (Smith, John)
> > So I guess I would have been more correct to say some of them are showing up
> > in File As format.


> Did you import any of these contacts? That tends to mess up the Address Book
> display.
> >

> .
>
 

Brian Tillman

Senior Member
"Bluebonnet" <Bluebonnet> wrote in message

news:D4D54ABC-0B61-4B1B-9182-A4B63669DD7B@microsoft.com...


> Thanks, Brian--That may be the problem. Is there any way to correct it,
> short of deleting and re-entering?? That's beginning to look like the most
> viable solution... Russ, The parsing is correct--that was one of the
> first
> things I checked.


The only way I know is manual and it involved modifying the Subject field of

each contact. There may be a tool you can use to change them en masse. Start

here: http://www.slipstick.com/addins/contacts.asp

--
 
R

Russ Valentine

Unfortunately importing often creates Contacts that may seem correct, but

aren't actually populated correctly until you open and save the actual

Contact Record. So if the name elements seem parsed correctly to you, simply

opening and saving the Contact may correct the sort order.

Russ Valentine

"Bluebonnet" <Bluebonnet> wrote in message

news:D4D54ABC-0B61-4B1B-9182-A4B63669DD7B@microsoft.com...
> Thanks, Brian--That may be the problem. Is there any way to correct it,
> short of deleting and re-entering?? That's beginning to look like the
> most
> viable solution... Russ, The parsing is correct--that was one of the
> first
> things I checked.

> "" wrote:
>
> > "Bluebonnet" <Bluebonnet> wrote in message
> > news:2F5562A2-F532-4732-8C38-BE9AE3409900@microsoft.com...
> >
> > > Tools>Account Settings>Address Books>Outlook Address Book
>>> > The choices are First Last (John Smith) or File As (Smith, John)
> >> > So I guess I would have been more correct to say some of them are
> > > showing up
> > > in File As format.

>

>> Did you import any of these contacts? That tends to mess up the Address
> > Book
> > display.
> > > >

>

>> .
> >
 
R

Russ Valentine

My understanding was that they stopped using the Subject field a couple of

versions ago. Do you think it is still in play?

Russ Valentine

"" <tillman1952@yahoo.com> wrote in message

news:O1WBN1v6KHA.2240@TK2MSFTNGP06.phx.gbl...
> "Bluebonnet" <Bluebonnet> wrote in message
> news:D4D54ABC-0B61-4B1B-9182-A4B63669DD7B@microsoft.com...
>
> > Thanks, Brian--That may be the problem. Is there any way to correct it,
> > short of deleting and re-entering?? That's beginning to look like the
> > most
> > viable solution... Russ, The parsing is correct--that was one of the
> > first
> > things I checked.


> The only way I know is manual and it involved modifying the Subject field
> of each contact. There may be a tool you can use to change them en masse.
> Start here: http://www.slipstick.com/addins/contacts.asp
> >
 

Brian Tillman

Senior Member
"Russ Valentine" <russval@mvps.org> wrote in message

news:OiymAGw6KHA.5112@TK2MSFTNGP02.phx.gbl...


> My understanding was that they stopped using the Subject field a couple of
> versions ago. Do you think it is still in play?


I'm going by what I had done in the past. You're probably correct because I

now see Subject fields that don't correspond to the Name field on the OAB

view. Sorry for the bad advice.

--
 
R

Russ Valentine

I was just checking whether I was remembering correctly. My recollection was

that Subject field was what the PAB used, but AFAIK the OAB has only used

the File As... field or the First, Last fields.

Microsoft has created a labyrinth of address books over the years no one can

unravel.

Russ Valentine

"" <tillman1952@yahoo.com> wrote in message

news:uig$jI46KHA.5112@TK2MSFTNGP02.phx.gbl...
> "Russ Valentine" <russval@mvps.org> wrote in message
> news:OiymAGw6KHA.5112@TK2MSFTNGP02.phx.gbl...
>
> > My understanding was that they stopped using the Subject field a couple
> > of versions ago. Do you think it is still in play?


> I'm going by what I had done in the past. You're probably correct
> because I now see Subject fields that don't correspond to the Name field
> on the OAB view. Sorry for the bad advice.
> >
 

Similar threads

Top