Outlook 2010 duplicates mail messages if you leave mail on server

Status
Not open for further replies.
T

The Rock

Just yet I installed Office 2010 pro from my MSDN subscription. This is the

retail version, not the Beta.

In my mail settings I have leave a copy of mail on the server, delete after

10 days so I get my mail on multiple computers. Upto now this worked fine.

However outlook 2010 does not notice that the mails were already downloaded,

and downloads them again an again. So now I have all my mails from the last

10 days multiple times in my mail box.

Is there a fix for this bug, and also is there a macro that removes all the

duplicate messages? I have hundreds of duplicate messages!

I think this is a major bug in Outlook 2010.
 
B

Brian Tillman

"The Rock" <TheRock> wrote in message

news:6E0D610B-F6DA-4BE0-9B2E-FEAFA51DE12D@microsoft.com...


> Just yet I installed Office 2010 pro from my MSDN subscription. This is the
> retail version, not the Beta.

> In my mail settings I have leave a copy of mail on the server, delete after
> 10 days so I get my mail on multiple computers. Upto now this worked fine.

> However outlook 2010 does not notice that the mails were already downloaded,
> and downloads them again an again. So now I have all my mails from the last
> 10 days multiple times in my mail box.


This means that something is reventing Outlook from writing the information

that helps it remember what's been downloaded. Strat Outlook in safe mode

(hold Ctrl when you start it) and see if the same thing happens. If not,

check your add-ins. Also, if you have an antivirus program configured to scan

mail, uninstall that program and reinstall it without any mail scanning.

--
 
T

The Rock

Re: Outlook 2010 duplicates mail messages if you leave mail on ser

Brian,

Thanks for the answer, however it did not help.

My ISP has a good virus scan on the mail server, I locally only have

Microsoft Security Essentials which does not have a separate mail scanner

that scans during mail coming in.

I did start Outlook in safe mode, then I did a compress on the .pst file to

verify if it is ok. The .pst file is of type Outlook Data File (97-2002).

Compression took a lot of time (more then one hour while I have a fast PC (4

corres, 4GB RAM, sata2 disks), but ended ok.

After running in safe mode the first time Outlook downloads all mails again.

Then I stop Outlook, start it again in safe mode and during the first mail

send and receive Outlook seems to run ok, no mails are downloaded and the

send receive process ends rapidly. However when I Press send and receive all

mails come in again duplicated for the 8th time now.

I also noticed the upgade from Office 2007 to Office 2010 switched of the

Auto archive settings, and changed my default account to hotmail.

Meanwhile my laptop on Office 2007 does not have any problem downloading the

same mails.

If there is no solution for this I'm thinking of uninstalling Office 2010,

restoring my backup of outlook.pst and going back to Office 2007. Needless to

say I'm very dissapointed.

"" wrote:


> "The Rock" <TheRock> wrote in message
> news:6E0D610B-F6DA-4BE0-9B2E-FEAFA51DE12D@microsoft.com...
>
> > Just yet I installed Office 2010 pro from my MSDN subscription. This is the
> > retail version, not the Beta.
> > In my mail settings I have leave a copy of mail on the server, delete after
> > 10 days so I get my mail on multiple computers. Upto now this worked fine.
> > However outlook 2010 does not notice that the mails were already downloaded,
> > and downloads them again an again. So now I have all my mails from the last
> > 10 days multiple times in my mail box.


> This means that something is reventing Outlook from writing the information
> that helps it remember what's been downloaded. Strat Outlook in safe mode
> (hold Ctrl when you start it) and see if the same thing happens. If not,
> check your add-ins. Also, if you have an antivirus program configured to scan
> mail, uninstall that program and reinstall it without any mail scanning.
> >

> .
>
 
B

Brian Tillman

Re: Outlook 2010 duplicates mail messages if you leave mail on ser

"The Rock" <TheRock> wrote in message

news:254F6570-7C26-425A-9022-1E338EF6AEB4@microsoft.com...


> I did start Outlook in safe mode, then I did a compress on the .pst file to
> verify if it is ok. The .pst file is of type Outlook Data File (97-2002).
> Compression took a lot of time (more then one hour while I have a fast PC (4
> corres, 4GB RAM, sata2 disks), but ended ok.


You'll want to change that PST format soonest. See this:

http://www.slipstick.com/outlook/convert-ansi-pst-to-unicode-pst/


> After running in safe mode the first time Outlook downloads all mails again.
> Then I stop Outlook, start it again in safe mode and during the first mail
> send and receive Outlook seems to run ok, no mails are downloaded and the
> send receive process ends rapidly. However when I Press send and receive all
> mails come in again duplicated for the 8th time now.


Something is keeping Outlook from completing its send/receive properly.

Enable diagnostic logging and see if the send/receive completes properly.


> I also noticed the upgade from Office 2007 to Office 2010 switched of the
> Auto archive settings, and changed my default account to hotmail.


I haven't seen that.

--
 
T

The Rock

Re: Outlook 2010 duplicates mail messages if you leave mail on ser

Thanks again for trying to help!

I created a new PST and moved all mail, agenda, taks, notes to the new pst,

changed my rules etc. However this did not help.

If I start outlook (in normal mode) I see outlook requesting new mails.

However it does not download my new mails while there are new mails, this is

another bug I think. If I then press Send and receive it starts to download

all mails of the past 10 days again.

The debug logging is full of Fails, why is Outlook normally being silent

while it is failing all the time? Again a bug I think. These are examples of

different the fails I have in the logging:

Outlook Pieter.pst-reconcile-111856320.log

129183517174000000|2010/05/14|23:01:57:400|SGORM_ScCompareIndexerAndPST

done|RECONCILE_STATE_RECONCILE_MESSAGES||||0x8004085c|FAIL

129183517174000000|2010/05/14|23:01:57:400|SGORM_ScReconcileWithIndexer

done|RECONCILE_STATE_RECONCILE_MESSAGES||||0x8004085c|FAIL

129183518710180000|2010/05/14|23:04:31:018|SGORM_ScIssueMessageQuery

done|RECONCILE_STATE_ISSUE_MESSAGE_QUERY||||0x8004085c|FAIL

Date|Time|Action|Search Owner|NID|Change Action|Change Semantics|URL|Count

Of DocIDs|Next NID Index to add to All Msg folder|Next NID Index to push to

FTE|Folder Path|Folder Path ID|HRESULT|Result Status

2010/05/14|23:00:31:505|Processed Catalog State:

CatalogGuid={E15B247E-4E32-41D2-A025-B4C76574117B}

CheckpointGuid={61545444-294E-4487-8859-AF71A27D9DB0} CheckpointNum=187

Source=1 Timestamp={High 0x01caf36d, Low 0x8b7ee7a0}|||||OK

2010/05/14|23:01:22:294|Doc Not Found|2|106116|||||||||0x8004010f|FAIL

2010/05/14|23:01:22:295|Doc Not Found|2|106117|||||||||0x8004010f|FAIL

> ....

2010/05/14|23:01:22:296|Doc Not Found|2|106121|||||||||0x8004010f|FAIL

2010/05/14|23:01:38:825|Timed out trying to reacquire the MS's CS.

SGO_SearchStep aborted, will retry later.|5||||||||||0x8004085c|FAIL

-
2010/05/14|23:02:00:385|SGO_ScProcessOnItemsChangedResults

done|5|||||63|||||0x8004085c|FAIL

2010/05/14|23:02:00:385|Batch Submitted|5|||||63|||||0x8004085c|FAIL

2010/05/14|23:02:00:385|SGO_ScPushItemsToIndexer encountered an error

between appending items to the SGPIQ and recording the resulting

DocIDs.|5||||||||||0x8004085c|FAIL

2010/05/14|23:02:00:385|Timed out trying to reacquire the MS's CS.

SGO_SearchStep aborted, will retry later.|5||||||||||0x8004085c|FAIL

> ...

2010/05/14|23:04:31:046|Doc Not Found|5|108611|||||||||0x8004010f|FAIL

2010/05/14|23:04:31:734|Timed out trying to reacquire the MS's CS.

SGO_SearchStep aborted, will retry later.|5||||||||||0x8004085c|FAIL

2010/05/14|23:04:32:743|Doc Not Found|5|108607|||||||||0x8004010f|FAIL

2010/05/14|23:04:34:694|OnIndexStatusChange -

Gatherer|5|2857732|Add||mapi://{S-1-5-21-189892497-3878525479-1947848643-1001}/Outlook Pieter($14fae19c)/0/Inbox/

So it looks like my PST already is corrupted.

Any clues how to solve this?

"" wrote:


> "The Rock" <TheRock> wrote in message
> news:254F6570-7C26-425A-9022-1E338EF6AEB4@microsoft.com...
>
> > I did start Outlook in safe mode, then I did a compress on the .pst file to
> > verify if it is ok. The .pst file is of type Outlook Data File (97-2002).
> > Compression took a lot of time (more then one hour while I have a fast PC (4
> > corres, 4GB RAM, sata2 disks), but ended ok.


> You'll want to change that PST format soonest. See this:
> http://www.slipstick.com/outlook/convert-ansi-pst-to-unicode-pst/
>
> > After running in safe mode the first time Outlook downloads all mails again.
> > Then I stop Outlook, start it again in safe mode and during the first mail
> > send and receive Outlook seems to run ok, no mails are downloaded and the
> > send receive process ends rapidly. However when I Press send and receive all
> > mails come in again duplicated for the 8th time now.


> Something is keeping Outlook from completing its send/receive properly.
> Enable diagnostic logging and see if the send/receive completes properly.
>
> > I also noticed the upgade from Office 2007 to Office 2010 switched of the
> > Auto archive settings, and changed my default account to hotmail.


> I haven't seen that.
> >

> .
>
 
B

Brian Tillman

Re: Outlook 2010 duplicates mail messages if you leave mail on ser

"The Rock" <TheRock> wrote in message

news:F024A88A-F003-46E7-A7F6-66588BF038A3@microsoft.com...


> I created a new PST and moved all mail, agenda, taks, notes to the new pst,
> changed my rules etc. However this did not help.


Did you make the new PST the default PST? Post the account configuration

details as well.

--
 
T

The Rock

Re: Outlook 2010 duplicates mail messages if you leave mail on ser

The new PST is my default PST.

My account settings are:

POP3 server, pop3.xs4all.nl, smtp.xs4all.nl

No special outgoing server settings

Connect Using my local area network (LAN)

Incoming POP3 110

Outgoing server SMTP 25

No encrypted connection

1 minute server timeout

Leave a copy of messages on the server

Remove from server after 10 days

I noticed some starnge things. Outher mail accounts that I have running

delivering mail to the same .pst do not have the duplicatin behaviour. Those

other accounts have leave a copy of messages on the server without the Remove

from server after 10 days.

Furthermore I left Outlook 2010 open since 16-5-2010, carefully not touching

the Send and Receive button. Now the duplicate mail problem seems to be gone.

Initially Outlook did not get my new mail, now it does. May be Outlook did a

overnight background consistency check on the pst.

Just jet I pressed Send Receive All Folders, this ended rapidly without

duplicating mail. So far so good.

So I restarted Outlook, pressed Send/Receive all Folders and again Outlook

starts duplicating all my mail. I cancelled the Send/Receive all Folders. Up

to now I manually deleted 6404 duplicate mails....

I will leave Outlook 2010 open again to see what it does. So far I conclude

the Send/Receive all Folders function together with Leave Messages on the

server and Remove after n days contains the duplicating bug.

"" wrote:


> "The Rock" <TheRock> wrote in message
> news:F024A88A-F003-46E7-A7F6-66588BF038A3@microsoft.com...
>
> > I created a new PST and moved all mail, agenda, taks, notes to the new pst,
> > changed my rules etc. However this did not help.


> Did you make the new PST the default PST? Post the account configuration
> details as well.
> >

> .
>
 
B

Brian Tillman

Re: Outlook 2010 duplicates mail messages if you leave mail on ser

"The Rock" <TheRock> wrote in message

news:1F41D842-44C8-49FF-902C-2ACDD6589C80@microsoft.com...


> Furthermore I left Outlook 2010 open since 16-5-2010, carefully not touching
> the Send and Receive button. Now the duplicate mail problem seems to be
> gone.
> Initially Outlook did not get my new mail, now it does. May be Outlook did a
> overnight background consistency check on the pst.


Not likely.


> Just jet I pressed Send Receive All Folders, this ended rapidly without
> duplicating mail. So far so good.

> So I restarted Outlook, pressed Send/Receive all Folders and again Outlook
> starts duplicating all my mail. I cancelled the Send/Receive all Folders. Up
> to now I manually deleted 6404 duplicate mails....


As I said before, this is an indication that Outlook isn't closing properly

and is not writing its internal data properly so it's not remembering what has

been downloaded. If this were to happen to me, I'd start with a new mail

profile. See if something here helps:

http://www.howto-outlook.com/faq/duplicates.htm

--
 
Status
Not open for further replies.
Top