Outlook 2007 clients do not connect to Exchange 2010

  • Thread starter Khalidr
  • Start date Views 2,059
Status
Not open for further replies.
K

Khalidr

I have a single Exchange 2010 server with the CAS, HT and MB roles installed. I can connect to a user mailbox via OWA but I am unable to connect to the same user mailbox with Outlook 2007. Error message - The Exchange Server is unavailable.
 
A

Amit Tank [MVP]

You need to add couple of registry keys to start MSExchangeRPC service. Once it is started, you can connect to mailbox with Outlook 2007. But still keep in mind that Public Folder doesn't work with Outlook 2007 in current public beta. These issues will be corrected in later builds...

Refer below thread for registry keys...

http://social.technet.microsoft.com/Forums/en-US/exchange2010/thread/7d5cf3dc-71b6-4252-95d6-6c52e654f90d

Amit Tank | MVP - Exchange | MCITP:EMA MCSA:M | http://ExchangeShare.WordPress.com
 
S

Snafu58

I am having the same issue. I have added the registry entries and now my MSExchangeRPC service is starting. But I still cannot connect to the 2010 server with Outlook 2007. During profile connection when you try to do a " Check Name" or " Finish" the network login comes up I fill it in but it never accepts the credentials it just keeps popping up. No error message either. I know the account is good because I can log into OWA with it. Ant ideas?
 
M

Matt Dobson

I have added both of these registry keys but Outlook 2007 profiles are still not working. The autodiscover process properly creates the profile when I first run Outlook 2007 but then I get an error stating that outlook.ost is not an offline folder file. So, I go in and remove Outlook.ost to force Outlook to create a new OST file. This doesn't work, the file is re-created but I still get the same error.
I then tried disabling Cached mode and Offline mode. Now when I start up Outlook I get an error stating that Microsoft Exchange is not available.
OWA works fine.
Single server running Windows 2008 (not R2) DC, Hub, CAS and MB role. Client is Outlook 2007 running on Windows 7 Ultimate.
Help!
 
M

Matt Dobson

Ok - I've installed SP2 but I still get an error. I'm also getting a certificate error as I jsut created a new SAN certificate but I think that's irrelevant at the moment. The error on teh Outlook profile is still the same.
 
M

Matt Dobson

I've tried setting up RPC over HTTPS but I still get the same error. As I said before the OWA seems to work fine.
I created a new mailstore and move the mailbox to that store to see if it was a problem with the default mailstore but that has made no difference.
Cheers,
Matt
 
A

Amit Tank [MVP]

Is outlook trying to connect or giving any error when you press CTRL + Right click on the outlook Icon available at Notification Area (near to clock)? Is " MSExchange Rpc Client Access" Service started after adding registries? Also disable firewall for Domain Profile of " Windows Firewall with Advance security" in Administrative tools on Windows 7 and on Windows 2008 Exchange server and check...
Haz Firewall, Want Cheezburger
http://blogs.3sharp.com/deving/archive/2009/03/17/ha z-firewall-want-cheezburger.aspx

Amit Tank | MVP: Exchange Server | MCITP: EMA | MCSA: M | http://ExchangeShare.WordPress.com http://feeds2.feedburner.com/ExchangeServerShare
 
M

Matt Dobson

When I check the prpoerties on the Outlook system try icon it says the directory connection is connected but the mail connection is " connecting" .
The " MSExchange Rpc Client Access" service is set to automatic but it is not running. When I try to start it it starts and then stops again straight away.
I have disabled the firewall on Windows 7 and Windows 2008 and this has not made a difference.
Thanks.
 
S

Srini_vas

Hi Matt Dobson,

1. Check the Registry settings are configured correctly.

2. Try to reboot the exchange server once.

3. Try to open outlook and Owa.

Regards

Srini
 
E

Evgeniy Sudyr

Hi all, I have same problem on my my configuration: Windows 2008 x64 as Domain Controller and second Exchange 2010 running on Windows 2008 x64 as Mailbox, HUB and CAS
DNS: domain have correct SRV record for autodiscover
CAS: 3rd party (GoDaddy's) SSL certificate installed and works correctly, OWA, SMTP, POP3, IMAP as well ans SSL and TLS. Outlook anywhere is enabled.
MSExchangeRPC service is enabled after I added two registry keys as described there http://social.technet.microsoft.com/Forums/en-US/exchange2010/thread/7d5cf3dc-71b6-4252-95d6-6c52e654f90d
Client: Windows XP SP3, Outlook 2007 SP1/SP2 (I tried both)
My symptoms:
When I try to configure Outlook's 2007 connection to CAS via Outlook Anywhere (or Rpc over https in other words) - I'm getting login prompt and when I input my credentials - I'm getting error message: " The action cannot be completed. The connection to Microsoft Exchange is unavailable. Outlook must be online or connected to complete this action."
Does anybody have solution for this problem already?
 
S

Shambhu Sharma

<!-- /* Font Definitions */ @font-face {font-family:SimSun; panose-1:2 1 6 0 3 1 1 1 1 1; mso-font-alt:宋体; mso-font-charset:134; mso-generic-font-family:auto; mso-font-pitch:variable; mso-font-signature:3 135135232 16 0 262145 0;} @font-face {font-family:" \@SimSun" ; panose-1:2 1 6 0 3 1 1 1 1 1; mso-font-charset:134; mso-generic-font-family:auto; mso-font-pitch:variable; mso-font-signature:3 135135232 16 0 262145 0;} /* Style Definitions */ p.MsoNormal, li.MsoNormal, div.MsoNormal {mso-style-parent:" " ; margin:0in; margin-bottom:.0001pt; mso-pagination:widow-orphan; font-size:12.0pt; font-family:" Times New Roman" ; mso-fareast-font-family:SimSun;} @page Section1 {size:8.5in 11.0in; margin:1.0in .5in .5in .75in; mso-header-margin:.5in; mso-footer-margin:.5in; mso-paper-source:0;} div.Section1 {page:Section1;} -->

Hi Evgeniy Sudyr,
Please give me below details:
1. Where did you install Windows 2008 DC and Exchange 2010 Servers. Is it on VMware OR, Hyper-V OR, Physical Server?
2. If you have installed your setup on VMware OR Hyper-V then did you use the same image file for other server? Means first you installed windows 2008 server on VMware or Hyper-V and then you use the same image (.vhd) or (.vmdk) file for other server where you installed Exchange 2010 Server.
3. If Yes, then you need to make new setup of your lab with separate installation of windows 2008 server and Exchange 2010 Server. (Do not copy the image (.vhd) or (.vmdk) file. You have to install one by one. Because on the image copy setup, servers doesn't generate the errors because of same SID of servers.
4. If you have installed your setup on Physical system OR, if you installed your setup on VMware or Hyper-v separately (no image copy) then I am sure you are getting some error events. Check those events please.
5. Make sure, there should be enough space on yours server.
6. Disable the Firewall on both server.
7. Shutdown the both server. First start DC and login in DC and then start your exchange server. When you start your exchange server, did you notice the Network connection comes as quick as you login in exchange server, OR, network connection comes late after your login?
8. Try to access the mailbox through OWA first and see the result.
9. I will suggest you install Mailbox server as stand alone because it will clear the picture of your problem and you will able to justify which services is running for respective roles (Not need but best practice.)
10. Run Exchange Best Practice Analyzer and check the result.
I hope the above steps will give you some clue and will help you solve your problem.
Regards
Shambhu
 
S

Shambhu Sharma

Hi Amit,
Tell me one thing, in above thread you written that " Public Folder doesn't work with Outlook 2007 in current public beta. These issues will be corrected in later builds..."
How did you get information that " the problem will solve in next builds..." ? Is it your assumption Or, Are you in touch with Microsoft OR, Microsoft provides you information about early release?
As of my knowledge from your blog site you work in Wipro then how can you claim that Microsoft will solve this problem in next version, beta or builds or SP?
I am Really strange about this and if you don't mind please share this information with me.
Thanks
Shambhu Sharma
 
E

Evgeniy Sudyr

Hi, thanks for answer:
1. Where did you install Windows 2008 DC and Exchange 2010 Servers. Is it on VMware OR, Hyper-V OR, Physical Server?
Both are physical servers. Fresh install for domain controller and Exchange.
2. If you have installed your setup on VMware OR Hyper-V then did you use the same image file for other server? Means first you installed windows 2008 server on VMware or Hyper-V and then you use the same image (.vhd) or (.vmdk) file for other server where you installed Exchange 2010 Server.
-
3. If Yes, then you need to make new setup of your lab with separate installation of windows 2008 server and Exchange 2010 Server. (Do not copy the image (.vhd) or (.vmdk) file. You have to install one by one. Because on the image copy setup, servers doesn't generate the errors because of same SID of servers.
-
4. If you have installed your setup on Physical system OR, if you installed your setup on VMware or Hyper-v separately (no image copy) then I am sure you are getting some error events. Check those events please.
5. Make sure, there should be enough space on yours server.
> 200 GB available on each server
6. Disable the Firewall on both server.
Disabled.
7. Shutdown the both server. First start DC and login in DC and then start your exchange server. When you start your exchange server, did you notice the Network connection comes as quick as you login in exchange server, OR, network connection comes late after your login?
sorry, but it's not clear for why this matter ?
8. Try to access the mailbox through OWA first and see the result.
OWA, SMTP, POP3, IMAP works perfect.
9. I will suggest you install Mailbox server as stand alone because it will clear the picture of your problem and you will able to justify which services is running for respective roles (Not need but best practice.)
I have no other server at the moment, but I can try ... with CAS on Hyper-V guest.
10. Run Exchange Best Practice Analyzer and check the result.
EXBPA don`t load updates (for unknown reason), otherwise I see only one warning for health test (it's exchange build version check).
I did some work around this problem with rpcping following this KB article http://support.microsoft.com/kb/831051
# Store
RpcPing -t ncacn_http -s mail.contoso.com -o RpcProxy=mail.contoso.com -P " eject,contoso.com,password1!" -I " eject,contoso.com,password1!" -H 1 -F 3 -a connect -u 10 -v 3 -e 6001 -B msstd:mail.contoso.com
Completed 1 calls in 2500 ms
0 T/S or 2500.000 ms/T
RpcPing -t ncacn_http -s mail.contoso.com -o RpcProxy=mail.contoso.com -P " eject,contoso.com,password1!" -I " eject,contoso.com,password1!" -H 1 -F 3 -a connect -u 10 -v 3 -e 6002 -B msstd:mail.contoso.com
Completed 1 calls in 2546 ms
0 T/S or 2546.000 ms/T
# DsProxy
RpcPing -t ncacn_http -s mail.contoso.com -o RpcProxy=mail.contoso.com -P " eject,contoso.com,password1!" -I " eject,contoso.com,password1!" -H 1 -F 3 -a connect -u 10 -v 3 -e 6004 -B msstd:mail.contoso.com
Exception 1722 (0x000006BA)
# End point mapper
RpcPing -t ncacn_http -s mail.contoso.com -o RpcProxy=mail.contoso.com -P " eject,contoso.com,password1!" -I " eject,contoso.com,password1!" -H 1 -F 3 -a connect -u 10 -v 3 -e 593 -B msstd:mail.contoso.com
Exception 1722 (0x000006BA)
Checked current registry settings for rpcproxy
[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Rpc\RpcProxy]
" Enabled" =dword:00000001
" ValidPorts" =" MAIL:593;MAIL:49152-65535;mail..contoso.com:593;mail.contoso.com:49152-65535"
" ValidPorts_AutoConfig_Exchange" =" mail:6001-6002;mail:6004;mail.contoso.com:6001-6002;mail.contoso.com:6004"

Btw, I remembered one important thing - during CAS installation I choosed " support for old clients" ... which enable PF... maybe this is problem ?
My problem is - mailbox cannot be resolved :(
 
E

Evgeniy Sudyr

OK, who told that we (people) do same mistakes over the years? In case if they are not well documented by vendor - case of possibility doubled :)
Solution I figured myself more than year ago during Exchange 2007 installation on Windows 2003 server, with 2008 server domain controller. I had same problem when I " unchecked" IPv6 for NIC on Domain Controller, but not disabled it in registry. In that case I just checked IPv6 and rebooted and it worked!!
But for now I have other solution and it's very easy - disable IPv6 completely on your NIC(s) or configure it (btw, I have no idea who using it).
To do this you you need 3 steps (again I recommend on both servers):
1) excute command: reg add HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Tcpip6\Parameters /v " DisabledComponents " /t REG_DWORD /d 0x 000000ff
2) Uncheck IPv6 protocol for you NIC(s)
3) reboot server
Also good idea is to add 2 records for mailserver to system's hosts and comment out ipv6 record for localhost
File C:\windows\system32\drivers\etc\hosts must looks like this:
192.168.0.2 mail
192.168.0.2 mail.contoso.com
127.0.0.1 localhost
::1 localhost
My previous posts there is this (again - 1 year old!) thread http://social.technet.microsoft.com/Forums/en-US/exchangesvrdeploy/thread/26877338-a1e4-41af-8128-7ef9e853f183
Now Outlook 2007 connects to Exchange 2010 using RPC over HTTPS proxy :)
Hope my post there will help for somebody else in future, so any thanks to me for writting there :)))
 
Status
Not open for further replies.
Top