Disable automatic failover on a DAG

Status
Not open for further replies.
A

Anatoly Ivanov

I am testing a geographically-dispersed multi-site DAG, and so far everything works... well, not fine, but very good.

However, I have run into a problem tonight.

A link between datacenters was offline for couple of minutes (well, it is a several thousand miles long cable, so things like taht may happen).

The servers in one of the datacenters had majority, and took over the databases. Everything went fine, but I would like to have more control about it.

So the question is: how do I disable automatic failover on a DAG?
 
S

Scott Schnoll

For each database you want to block automatic failover, use Suspend-MailboxDatabaseCopy with the -ActivationOnly parameter. This keeps log shipping and replay going, but blocks activation of the database.

See http://technet.microsoft.com/en-us/library/dd351074(EXCHG.140).aspx. BTW, there is a doc bug in the example on that page. The database name should be in the format of DB\Server, not Server\DB as shown in the example. See also, http://technet.microsoft.com/en-us/library/dd298159(EXCHG.140).aspx, for related info.

Hope this helps.This posting is provided " AS IS" with no warranties, and confers no rights.
 
A

Anatoly Ivanov

Thanks Scott!

That will definitely block the automatic failover, but how do I do the manual failovcer when I need it?

Move-ActiveMailboxDatabase : A server-side Active Manager operation has failed. The database action failed: An error occurred while trying to validate the specified database copy for possible activation. Error: Database copy 'Mailbox Database XXX' has been blocked from activation on server 'exmbx-XX.domain.local' by administrative action. Reason: None specified... [Database: MailboxDatabase East 1, Originating Server: exmbx-XX.domain.local]

At line:1 char:27

+ Move-ActiveMailboxDatabase <<<< " Mailbox database XXX" -ActivateOnServer:EXMBX-XX
+ CategoryInfo : InvalidOperation: (Mailbox Database East 1:ADObjectId) [Move-ActiveMailboxDatabase], AmDbActionWrapperException
+ FullyQualifiedErrorId : 163C43BB,Microsoft.Exchange.Management.SystemConfigurationTasks.MoveActiveMailboxDatabase

I understand I can remove the administartive block with Resume-MailboxDatabaseCopy, but would that work when the primary copy is failed?
 
E

Eduardo_Oscar

I have the same issue, I have looked around and found nothing regarding this problem
 
G

Grady Vogt

Too bad there is not a right click for this. They offer disable copy but not disable auto fail
 
E

eng.Mohamed Hassan

Just open exchange management shell and write this command :

Resume-MailboxDatabaseCopy -Identity 'DatabaseName\Servername'

where servername =the server which has the secondary DataBase " healthy "

this is work for me !!
 
D

DG1212

Would this be a good use of the " Datacenter Activation Coordination Mode" in Exchange 2010?
 
Status
Not open for further replies.
Top