Rules don't seem to work automatically - I must manually run them

  • Thread starter Dave Horne
  • Start date Views 16,190
Status
Not open for further replies.
D

Dave Horne

I keep receiving messages from sourceforge.net and have the Rules set to

automatically delete them. The Rule only seems to work when I run that rule

manually.

I realize this information is quite generic but was wondering if there is

general advice for me to follow first. I'm not new to computers nor to

Outlook and I'm at a loss to understand why Rules is not working as I would

expect it to.

Thanks, Dave
 
C

Christian Goeller

Dave Horne, you wrote on Sun, 10 May 2009 18:05:18 +0200:


> I keep receiving messages from sourceforge.net and have the Rules set to
> automatically delete them. The Rule only seems to work when I run that rule
> manually.



> I realize this information is quite generic but was wondering if there is
> general advice for me to follow first. I'm not new to computers nor to
> Outlook and I'm at a loss to understand why Rules is not working as I would
> expect it to.


http://www.msoutlook.info/question/133

 
V

VanguardLH

Dave Horne wrote:


> I keep receiving messages from sourceforge.net and have the Rules set to
> automatically delete them. The Rule only seems to work when I run that rule
> manually.

> I realize this information is quite generic but was wondering if there is
> general advice for me to follow first. I'm not new to computers nor to
> Outlook and I'm at a loss to understand why Rules is not working as I would
> expect it to.

> Thanks, Dave


When you run the rules manually, are you running ALL of them or just the

one rule that applies against the unwanted e-mail? If you are running

just one rule manually then it is likely that a prior rule in the list

is preventing the wanted rule from getting reached. That is, some prior

rule (with a stop-clause) is triggering first and prevents getting to

the later rule that you want exercised against the unwanted e-mail.

Enable ALL rules when running them manually and see if your particular

rule still gets exercised against the unwanted e-mail. If not, start

looking at the logic or flow through the rules prior to the one you want

to trigger.
 
D

Dave Horne

"VanguardLH" <V@nguard.LH> wrote in message

news:gu7e3h$cgi$1@news.motzarella.org...
> Dave Horne wrote:
>
> > I keep receiving messages from sourceforge.net and have the Rules set to
> > automatically delete them. The Rule only seems to work when I run that
> > rule
> > manually.
>

>> I realize this information is quite generic but was wondering if there is
> > general advice for me to follow first. I'm not new to computers nor to
> > Outlook and I'm at a loss to understand why Rules is not working as I
> > would
> > expect it to.
>

>> Thanks, Dave


> When you run the rules manually, are you running ALL of them or just the
> one rule that applies against the unwanted e-mail? If you are running
> just one rule manually then it is likely that a prior rule in the list
> is preventing the wanted rule from getting reached. That is, some prior
> rule (with a stop-clause) is triggering first and prevents getting to
> the later rule that you want exercised against the unwanted e-mail.

> Enable ALL rules when running them manually and see if your particular
> rule still gets exercised against the unwanted e-mail. If not, start
> looking at the logic or flow through the rules prior to the one you want
> to trigger.


I tried all the suggestions given but still have the same problem. I

deleted _all_ the rules and everythign related to them and then just added

one rule. That rule only works when I apply it manually.

Is there a file I can delete that contains all the 'rules' so I can start

from scratch? This 'problem' isn't a big deal but I am at a loss to

understand why Rules is not worling as it should.

Thanks, Dave Horne
 

Brian Tillman

Senior Member
"Dave Horne" <davehorne@home.nl> wrote in message

news:%23WePMKN1JHA.1096@TK2MSFTNGP06.phx.gbl...


> Is there a file I can delete that contains all the 'rules' so I can start
> from scratch? This 'problem' isn't a big deal but I am at a loss to
> understand why Rules is not worling as it should.


No file, but you can start Outlook once with the /cleanrules command switch to

clear out all rules.

--
 
D

Dave Horne

"Brian Tillman " <tillman1952@yahoo.com> wrote in message

news:OVvflWV1JHA.3524@TK2MSFTNGP03.phx.gbl...
> "Dave Horne" <davehorne@home.nl> wrote in message
> news:%23WePMKN1JHA.1096@TK2MSFTNGP06.phx.gbl...
>
> > Is there a file I can delete that contains all the 'rules' so I can start
> > from scratch? This 'problem' isn't a big deal but I am at a loss to
> > understand why Rules is not worling as it should.


> No file, but you can start Outlook once with the /cleanrules command
> switch to clear out all rules.
> >


Brian, thanks. I ran that switch, closed Outlook, restarted it with no

switches and then added one rule.

The 'Review Rule Description' is as follows:

Apply this rule after the message arrives

from davehorne@users.sourceforge.net

delete it

I won't know if this works until I receive yet another piece of unwanted

mail from sourceforge.net.

I'll be back to report whether this rule worked or not. Thanks again, Dave

Horne
 
D

Dave Horne

"Brian Tillman " <tillman1952@yahoo.com> wrote in message

news:OVvflWV1JHA.3524@TK2MSFTNGP03.phx.gbl...
> "Dave Horne" <davehorne@home.nl> wrote in message
> news:%23WePMKN1JHA.1096@TK2MSFTNGP06.phx.gbl...
>
> > Is there a file I can delete that contains all the 'rules' so I can start
> > from scratch? This 'problem' isn't a big deal but I am at a loss to
> > understand why Rules is not worling as it should.


> No file, but you can start Outlook once with the /cleanrules command
> switch to clear out all rules.
> >


My problem still exists. Rules does not delete e-mail automatically though

it does work if I use it manually.

I am still open to suggestions. Thanks, Dave Horne
 

Brian Tillman

Senior Member
"Dave Horne" <davehorne@home.nl> wrote in message

news:%23u5DmWY1JHA.6004@TK2MSFTNGP02.phx.gbl...


> My problem still exists. Rules does not delete e-mail automatically though
> it does work if I use it manually.


Try using the condition "with specific words in the sender's address" and make

those specific words "sourceforge.net", instead of the "from people or

distribution list" condition. If you have more than one rule, also add the

"stop proccessing more rules" action.

--
 
D

Dave Horne

"Brian Tillman " <tillman1952@yahoo.com> wrote in message

news:eRBY87Y1JHA.5684@TK2MSFTNGP04.phx.gbl...
> "Dave Horne" <davehorne@home.nl> wrote in message
> news:%23u5DmWY1JHA.6004@TK2MSFTNGP02.phx.gbl...
>
> > My problem still exists. Rules does not delete e-mail automatically
> > though it does work if I use it manually.


> Try using the condition "with specific words in the sender's address" and
> make those specific words "sourceforge.net", instead of the "from people
> or distribution list" condition. If you have more than one rule, also add
> the "stop proccessing more rules" action.
> >


Brian, I've tried what you suggested and the only way to get Rules to work

is if I invoke Rules manually.

Is it possible (and I'll enclose the message routing if you wish) that what

I see as 'From' and 'To' is not what Rules sees?

Thanks, Dave Horne
 

Brian Tillman

Senior Member
"Dave Horne" <davehorne@home.nl> wrote in message

news:u6JC7AH2JHA.4412@TK2MSFTNGP06.phx.gbl...


> Is it possible (and I'll enclose the message routing if you wish) that what
> I see as 'From' and 'To' is not what Rules sees?


It's very possible. That's why I saoid to use the condition I mentioned

rather than the "from people or distribution list" condition. If the "with

specific words in the sender's address" doesn't work, then try "with specific

words in the message header".

--
 
D

Dave Horne

"Brian Tillman " <tillman1952@yahoo.com> wrote in message

news:OjL%23rWH2JHA.1424@TK2MSFTNGP02.phx.gbl...
> "Dave Horne" <davehorne@home.nl> wrote in message
> news:u6JC7AH2JHA.4412@TK2MSFTNGP06.phx.gbl...
>
> > Is it possible (and I'll enclose the message routing if you wish) that
> > what I see as 'From' and 'To' is not what Rules sees?


> It's very possible. That's why I saoid to use the condition I mentioned
> rather than the "from people or distribution list" condition. If the
> "with specific words in the sender's address" doesn't work, then try "with
> specific words in the message header".
> >


Brian, I've already tried that and the same thing happens - Rules only work

manually, not automatically.

I've also Googled this general problem and see that there are others with

the same problem. I am still open to suggestions.

Thanks, Dave Horne
 

Brian Tillman

Senior Member
"Dave Horne" <davehorne@home.nl> wrote in message

news:uN0GlhI2JHA.1096@TK2MSFTNGP06.phx.gbl...


> Brian, I've already tried that and the same thing happens - Rules only work
> manually, not automatically.


Does the behavior change if run in Outlook's safe mode?

--
 
D

Dave Horne

"Brian Tillman " <tillman1952@yahoo.com> wrote in message

news:eDgWGXL2JHA.3988@TK2MSFTNGP05.phx.gbl...
> "Dave Horne" <davehorne@home.nl> wrote in message
> news:uN0GlhI2JHA.1096@TK2MSFTNGP06.phx.gbl...
>
> > Brian, I've already tried that and the same thing happens - Rules only
> > work manually, not automatically.


> Does the behavior change if run in Outlook's safe mode?
> >


__________________________________

Brian, first, thanks again for your patience with this.

I started Outlook 2007 in Safemode (using Outlook Tools 2.2) and choosing

the topmost 'safe' startup switch. (Starts Outlook without Microsoft

Exchange Server Client Extensions (ECE), the Reading Pane, or toolbar

customizations. Component Object Model (COM) add-ins are turned off.)

Again, Rules would only delete the message if I invoked Rules manually; it

doesn't delete the message in question automatically.

I will include the message routing in question below. Also, the rule for

this message which only works manually is:

Apply this rule after the message arrives

with sourceforge.net in the message header

delete it

__________________________________

X-MSKTag: [SPAM]

X-MSK: CML=10.000000

Return-path: <Kristyn-justizko@wilkins.id.au
Received: from smtp4.gn.mail.iss.as9143.net ([212.54.34.135])

by mta1z1.gn.mail.iss.as9143.net

(Sun Java(tm) System Messaging Server 6.3-7.04 (built Sep 26 2008; 32bit))

with ESMTP id <0KJW001G9HAR5D00@mta1z1.gn.mail.iss.as9143.net> for

davehorne@home.nl; Tue, 19 May 2009 18:47:15 +0200 (CEST)

Received: from mx5.gn.mail.iss.as9143.net ([212.54.34.104])

by smtp4.gn.mail.iss.as9143.net with esmtp (Exim 4.69)

(envelope-from <Kristyn-justizko@wilkins.id.au>)

id 1M6ST2-0002G3-5u for davehorne@home.nl; Tue, 19 May 2009 18:47:04 +0200

Received: from mx.sourceforge.net ([216.34.181.68])

by mx5.gn.mail.iss.as9143.net with esmtp (Exim 4.69)

(envelope-from <Kristyn-justizko@wilkins.id.au>)

id 1M6ST0-0006Uy-GX for davehorne@home.nl; Tue, 19 May 2009 18:47:02 +0200

Received: from [124.53.7.20] by 1b2kzd1.ch3.sourceforge.com with esmtp

(Exim 4.69) id 1M6SSo-0007tu-Se for davehorne@users.sourceforge.net; Tue,

19 May 2009 16:47:00 +0000

Date: Tue, 19 May 2009 18:47:15 +0200 (CEST)

Date-warning: Date header was inserted by mta1z1.gn.mail.iss.as9143.net

From: Kristyn <Kristyn-justizko@wilkins.id.au
Subject: [SPAM]{Spam?} [SPAM] It's your enemy writing

To: davehorne@users.sourceforge.net

Message-id: <1977176.C546105C8FD258250@[124.53.7.20]
MIME-version: 1.0

Content-type: text/html; charset=iso-8859-1

Content-transfer-encoding: 7bit

X-ACL-Warn:

X-Spam-Score: 15.5 (+++++++++++++++)

X-Spam-Report: Spam Filtering performed by mx.sourceforge.net. See

http://spamassassin.org/tag/ for more details. 0.5 URIBL_WS_SURBL Contains

an

URL listed in the WS SURBL blocklist [URIs: lofecid.ru] 2.0 URIBL_BLACK

Contains an URL listed in the URIBL blacklist [URIs: lofecid.ru] 0.0

MISSING_DATE Missing Date: header 0.5 RCVD_IN_PBL RBL:

Received via a relay in Spamhaus PBL [124.53.7.20 listed in

zen.spamhaus.org]

2.9 RCVD_IN_XBL RBL: Received via a relay in Spamhaus XBL 2.5

RCVD_IN_BL_SPAMCOP_NET RBL: Received via a relay in bl.spamcop.net

[Blocked -

see <http://www.spamcop.net/bl.shtml?124.53.7.20>] 1.3 HTML_IMAGE_ONLY_32

BODY: HTML: images with 2800-3200 bytes of words 0.2 HTML_IMAGE_RATIO_04

BODY: HTML has a low ratio of text to image area 0.0 HTML_MESSAGE

BODY: HTML included in message 1.7 MIME_HTML_ONLY BODY: Message only

has

text/html MIME parts 1.5 RAZOR2_CF_RANGE_E8_51_100 Razor2 gives engine 8

confidence level above 50% [cf: 100] 2.0 RAZOR2_CHECK Listed in

Razor2 (http://razor.sf.net/) 0.5 RAZOR2_CF_RANGE_51_100 Razor2 gives

confidence level above 50% [cf: 100]

X-VA-Spam-Flag: YES

X-Headers-End: 1M6SSo-0007tu-Se

X-MailScanner-ID: 1M6ST0-0006Uy-GX

X-ZiggoMX-MailScanner: Found to be clean

X-ZiggoMX-MailScanner-SpamCheck: not spam

X-ZiggoMX-MailScanner-From: kristyn-justizko@wilkins.id.au

X-ZiggoSMTP-MailScanner-Information: Please contact the ISP for more

information

X-ZiggoSMTP-MailScanner-ID: 1M6ST2-0002G3-5u

X-ZiggoSMTP-MailScanner: Found to be clean

X-ZiggoSMTP-MailScanner-SpamCheck: spam, SpamAssassin (not cached,

score=8.427,

required 5, BAYES_99 3.50, HTML_IMAGE_ONLY_32 1.05, HTML_IMAGE_RATIO_04

0.17,

HTML_MESSAGE 0.00, MIME_HTML_ONLY 0.00, MISSING_DATE 0.00,

RCVD_IN_BL_SPAMCOP_NET 2.70, RCVD_IN_JMF_W -4.00, RCVD_IN_SORBS_SPAM 2.00,

URIBL_PROLO 3.00)

X-ZiggoSMTP-MailScanner-SpamScore: ssssssss

X-ZiggoSMTP-MailScanner-From: kristyn-justizko@wilkins.id.au

X-Spam-Flag: YES

Original-recipient: rfc822;davehorne@home.nl

X-Spam-Status: No
 

Brian Tillman

Senior Member
"Dave Horne" <davehorne@home.nl> wrote in message

news:ufMx8PS2JHA.4880@TK2MSFTNGP03.phx.gbl...


> Again, Rules would only delete the message if I invoked Rules manually; it
> doesn't delete the message in question automatically.

> I will include the message routing in question below. Also, the rule for
> this message which only works manually is:

> Apply this rule after the message arrives
> with sourceforge.net in the message header
> delete it


Is this your only rule?

--
 
D

Dave Horne

"Brian Tillman " <tillman1952@yahoo.com> wrote in message

news:OjaaJCU2JHA.3304@TK2MSFTNGP06.phx.gbl...
> "Dave Horne" <davehorne@home.nl> wrote in message
> news:ufMx8PS2JHA.4880@TK2MSFTNGP03.phx.gbl...
>
> > Again, Rules would only delete the message if I invoked Rules manually;
> > it doesn't delete the message in question automatically.
>

>> I will include the message routing in question below. Also, the rule for
> > this message which only works manually is:
>

>> Apply this rule after the message arrives
> > with sourceforge.net in the message header
> > delete it


> Is this your only rule?
> >


Yes.
 
D

Dave Horne

"Brian Tillman " <tillman1952@yahoo.com> wrote in message

news:eagxkiW2JHA.1380@TK2MSFTNGP05.phx.gbl...
> "Dave Horne" <davehorne@home.nl> wrote in message
> news:e9KbMNU2JHA.1716@TK2MSFTNGP03.phx.gbl...
>
> > Yes.


> I'm stumped. Sorry.
> >


I am also stumped. Thanks for your suggestions just the same.

Dave Horne
 
D

Dave Horne

"Brian Tillman " <tillman1952@yahoo.com> wrote in message

news:eagxkiW2JHA.1380@TK2MSFTNGP05.phx.gbl...
> "Dave Horne" <davehorne@home.nl> wrote in message
> news:e9KbMNU2JHA.1716@TK2MSFTNGP03.phx.gbl...
>
> > Yes.


> I'm stumped. Sorry.
> >


Brian, I just got back from a short vacation and see _now_ that Rules (re

sourceforge.net) is in fact working. I did a little google research re this

problem and it seems (at least in my case) that the added step of clicking

on the top most option - Sent to People or Distribution list did the trick

(including myself, of course). Just clicking on 'specific words' in the

subject, body, etc. didn\t work; it seems that I first had to include

'myself' in the list of conditions.

Problem solved .... and I thank you for your input.

All the best, Dave Horne
 
D

Dave Horne

"Brian Tillman " <tillman1952@yahoo.com> wrote in message

news:eagxkiW2JHA.1380@TK2MSFTNGP05.phx.gbl...
> "Dave Horne" <davehorne@home.nl> wrote in message
> news:e9KbMNU2JHA.1716@TK2MSFTNGP03.phx.gbl...
>
> > Yes.


> I'm stumped. Sorry.
> >


> ... a correction to my previous post. The 'Sent To' option is not the

topmost option when creating a new rule from scratch. I looked at the now

successful sourceforge.net rule and saw the 'Sent to' option as the topmost.

At any rate, adding myself to the Rule did the trick as I wrote in my

previous post. DH
 

Brian Tillman

Senior Member
"Dave Horne" <davehorne@home.nl> wrote in message

news:%23d4$%236H3JHA.1420@TK2MSFTNGP04.phx.gbl...


> At any rate, adding myself to the Rule did the trick as I wrote in my
> previous post. DH


I'm glad it's working, although it should have worked before without adding

yourself as the recipient.

--
 
Status
Not open for further replies.

Top