Remove Exchange 2010 Server with CAS, HUB, and MB Roles

Status
Not open for further replies.
L

lnxguy

I currently have an Exchange 2003 server running with an ISA 2006 SP1 being used for OWA authentication. I prepped AD and installed an Exchange 2010 Enterprise server with CAS/HUB/MB roles and all seemed to have gone smoothly. Now I am having issues with the machine and need to uninstall it from my network. Thankfully it is not in production yet.

How do I uninstall all of the roles and the system from my network and reinstall everything gracefully without affecting my current 2003 mailboxes? I have a few 2010 mailboxes that I have been testing with and they can be removed.

TIA,

Troy Lawson
 
A

Amit Tank [MVP]

Supported way to uninstall Exchange server is to remove from Programs and Features of Control Panel.

Modify or Remove Exchange 2010
http://technet.microsoft.com/en-us/library/ee332361.aspx

Basically you need to move the mailboxes and Public Folders from 2010 to 2003, and also delete arbitration mailboxes before going to uninstall..

You can get arbitration mailboxes id with below cmdlet and remove with next one...

Get-Mailbox –Database “E-DB01” –arbitration | ft –wrap –auto

Get-Mailbox –Database “E-DB01” –arbitration | Remove-Mailbox -Arbitration -RemoveLastArbitrationMailboxAllowed

Amit Tank
MVP: Exchange Server | MCTS: Microsoft Exchange Server 2010, Configuration | MCITP: EMA | MCSA: M
Blog: http://ExchangeShare.WordPress.com | User Group: http:/MUC-UG.org.in
 
L

lnxguy

Thanks Amit,

Two additional questions.

1. Do I need to delete the Discovery Search Mailbox prior to uninstalling the server?

2. Should I remove the receive connectors that were created on initial installation before uninstalling the server? If so, should I delete them from the ESM on Ex2003 or the EMC on the Ex2010 server?

Troy
 
A

Amit Tank [MVP]

1. Yes, forgot discovery mailbox.

2. If you have internet mailflow configured through Exchange 2010 then you need to re-configure it to flow mails through Exchange 2003 server.

Routing Group Connector between 2003-2010 can be configured through EMS only. Send/Receive connector can be configured through EMS or EMC so you can't configure connectors through Exchange 2003 ESM. Exchange uninstall process takes care of server removal from all these connectors so no need of doing it manually and if something goes wrong then later you can just install (or keep installed) Exchange 2010 Management Tools to modify them...

Amit Tank
MVP: Exchange Server | MCTS: Microsoft Exchange Server 2010, Configuration | MCITP: EMA | MCSA: M
Blog: http://ExchangeShare.WordPress.com | User Group: http:/MUC-UG.org.in
 
L

lnxguy

Amit,

I was able to successfully delete the arbitration mailboxes as well as the discovery mailbox. However I am unable to uninstall the server due to the following error for the Mailbox server:

Mailbox Role Prerequisites

Failed

Error:

Uninstall cannot continue. Database 'Public Folder Database 0345919967': Public folder database " Public Folder Database 0345919967" is the default public folder database for the following mailbox database(s):

Mailbox Database 0788465309

> Before deleting the public folder database, assign a new default public folder database to the mailbox database(s).

Recommended Action: http://go.microsoft.com/fwlink/?linkid=30939&l=en&v=ExBPA.4&id=b6e3b32a-8848-46cb-9567-72288ac15f60

I have tried to delete the 'Public Folder Database 0345919967' (The original public folder db), but it cannot be deleted as it is the only PF db on the server. In the Ex2003 Folders properties in the ESM on the Exchange 2003 server, the 'Public Folder Database 0345919967' shows up as a Public Folder associated to the folder tree. Being the last/only Exchange 2010 server that I need to remove, I have no server to move it to. How can I get around this and clean up Exchange 2010 so I can get rid of it? I have looked at a number of technet articles on how to do this but none of the solutions work.

Also, I have removed the 2 connectors via the ESM on the Exchange 2003 server as there was an error that said they must be removed prior to uninstalling the Hub Server. After doing so, I come up with the following message:

Hub Transport Role Prerequisites

Completed

Warning:

There are 2 messages waiting in the 'knights\Unreachable' queue. Proceeding with the removal of the server role may result in data loss.

Hopefully this is nothing to worry about as the server is being decommissioned and rebuilt.

One thing that we did have happen between the original building of the server and the attempted removal is that our main Win2k3 DC failed and has been replaced with a virtual Windows 2008 DC. This required me to change the Configuration Domain Controller on the Organization Configuration and as well as the Recipient Scope to View all recipients in forest, check the GC box, and find the new Win2k8 DC so that it could read the configuration information. The temporary DC will be changed over to a physical box after the new year.

TIA,

Troy Lawson
 
T

theJonson

I'm trying to do the exact same thing as you, I know I need to move the public folder replicas back to the Exchange 2003 server, but I can see the 2010 public folder store in the Exchange System Manager on the 2003 server, how are you able to view it?
 
Status
Not open for further replies.
Top