Exchange 2010 rollup 3 and Outlook 2007 sp2 Can't save attachments

  • Thread starter Fabian Castagna
  • Start date Views 2,806
F

Fabian Castagna

Issue with the SAVE ATTACHMENTS button/option in outlook not working, click the button and does absolutely nothing, NO POPup or anything.

When a user sends an email with attachment in or out of the network (external) when you click save attachments it does nothing, then externally if you then forward it to someone else it works again.

Works perfectly fine internally.

Windows XPsp3, Office 2007sp2, Windows 2008r2, Exchange2010rollup3 ALL updates and patches possible. Have bypass Mail filters and everything else..STILL NO GO!!

I have searched far and wide for the answer to this issue to no avail. Lots of other people have seen this and reported it but no Answer other then install Office 2010 (which does work) but thats not the answer, thats a cheaters way out.

Need to resolve this not just for my customer, but future customers and othe IT peoples
 
W

wfejessie

Found a work around for Outlook 2003 (have not tested other versions): Select all attachments (Ctrl+A), Copy (Ctrl+C), navigate to your destination folder, Paste (Ctrl+V). Don't know why I didn't think of it sooner!
 
A

- Andrea Gallazzi -

@ Fabian

I have the same issue.

Exchange 2010, Outlook 2007, Win 7. Outlook 2003, Win XP.

The issue occurs only on some mailboxes.

I have some question for you:
1. Does the issue occur to all Outlook users?
2. Does the issue occur in OWA?
3. Does the issue occur to any attachments?
4. With " click the button and does absolutely nothing" , do you mean nothing happens when right click on the attachment in an email?
5. Does the issue occur if you run the Outlook in safe mode?
Andrea Gallazzi
http://andreagx.blogspot.com
 
A

- Andrea Gallazzi -

update 2:

From MSFT support:

There is a known issue with Exchange 2010 mailbox that Outlook is unable to save all attachments. The attachments are not listed properly. However, users are still able to save individual attachment. I want to confirm whether you are encountering the same issue. If this is the case, a KB is going to be released about this issue. The workaround is to save the attachment individually. Sorry for the inconvenience.

As the behavior is just as I described, it is the known issue in Exchange 2010 and is considered a designed behavior. A KB 980940 is written for it and will soon be published. The details of the issue is:
When users receive a MIME message from the Internet with attachments, Exchange 2010 Content Conversion sets Content-Id on all attachments, thus making them inline for Outlook. So Outlook is unable to list these attachments in " save attachments" command. That is why it doesn't work if we save attachments using the following methods:
1. Click File (menu) -> Save Attachments.
2. Open the mail, and go to the Office button | Save As | Save Attachments.
To workaround the issue, we have to save the attachment individually. Sorry for the inconvenience.
Andrea Gallazzi
http://andreagx.blogspot.com
 
F

Fabian Castagna

1. Yes it does happen for all users

2. Haven't tried via OWA

3. yes it happens to any attachment that is router externally (meaning sent out of or into exchange form elsewhere Gmail, Other exchange servers etc

4. I mean when you click on file save attachements or the quick launch bar save attachment button

5. Yes it does occur in safe mode
 
J

JanBoris

update 2:

From MSFT support:

There is a known issue with Exchange 2010 mailbox that Outlook is unable to save all attachments. The attachments are not listed properly. However, users are still able to save individual attachment. I want to confirm whether you are encountering the same issue. If this is the case, a KB is going to be released about this issue. The workaround is to save the attachment individually. Sorry for the inconvenience.

As the behavior is just as I described, it is the known issue in Exchange 2010 and is considered a designed behavior. A KB 980940 is written for it and will soon be published. The details of the issue is:
When users receive a MIME message from the Internet with attachments, Exchange 2010 Content Conversion sets Content-Id on all attachments, thus making them inline for Outlook. So Outlook is unable to list these attachments in " save attachments" command. That is why it doesn't work if we save attachments using the following methods:
1. Click File (menu) -> Save Attachments.
2. Open the mail, and go to the Office button | Save As | Save Attachments.
To workaround the issue, we have to save the attachment individually. Sorry for the inconvenience.
Andrea Gallazzi
http://andreagx.blogspot.com
I can confirm, i have the same problem. Is the KB released?
 
A

- Andrea Gallazzi -

Hello Trikno,

Outlook team is working on the issue to change the behavior from Outlook side. Thus, when Content-Id are set on the attachments, the same issue will not occur.

Currently, Outlook 2003/2007 only checks if PR_ATTACH_CONTENT_ID is present to decide if the attachments is suspect and hide it from the user (in the save all attach dialog). Outlook team would change this behavior so that Outlook looks for PR_ATTACH_CONTENT_LOCATION as well, and maybe check if R_ATTACHMENT_HIDDEN== true too.

With this Outlook design change, you will no longer have the same issue in Exchange 2010 environment.

Andrea Gallazzi
http://www.andreagallazzi.com
This posting is provided " AS IS" with no warranties, and confers no rights.
 
S

slammers25

the workaround for us has been to right click on each attachment in the message and select Save. that works every time.
 
T

Tigelaar

We have the same problem with a Exchange 2010 Office 2007 configuration.
Customer uses a plugin to upload attachments in to an other application.
This plugin does not recognise teh attachments
Works fine with a Exchange 2007 server.

We opend a call with Microsoft in August, but Microsoft dit no have a solution that moment.
We were told a solution will be available for Office 2007 with the release of SP3, but no release date was given.
Any news on this date or the KB article?!

Wout
 
A

- Andrea Gallazzi -

Hi All,

The only news or workaround that I have is using OWA SP1.

Now in OWA SP1 has been added the feature " save all attachments" .

Andrea Gallazzi
http://www.andreagallazzi.com
This posting is provided " AS IS" with no warranties, and confers no rights.
 
D

dstones

Any update's on a hotfix or Office 2007 SP3?? How annoyingly inconvenient this is.
 
T

Tigelaar

We are also waiting for a solution.
Any news on the Service pack 3 for Office 2007?

We are working on a workaround for our customer (Resource Forest Exchange 2007) so the clients can connect to a Exchange 2007 mailbox.
But if a solution is on its way, it could save us a lot of time and €.

Wout Tigelaar Sr. Systems Engineer
 
D

dstones

Only respectable workaround I have come across is:

Right click on an attachment, click select all. Right-click on attachment again and click Save as. This will bring up a location to save all the attachments in that e-mail to.

- Alternatively, to select all: Left-click in the attachment area, you can press ctrl+a to “select all” and then proceed with right-clicking and clicking save as.

Not the most convenient method, but at least allows you to save multiple attachments at once. Hope this helps your situation.

Dstones
 
Top