2003 to 2010 upgrade issues with smarthost

Status
Not open for further replies.
J

jason_OSINS



Hello,

We are in the process of upgrading from Exchange 2003 to 2010. Most things have gone very well, but the Exchange 2003 server is not routing email to the Exchange 2010 server and I believe this is because a smarthost is configured on the 2003 box.

When I send an email from a 2010 user the 2003 user received the email. When I reply to the email, message tracking indicates that the message is first being sent to the journaling mailbox and then out to the MXLogic smarthost. On the 2003 box there is only the default SMTP Virtual Server and it is configured to send all mail out to the smarthost - is this the issue? I suspect it is, but in the interim how do I configure 2003 to first use the routing group connectors and then send to the external smart host?

Thanks for any help you can offer.
 
S

Shafaquat Ali



Hi Jason ,

Have you make the receive connector on your ex 2010 box also the routing group between 2003 and 2010 I think you should delete them and reconfigure them again with the help of this.

Please delete RGC between Exchange 2003 and 2010 and recreate it using the New-Routinggroupconnector command:

New-RoutingGroupConnector -Name "2010-2003" -SourceTransportServers "Ex2010.contoso.com" -TargetTransportServers "Ex2003.contoso.com" -Cost 1 -Bidirectional $false -PublicFolderReferralsEnabled $true
and

New-RoutingGroupConnector -Name "2010-2003" -SourceTransportServers "Ex2003.contoso.com" -TargetTransportServers "Ex2010.contoso.com" -Cost 1 -Bidirectional $false -PublicFolderReferralsEnabled $true

Please check the results running below cmdlet:
Get-RoutingGroupConnector| FL

Please also run NSlookup on the 2010 server to check the MX records

Under properties of Default SMTP Virtual Server in exchange 2003, Access Tab > Communication button > turn off "Require secure channel"

If the problem still appears, please run the exchange best practices analyzer on 2k10 to check the mail flow.

Regards.

Shafaquat Ali.

M.C.I.T.P Exchange 2007/2010, M.C.I.T.P Windows Server 2008, M.C.T.S OCS Server 2007 R2
 
T

TWHarrington



Is your smarthost configured in the Virtual Default Server for SMTP (Delivery Tab -> Advanced button) or do you have a SMTP connector for outbound email defined under the Connectors node? My assumption is that you don't have a specific outbound connector defined and are just using the default virtual server for smtp. If this is the case you will need to remove the smarthost from that and create a outbound connector for SMTP flow to your smarthost. Right now all of your email is flowing through that default virtual server and delivering to your smarthost. If you are migrating to 2010 anyway, you can just create this in the 2010 server since you will have to move it over anyway. But you will still have to take the smarthost out of your default virtual server for smtp.

Link for 2010 Send Connectors: http://technet.microsoft.com/en-us/library/aa997285.aspx

 
Status
Not open for further replies.
Top