Outlook 2003 or 2007/Exchange 2007 OAB Sync Issue

Status
Not open for further replies.
R

Ricardo Linares



I resently installed Exchange 2007.  This is one of the few problems I have left to resolve for this server.  I keep getting this error for all my clients whether they are running Outlook 2003 or 2007.  It keep erroring when it trys to sync the OAB.

10:08:20 Microsoft Exchange offline address book

10:08:20                0X80190193

If anymore information is needed, I will gladly offer any info. 
 
D

djwells



Hi, im having the same problem with an Outlook 2007 client connecting to Exchange 2007 Server.

Have you tried rebuild the OAB on the server?
 
R

Ricardo Linares

I tried to creat a new OAB.  I also upgraded the address lists and the GAL.  Still errors out.
 
N

Nathan Winters [MVP]



Hi,

Right, I think I have this fixed!

Basically it would appear this is down to authentication.

Are you publishing this with ISA?

I am, and found that the ISA server is setup to use basic auth. I therefore checked the OAB Vdir and found it wasn't set for Basic Auth.

Once I set this, I could then sync the OAB externally.

On top of this I also setup basic auth on the EWS vdir which enabled me to set my Out Of Office externaly too!

Hope this helps

Cheers

Nathan

 
 
C

code_blue



Hi,

I tried your solution, but it didn't work. which is probably because the problem is related to Public Folders more than OWA.

Which by the way was not created by the setup. I actually had to create the Public Folder manually and then assign the OAB to it for distribution.

And still I get the same error on all my outlook 2007 clients.

code_blue
 
P

PTechS



Hi,

From my understanding the OAB is mainly used when your Outlook is Cached Mode and also through OWA.

There are two things that I did to resolve this issue for me; Use the Exchange Management Console to check the following:

1. Organization Configuration > Mailbox > Offline Address Book Tab. (Check to make sure this is present and the distribution includes Public Folders; Web-based)

2. Server Configuration > Mailbox > Database Managment Tab ( If you right click the Mailbox Database and select properties it will display 3 tabs; select Client Settings and check the Offline address book is filled in. If it is not then click browse and select your offline address book.

All of the above fixed the SYNC error Outlook clients were getting. After performing the above your Outlook clients will need to close and re-open to download a fresh copy of the OAB.

Cheers 
 
R

Robert1162



I have recently installed a new Exchange_07 single box for a client that was using Pop3 and their ISP and had these same problems. After trying numerous things found online I noticed that I had a few people without errors. Their Outlook was in UniCode mode while those with errors were not.

I created a new Profile and Outlook came up in Unicode mode -> no more errors.

It's worth a check.

Robert

 

 
 
A

apalmer



Had the same problem recently, you need to attach the mailbox store to an address list through the wizard, by default i don't think it does this!

Look at the properties of the mailbox store and point it at the "Default Address List"

Hope this helps it worked for me!
 
M

Morgan Simonsen



Hi folks

I had this error recently at one of my customers. They are running a native Outlook/Exchange 2007 setup. No Exchange 2003 or Outlook 2003 server/clients, although we do have public folders as we are migrating from Domino. The OAB is distributed by Web and Public Folder.

I started noticing the 0X80190193 error in the Sync Issues folder on the clients. I trid to connect to the OAB virtual directory manually using the Internal URL specified for the OAB virtual directory in EMC. That resulten in an HTTP 400 Bad Request error. After looking at the IIS config I discovered that I had entered a host header vaule for the Deafult Web Site. It was set to the external FQDN we use for OWA, EAS etc. So when a client tried to contact the CAS server hosting the OAB folder using the value from the Internal URL speficied in EMC (obtained by the client through the Autodiscovery service) IIS would not accept that name because of the host header, and return an HTTP 400 Bad request error. So in my case it was a mismatch between the host header and the Internal URL specified in EMC. I had apparently set the host header to test something, it is not required for proper operation of E2K7. Once a website is set up with a host header, port and IP it will not accept connections with another name in the HTTP GET request, to that same IP and port.

I realize that this solution might not helt a lot of people, but I include it here on the off-chance that it might help someone.

Good luck!

Best regards

Morgan

 
 
R

Raptor316

We had a similar issue, however it was caused by the OAB virtual directory requiring SSL.  On your exchange server verify under IIS that the OAB virtual directory does not have the SSL required checked, if it does uncheck it and restart the web site. 
 
M

MJLouwrens



Thanks Raptor316

MY OAB was set to use SSL. turning it off fixed the problem.
 
B

Brunediddy



Yep Same problem here... OAB virtual directory was set to use SSL, wierd how it randomly got turned on.

Disabled SSL and it worked liek a charm.

 
 
W

worldzfree

 

MJLouwrens said:

Thanks Raptor316

MY OAB was set to use SSL. turning it off fixed the problem.

SSL will not work with self-signed certs.  If you have a fully trusted cert installed you can use SSL.

"The OAB Virtual Directory supports direct connection as well as connections through ISA server. However, the BITS client does not support self-signed certificates so by default, OAB distribution points are created to use HTTP. You can enable SSL support if you provide a fully trusted certificate in IIS." ---source http://msexchangeteam.com/archive/2006/11/15/431502.aspx
 
S

Specialized1974



There a few causes and solutions for this in Exchange 2007 .
1. There are two ways of distributing the OAB, you can do it through web access and or through public folders. Web distibution is what causes the error internally unless you do one of the following solutions below. In theroy you should be able to do both and if one fails the next option kicks in. However I havent got that to work. Public folders distribution does not require SSL or web page and thus no error. If this error is new for your company than you probably use this method of delivery and for some reason have tried to enable web deliver. Simply uncheck the web delivery method to resolve. Takes about 15 min to change.

2.Is as mentioned in this thread SSL can be disabled on the OAB virtual directory. I do not recommend this especially if you use the same virtual OAB directory for external or OWA access.

3. you could change the Internal OAB URL to an https:// address. You may run into SSL certificate prompts and would need to create a proper certificate to resolve.
 
Status
Not open for further replies.
Top