SBS SSL Certificate Nightmares!

Status
Not open for further replies.
H

hinkdad



I have installed SBS 2008 and with all of my Outlook 2007 clients the Out of Office assistant will not work. I am using a Godaddy 3rd party certificate. When you try to launch out of office assistant within Outlook you get an error of "server is offline or unavailable". I can log into webmail and set the OOO assistant however. I beleive it is a certificate issue, but cannot find how to fix it.

I have created an "A" record pointing autodiscover to the IP of the server but when I launch Outlook I receive two certificate errors. One for the url of webmail and one for autodiscover. Upon examining the certificates on these errors it is using a self signed certificate instead of the Godaddy 3rd party cert. If I look in IIS the "SBS Web Applications" directory has the right certificate set under it's bindings but it appears the virtual directories under this section are still using the servers self signed cert.

 
E

Ed Crowley [MVP]



In Exchange Management Shell enter "Get-ExchangeCertificate | fl" to verify which certificate is assigned to which service. You can use Enable-ExchangeCertificate with the appropriate thumbprint to assign the Go Daddy certificate to the services you want it it used for, which would be "-Services IIS" in your case.

--

Ed Crowley MVP
"There are seldom good technological solutions to behavioral problems."
..



"hinkdad" wrote in message news:690bb1d5-249c-4fcb-a4a5-d37466258a17...

I have installed SBS 2008 and with all of my Outlook 2007 clients the Out of Office assistant will not work. I am using a Godaddy 3rd party certificate. When you try to launch out of office assistant within Outlook you get an error of "server is offline or unavailable". I can log into webmail and set the OOO assistant however. I beleive it is a certificate issue, but cannot find how to fix it.

I have created an "A" record pointing autodiscover to the IP of the server but when I launch Outlook I receive two certificate errors. One for the url of webmail and one for autodiscover. Upon examining the certificates on these errors it is using a self signed certificate instead of the Godaddy 3rd party cert. If I look in IIS the "SBS Web Applications" directory has the right certificate set under it's bindings but it appears the virtual directories under this section are still using the servers self signed cert.

Ed Crowley MVP "There are seldom good technological solutions to behavioral problems."
 
Status
Not open for further replies.
Top