Exchange and Multi-Site AD

Status
Not open for further replies.
G

Gekko_uk



Hello All,

I am looking for a litte advice.

I have 3 sites at the moment.

Site 1 - Head Office

2 x Server 2008 R2 DC's (DHCP, DNS, AD role)

1 x Exchange 2010 installed on 2008 R2

Site 2 - Office

1 x Server 2003 R2 DC (DHCP, DNS, AD Role)

Site 3 - Office

1 x Server 2008 R2 DC (DHCP, DNS, ADRole)

Each site is connected via LAN to LAN VPN and replication etc seems to working ok.

A user can log on to any office and access resources etc.

My knowledge of DNS is limited, I added the DNS role at remote sites after Head Office was working and it seemed to populate itself.

Clients at each site use their locan DNS server as primary and remote one as secondary.

When I install exchange do I need to do anything special to allow users at remote site to access their mail boxes etc.

Currently at remote site when setting up outlook, when I put Exchange server name in and mail box and select "check name" it cant connect/find exachange server.

I can ping it and I have tried putting IP in but to no avail.

It is one single domain accross each site which was setup with exchange at head office first them other sites were added.

Our email is still outsourced so I am just trying to get this working before bringing it in-house.

Clients located in head office seem to be able to access exchange with no issue but remote ones cant.

THanks
 
M

MTNG



If your user in HQ working fine accessing server(Primary DNS), your another 2 remote branch site (Secondary DNS) should be working as well, make sure both primary and secondary record is updated same.

Try troubleshooting based on below guide.

http://technet.microsoft.com/en-us/library/cc787724(WS.10).aspx

You may want to ensure the networking does not block the traffic too.

====================

You may try this,

On one of site 2 client pc, change the client TCP/IP dns pointing to Site1 DNS instead of pointing to Site2 DNS. (If this solved the problem, then it might be dns site 2 is not updated)

MT | MCITP ----- Please vote helpful or mark as answer if it's answered your question, this help us follow up the question status.
 
J

Jonas Andersson [MCITP]



Are you using AD Integrated DNS zones?

Are they located on all your DC's?

Try to replicate something so you will see that this works, that's step 1

Then go for MTNG's suggestion

Jonas Andersson MCTS: Microsoft Exchange Server 2007/2010 | MCITP: EMA 2007/2010 | MCSE/MCSA Blog: http://www.testlabs.se/blog
 
B

Brian Desmond -MVP-



Couple things-

If you do an nslookup on the Exchange server names against your branch office DNS, does it resolve?

You're going to want to configure Autodiscover Site Scope so this all works internally for your users.

Active Directory, 4th Edition - www.briandesmond.com/ad4/
 
G

Gekko_uk



Hello All,

Sorry for the delay in reply - been out of the office.

@ [MT]

I changed the DNS of a client pc in the remote office to point to the HQ DNS and it didnt make any difference.

VPN between each site is straight LAN to LAN VPN with no restrictions between sites.

@ Jonas Andersson [MCITP]

I am not that hot on my DNS, it seemed to set itself up.

I can ping my exchange by name and IP from remote sites using local DNS.

If you can explain somthing I could check/do to answer your question I would be more than happy to do it.

At the moment each DC is acting as a DNS server as we have one DC per site apart from HQ.

If I create a new user in AD @ HQ within 15mins it appears on remote AD so replication looks ok.

@ Brian Desmond -MVP-<abbr class="affil">MVP</abbr>

<abbr class="affil">nslookup results</abbr>

<abbr class="affil">nslookup exchange_server_name</abbr>

<abbr class="affil">Server: Unknown</abbr>

<abbr class="affil">Address: 192.168.2.101</abbr>

<abbr class="affil">Name: exchange_server_name.our_internal_domain.local</abbr>

<abbr class="affil">Address:192.168.1.101</abbr>

<abbr class="affil">with 192.168.2.101 = remote domain controller and 192.168.1.101 being exchange IP Address.</abbr>

<abbr class="affil">I am a little unsure what you mean about the autodiscover site scope?</abbr>

<abbr class="affil" />

<abbr class="affil">Thanks in advance.</abbr>

<abbr class="affil" />

<abbr class="affil" />
 
J

Joe Tam



Dear Gekko,
In my memory, the remote site segment PC client connect connect to their segment GC and searching for Exchange CAS roles server. It cannot connect to main office CAS role server properly.
Can you try below 2 options:

1. In the remote site, setup a CAS roles Exchange server for connection.

2. Use Outlook Anywhere for connection.

Regards,

Joe
 
M

[MT]

G

Gekko_uk



@ Joe - Are you saying I need to have a CAS server at each site? I didnt think this was the case?

@ MT I am unable to run those tests as it will not allow me to create an account - ie it cant find the exchange server in the first place.

Today I did get a glimmer of hope but it was removed just as quick.

It found the server, and looked up the name ok, seemd ok then I got this -

Unable to open your default email folders. You must connect to your microsoft Exchange Server computer with the current profile before you can synchronize your folders with your offline folder file

When I checked the connection status at this point it just said "Disconnected".

Further more, I logged in with a different user and it started doing the "cant find the exchange server stuff".

Please help...
 
G

Gekko_uk



@ MT - You are the man!

Solved my issue....

Cant thank you enough.

Now only have two things to get working - Out of Office prompts for username/password and get iPhones/SSL certificate working.

If you have any advice on this I would appreciate it.

But again - Many Many Thanks.

If you are every in Scotland - I owe you a beer!
 
G

Gekko_uk



Right further update...

When I try and set OOF within outlook 2003 - sets ok but only replys to emails from internal email addresses

When I try and set OOF within outlook 2007 it propts for user credentials, once entred opens OOF and works ok for both internal and external clients.....

Think it is somthing to do with EWS directory and authentication within IIS.

I have Windows, basic and annonymous selected.

Any advice anyone?

Thanks
 
M

[MT]



I am glad it helps.

I am lucky i visited UK once at May, best country i ever visited. (Love the friendly environment, and GREEN at everywhere)

1) For out of office prompts for authentication, i do not have any knowledge about it.

(I don't think it is user-friendly to implement)

2) For inquiry Iphone with certificate.

Refer this 2 link below, they are great guide.

Write by Jeff

http://www.expta.com/2010/02/how-to-securely-deploy-iphones-with.html

Articles in this series:

Phase 1 - Building the ADCS server and Generating Certificates

Phase 2 - Configuring ActiveSync and Active Directory

Phase 3 - Publishing User Certificates to Active Directory

Phase 4 - Creating the iPhone Configuration Profile

Phase 5 - Creating the Web Site for iPhone Profile Deployment

Phase 6 - End-User Deployment of the ActiveSync Profile

From Apple:

http://www.apple.com/iphone/business/integration/

Look on deployment resources on the right, lots of great reference.

Take note on this issue.

http://msexchangeteam.com/archive/2010/07/01/455342.aspx

MT | MCITP ----- Please vote helpful or mark as answer if it's answered your question, this help us follow up the question status.
 
B

Brian Day MCITP



When I try and set OOF within outlook 2003 - sets ok but only replys to emails from internal email addresses

When I try and set OOF within outlook 2007 it propts for user credentials, once entred opens OOF and works ok for both internal and external clients.....

Think it is somthing to do with EWS directory and authentication within IIS.

I have Windows, basic and annonymous selected.


In Exchange System Manager 2003 go to; Global Settings --> Internet Message Format --> Properties of Default in teh righthand pane --> Advanced Tab --> What do you see in "Allow out of office response" ?

For your EWS directory would you be able to post two things for us?

1. Get-WebServicesVirtualDirectory | fl ExchangeVersion,*auth*

2. Go into IIS manager, Sites --> Default Web Site --> EWS --> Authentication in the middle pane, can you post what is enabled/disabled there too?

 
G

Gekko_uk



Thanks for all your responses....

I have managed to break it... was trying to look into permission issues on EWS directory and I have changed a bit too much I think.

Is it possible for me to uninstall exchange and reinstall without effecting existing AD/DNS adversly?

Asked same question elsewhere and general opinion seems to be you can uninstall/reinstall without too much of an issue.

Thanks
 
D

Dhruva raj pudel



@ Joe - Are you saying I need to have a CAS server at each site? I didnt think this was the case?

@ MT I am unable to run those tests as it will not allow me to create an account - ie it cant find the exchange server in the first place.

Today I did get a glimmer of hope but it was removed just as quick.

It found the server, and looked up the name ok, seemd ok then I got this -

Unable to open your default email folders. You must connect to your microsoft Exchange Server computer with the current profile before you can synchronize your folders with your offline folder file

When I checked the connection status at this point it just said "Disconnected".

Further more, I logged in with a different user and it started doing the "cant find the exchange server stuff".

Please help...

For this error. please ensure that you have the microsoft exchange AB service staerted

and also ensure spn of "ExchangeAb" is already created

Dhruv
 
Status
Not open for further replies.
Thread starter Similar threads Forum Replies Date
S Exchange 2010 Design Consideration in Multi Site Topology Exchange Server Administration 3
E Exchange 2007 multi-site cluster and load balancing Exchange Server Administration 2
S Outlook 2010/Exchange 2010 Multi Mailboxes (Server unavailable) Using Outlook 6
A Exchange 2010 in single forest multi-domain environment Exchange Server Administration 3
L Exchange 2010 in multi-tree forest Exchange Server Administration 3
R Can BCM use Public Folders and Exchange for multi-user/ BCM (Business Contact Manager) 1
W Exchange 2010 Multi-tenant support Exchange Server Administration 17
A Ol16 desktopT suddenly can't connect with Exchange Using Outlook.com accounts in Outlook 5
T How can Exchange be configured to sync/push one-way so that the server data can't be affected Exchange Server Administration 0
E How to display "Change Folder" in Change Default Email Delivery Location in Exchange Outlook 2016 Using Outlook 1
J Outlook 2016 Moving IMAP emails to Exchange Using Outlook 1
L How to Import Exchange OST file into Outlook? Using Outlook 3
O Outlook 365 Exchange .ost within Personal Vaul Using Outlook 0
D Outlook 2016 Migrate 'On My Computer' (local storage) Calendar from Mac Outlook to Exchange Account Using Outlook 5
A .restrict results changing after moving to Exchange online Outlook VBA and Custom Forms 0
D Can Exchange Admin Center create a pst for users email/contacts/calendar? Exchange Server Administration 0
S Messages moved / deleted by auto-archive are not synchronized to exchange Exchange Server Administration 8
llama_thumper Setting up forwarders on Exchange server Exchange Server Administration 0
D Importing Outlook Categories from another domain (Exchange 2016/Outlook 2016) Using Outlook 4
M WMI query for Get Disk IO performance in exchange Exchange Server Administration 0
B Outlook 2013/Exchange 2013 - Conf Rooms not fully booking "resolved conflict" meetings Using Outlook 3
D Adding Enterprise Exchange Email Account to Outlook Prevents Sending via Outlook.com Account Using Outlook.com accounts in Outlook 10
O Benefits of Exchange over IMAP and why would I choose Exchange? Using Outlook 2
F Delete/create/reset Exchange mailbox on Outlook.com Using Outlook.com accounts in Outlook 3
A Prevent connection to Public Folders on Exchange? Exchange Server Administration 3
S Add Exchange Account as Secondary to Existing PST? Exchange Server Administration 1
S Adding new Exchange (2016) rule very slow down Microsoft Outlook Exchange Server Administration 0
CWM030 A quick question for Diane about Exchange Exchange Server Administration 2
G How to have domain client use owa server instead of exchange server while connect to network Using Outlook 1
J Outlook 2016 message content does not display - outlook.com; exchange Using Outlook.com accounts in Outlook 9
C Filter/Search emails sent to internal Exchange address only Using Outlook 2
B Copy/Move Exchange inbox to Pop inbox Using Outlook 4
Fozzie Bear Correct Method to set up Outlook.com accounts as Exchange Using Outlook.com accounts in Outlook 7
P AutoArchive exchange folder to exchange folder Using Outlook 1
J Syncing notes between Outlook 2016/Exchange and Outlook for Android Using Outlook 2
Brian Murphy Exchange Online Everything a Transport Rule should do and cannot Exchange Server Administration 1
E Customer wants a portion of GAL from exchange to sync down to Android contacts via Activesync Using Outlook 2
R Problem with searching public folders Exchange 2013/16 Exchange Server Administration 2
I outlook 2016 manual exchange config Using Outlook 0
R Add Exchange Account to existing POP3 Outlook 2007 Profile Using Outlook 0
Fozzie Bear Office 365 Home Premium with Exchange Online email accounts Using Outlook 3
S What is /O=FIRST ORGANIZATION/OU=EXCHANGE ADMINISTRATIVE GROUP(***************)/CN=RECIPIENTS/CN=... Using Outlook 5
Commodore Microsoft Exchange Add-in Using Outlook 2
D Winmail.dat with MS Exchange Personal and Outlook.com Using Outlook.com accounts in Outlook 5
I Outlook 2013 Transition to Exchange - weirdnesses Using Outlook.com accounts in Outlook 4
E you don't have permission to perform this action exchange 2016 Exchange Server Administration 0
Diane Poremsky Set Another Data File as Default When Using an Exchange Account New Slipstick.com Articles 0
PMR0001 Exchange cf Exchange ActiveSync Exchange Server Administration 1
PMR0001 Mydomain Outlook.com and Exchange post EAS Using Outlook 1
F Contacts folders not syncing with hosted exchange Using Outlook 3
Similar threads


















































Top