Outlook 2010, Multiple Accounts & Default Account

Do you like Outlook 2010's handling of default accounts?

  • Yes, I use Outlook 2010 and I like this feature.

    Votes: 7 46.7%
  • No, I use Outlook 2010 and don't like it. It's more work & I send mail from the wrong account.

    Votes: 8 53.3%
  • I don't use Outlook 2010, but I think it sounds like a great feature.

    Votes: 0 0.0%
  • I don't use Outlook 2010, but it doesn't sound like a feature I'd like.

    Votes: 0 0.0%
  • Really? I use Outlook 2010 but didn't know it did that because I use one account or only one pst.

    Votes: 0 0.0%

  • Total voters
    15
Status
Not open for further replies.
Outlook version
Outlook 2016 32 bit
Email Account
Office 365 Exchange
#21
That might be expected behavior. I'll check it to be sure.


Outlook will use the outbox in the pst - but new in Outlook 2010 is the ability to pick the Sent folder IMAP uses.
 
#22
:mad:Just installed Outlook 2010 and sent a large mail merge, after resetting the default email address. All the messages were sent from my private address rather than the default business address. Not at all happy and cannot see how to easily change this behaviour apart from deleting all my account settings and then setting them up again.


Don't really want to do this.
 
Outlook version
Outlook 2016 32 bit
Email Account
Office 365 Exchange
#23
What folder were you viewing when you did the merge? It should pick up the address associated with the current folder. However, to insure the correct account is used, close outlook and go to control panel, Mail. Copy the profile and delete the 'wrong' accounts from the copy of the profile. Close outlook and switch profiles when you want to do a mail merge and be 100% sure it goes from the correct account.
 
#24
As you can no doubt tell from the poll, users largely do not like this new 'feature'. I realize it was an attempt to make life easier, but you've violated one of the most basic rules of adding features to released software. If you are changing behavior that users are accustomed to, you need to make it a configuration option that they can opt in on if they so choose. At bare minimum make it possible to opt out.




In my case, I ALWAYS want to default to sending from my work email, even though I also collect personal emails into other folder stores. Since upgrading to Office 2010 I have inadvertently sent several work-related emails from a personal email account, causing confusion and questions from coworkers and my immediate supervisor, not to mention reflecting poorly on my professional image. You wouldn't think it should be that big a deal, but guess what? It turns out that IT IS.




I saw your registry hack and tried it. That will sidestep the problem, but it also causes me an extra step 90% of the time I send an email, as opposed to how Outlook previously worked.




Personally, I am stunned and amazed that you would make such a significant change without giving me a means to configure Outlook to behave exactly as it did, in the way that I am accustomed to from many years of using the product.




Maybe you will address this sensibly in a future patch, but for now I will be recommending AGAINST Office 2010 to anyone I know who is considering an upgrade.
 
#25
Well, I do not accept the registry workaround for such a simple issue. I insist that such a simple problem as the selection of default IMAP account as the real default account, should be something to be fixed by Microsoft with a hotix within hours.

Are there any news on this issue?

I guess I'm going back to either Office 2007 or better 2003 which was the most stable and maybe the best selection.
 
#26
I absolutely hate it!:mad: I use different POP3 accounts, only to be able to use different senders when I do an e-mail shot using the mail merge facility in Word. In previous Outlook versions it was very simple to choose another standard account in Outlook, complete the mail merge in Word and: ready. Now all mails get the same standard account and there is no way I can use the other accounts. Why on earth changes Microsoft something that worked perfectly??
 
#27
So when I'm using the "mass email" feature from the Business Contact Manager in Outlook 2010 how do I change the email address I'm sending from?? It always defaults to the same (wrong) email address and I can't figure out how to change it. There is no "from" selection box. I honestly don't see how the end user should have to change the registry to send an email when this function was available in the previous version.

Yes, I see where this new "feature" could be handy for some. However, when I set an email account as a "DEFAULT" in account settings I expect it to indeed be the default.
 
#28
Having battled with this issue for quite a number of hours, I have a simple workaround that may provide a solution for some folks.

This is a solution in the instance where you want to send all mail as one address, but you are using a service like Gmail IMAP as your storage (so that messages and folders are accessible across devices and via webmail). Essentially, we are "tricking" the IMAP account by setting everything but the logon credentials and incoming server to whatever default account we want.

For example, you have user@abc.com and user@bcd.uk and user@gmail.com addresses. You're using the @gmail account IMAP feature as "storage" for all your mail, but you want to send all mail as user@abc.com. Using the above example, in the account settings for your user@gmail.com account, change the "Email Address:" field from user@gmail.com to user@abc.com.

  1. On the "More Settings" page, on the "General Tab"
    1. Change the name of the account to something that reflects these changes ie. user@abc.com (Gmail) so that it doesn't get confusing.
    2. Add or change the "Reply to:" address to user@abc.com as well.
    3. Change the outbound server, if you prefer, to the outbound server for @abc.com domain. While Gmail and other providers might allow you to send email to other domains, your messges are, more often than not, going to get flagged as spam.
  2. If you still need to send as user@gmail.com or user@bcd.uk or any other address on the odd occasion, then set them up as separate POP3 accounts in order to make the addresses available to you in the "From:" field in new/reply/forwarded messages.
  3. Set the Gmail account to be your default account if it isn't already.
Now, even though you are using IMAP folders even while you're "in" the IMAP inbox, the from address will default to send as whatever email address you setup above, and your other addresses will be available in a pinch.

This also works on the iPhone and presumably other smartphones, where getting the right default address is elusive. Simply change everything but the incoming server address and the logon credentials to reflect your desired default address. Add dormant POP3 accounts as necessary to add "From:" addresses.
 
#29
Incidentally, I am using Gmail in this fashion as a storage box because many hosted email providers don't offer the same storage capacity or features. Also, I ran into a known and unresolved error with Outlook and some IMAP providers where messages moved or copied between folders would present an "Error cannot move items xxxx OK [CopyUID xxxxxxxxxxxxx]". Outlook would, in fact move/copy the message(s) but would not mark the moved message for deletion from it's previous location.

Yet another hairpuller, but with some creativity and free mail providers like Gmail (albeit one that spies within your messages for marketing purposes), workarounds are available.
 
#30
As you can no doubt tell from the poll, users largely do not like this new 'feature'. I realize it was an attempt to make life easier, but you've violated one of the most basic rules of adding features to released software. If you are changing behavior that users are accustomed to, you need to make it a configuration option that they can opt in on if they so choose. At bare minimum make it possible to opt out.

In my case, I ALWAYS want to default to sending from my work email, even though I also collect personal emails into other folder stores. Since upgrading to Office 2010 I have inadvertently sent several work-related emails from a personal email account, causing confusion and questions from coworkers and my immediate supervisor, not to mention reflecting poorly on my professional image. You wouldn't think it should be that big a deal, but guess what? It turns out that IT IS.

I saw your registry hack and tried it. That will sidestep the problem, but it also causes me an extra step 90% of the time I send an email, as opposed to how Outlook previously worked.

Personally, I am stunned and amazed that you would make such a significant change without giving me a means to configure Outlook to behave exactly as it did, in the way that I am accustomed to from many years of using the product.
Couldn't agree more..Please Fix this ASAP. An options screen that allows you to pick what account to send from in a given situation is the ultimate solution...we need a hotfix!!
 
#33
If you used pop accounts and all went into one pst, the default would work as in older versions. If theyeach had their own pst, it would vary with the selected folder.




Did you see the registry fix to force acccount selection? That is one solution to the problem for IMAP users - and there is a macro that always uses the default set in Account settings.




The reg key and links to the macro are here:: http://www.slipstick.com/emo/2010/up100826.htm#4



This is the worst thing that could have happened for default account setting. This registry "fix" does not work (it doesn't even properly point to the folder in the registry). I am sorry I upgraded to Office 2010 now unless I can make my "default account" the default account all the time. Even my calendar assumes the wrong email address.




Yes - I am am IMAP and POP account user and I need the IMAP account to be the default. Always.




Is there any real help for this??
 

Diane Poremsky

Senior Member
Outlook version
Outlook 2016 32 bit
Email Account
Office 365 Exchange
#34
Try this:


Create a POP3 account using the IMAP email address. Use Mail for the incoming server, the correct smtp for the IMAP account and deliver it to the default PST. Configure the outgoing server authentication then in Account settings, set it as default email account. At this point you have the desired email address delivering to the default pst. close the dialog.




press ctrl+alt+s to open the send/receive settings. Edit the settings - select the new fake POP account and set it to send only.




All new mail send outside of outlook and while viewing the pst folders should use the desired default address, as will mail sent while viewing the imap folder.
 

Diane Poremsky

Senior Member
Outlook version
Outlook 2016 32 bit
Email Account
Office 365 Exchange
#35
This registry "fix" does not work (it doesn't even properly point to the folder in the registry).





It works - you do need to create the registry keys in the path if they do not exist. Or you can set it using the group policy templates for Office 2010.
 
#36
This is a terrible BUG (not a feature). What's the point of calling it "default" if it doesn't behave as the "default"?

This to me is a bug and not a feature unless it is changed to be an option for those that want it to be this way.

I don't want to hack the registry, create some fake email account, or try any other method to "FIX-IT".

I really would like to see this fixed at the source (i.e., MS)!!!!! Please....
 
Outlook version
Outlook 2010 32 bit
Email Account
IMAP
#37
Try this:

Create a POP3 account using the IMAP email address. Use Mail for the incoming server, the correct smtp for the IMAP account and deliver it to the default PST. Configure the outgoing server authentication then in Account settings, set it as default email account. At this point you have the desired email address delivering to the default pst. close the dialog.

press ctrl+alt+s to open the send/receive settings. Edit the settings - select the new fake POP account and set it to send only.

All new mail send outside of outlook and while viewing the pst folders should use the desired default address, as will mail sent while viewing the imap folder.
I have sort of the opposite problem:

I have a pop account to send and receive my email, and an exchange server that i use to be the destination storage. So i have an exchange connection and an .ost file, and all my mail is stored on the exchange server. The exchange server is not configured to send and receive mail at all. We share the calendar and contacts, and use it as a centralized storage for everyone's mail. So, if i am viewing my inbox, which is on the exchange server, and send email to someone i sometimes get a bounce message from the exchange server saying that the email was not sent because no exchange connector is configured (I know this!) How am i going to get outlook 2010 to send from the correct account -the pop account- which is set as default when i am viewing all my mail in the exchange mailbox?
 
Outlook version
Outlook 2016 32 bit
Email Account
Office 365 Exchange
#38
Yeah, it's really tough to do anything when you have an exchange account. I'm hoping sp1 or a hotfix will address this problem.




However, for various reasons (not just this one) we recommend configuring Exchange to send using a smart host (ie, forward mail to your pop3's smtp server) and setting your pop3 email address as the default smtp address in Exchange. This would solve this problem. There are 3rd party Pop3 connectors you can use so exchange downloads your email too, but you can certainly keep the pop and smtp account in Outlook and let it do the downloading. It won't matter which account sends the mail as both use the same From address and send it to the smtp server.
 
Status
Not open for further replies.
Top