Outlook 2010, Multiple Accounts & Default Account

Do you like Outlook 2010's handling of default accounts?

  • Yes, I use Outlook 2010 and I like this feature.

    Votes: 7 46.7%
  • No, I use Outlook 2010 and don't like it. It's more work & I send mail from the wrong account.

    Votes: 8 53.3%
  • I don't use Outlook 2010, but I think it sounds like a great feature.

    Votes: 0 0.0%
  • I don't use Outlook 2010, but it doesn't sound like a feature I'd like.

    Votes: 0 0.0%
  • Really? I use Outlook 2010 but didn't know it did that because I use one account or only one pst.

    Votes: 0 0.0%

  • Total voters
    15
Status
Not open for further replies.
Outlook version
Outlook 2010 32 bit
Email Account
POP3
#41
Oh, yes.. I forgot to update this page - it's fixed in SP1. See http://www.slipstick.com/outlook/ol2010/default_acct.asp#sp1 for the reg key you need to set - it works for Send to and mailto commands without the key but if you deliver pop to the default pst, you need to use the reg key to force it to act completely like previous versions.
Well, SP1 did NOTHING at all, except goof up my signatures so i had to reset them. SP1 one also reintroduced the bug in 2007 that had the reminder window stay open half the times I close the main window. great steps BACKWARD! Why would we want to install SP1?

Thanks for the reg hack though, that fixed it!

This is a bug, not setting that reg entry! Why won't MS admit it? (Oh, they have a monopoly on Exchange clients.)

2007 and before, we just simply change the default mail account which was used for sending OUTSIDE of Outlook (i.e. mailmerge). Then then changing the default account did nothing, no visible change in any way. We had to change the default PST (like changing the motor in your car to change gears.)

With your once simple reg addition, it works as it always did. I didn't even have a "Mail" section in the Outlook part of the registry.

One year later and MS still can't get it right? I'm angry! Can they tell why no one wants to buy their phones? They are just too big to hear us any more.
 
Outlook version
Outlook 2010 32 bit
Email Account
POP3
#43
How did SP1 mess up your signatures? I haven't noticed any problems.
i have two signatures, one for each account.

one signature got set to use a different account.

second cleared inserting it into new emails.

just changed them back.
 
Outlook version
Outlook 2010 32 bit
Email Account
POP3
#44
well, the registry hack does set the default, but it forces the default address no matter what account you are viewing.

the intuitive behavior, is that setting the default would set it when you are NOT looking at an inbox. when in an inbox, and creating a new emails, then pick up form the current inbox.

what a joke MS? Without the registry hack, what is the behavior of setting the default? It seems to do nothing at all. even after SP1, it did nothing at all. did the KB fix get rolled into SP1 or did we just assume so. I don't see it downloadable from MS support page any more.
 
Outlook version
Outlook 2016 32 bit
Email Account
Office 365 Exchange
#45
The NewItemsUseDefaultSendingAccount registry hack (and SP1) restores the behavior from older versions - one default account for outlook.




If you want a mix - mailtos and sendtos using the default but the account determined by the data file you are viewing otherwise, SP1 without the NewItemsUseDefaultSendingAccount key set might work better for you. Note- if you deliver a POP3 to the default pst (when IMAP is default) will use the POP account when you view the inbox.
 
Outlook version
Outlook 2010 64 bit
Email Account
POP3
#46
I setup my IMAP accounts first, all on gmail.com. Then I setup my POP3 accounts, for domains I own and use for business. The IMAP accounts all use the selected account as the From account when sending email, and a separate .pst file was automatically created for them by Outlook. The POP3 accounts always use the Default account as the From account when sending email. I have setup separate .pst files for each of the POP3 accounts and the behavior is unchanged. I have read all about the registry settings and other posts about this article and nothing appears to solve my problem.

I want all my accounts, IMAP and POP3, to use the appropriate (selected) account when sending. What am I not seeing here? I have the separate .pst files, but the behavior is unchanged. I have set the Default Account to an IMAP account and one of the POP3 accounts, no change.

I do not believe that I have SP1 installed, and after checking, it looks like I have 32-bit Outlook running on 64-bit Windows 7, oops. Hopefully that is not the problem. I have all the install disks, so I can reinstall if that is the issue.

Thanks,

James
 
Outlook version
Outlook 2016 32 bit
Email Account
Office 365 Exchange
#47
If you want Outlook to use the account assigned to the current folder as the account when you start a new message, you need to use the default Outlook configuration - do not add any of the registry keys.




It doesn't matter if you have SP1 - the behavior of RTM is what (i think) you are desiring: when you click 'New message', outlook 2010 uses the account assigned to the folder you are viewing as the sending account for that message.




ie, If you view the imap folders and click new message, the imap account is set as the sending account - if you are in the pop3 pst, the pop3 account is used instead.






If you want all new mail to use the default account as set in File, Account Settings, regardless of the folder you are viewing (same as older versions of outlook), then you need to install SP! and set the registry key as explained here: http://www.slipstick.com/outlook/ol2010/default_acct.asp#sp1 (There is a reg file there to set the key for you.)




With this key set, when you open a new message form, it behaves like older versions and defaults to the default account.




File, Help will show 14.0.60xx if you have SP1. RTM is 14.0.5xxx
 
Outlook version
Outlook 2010 64 bit
Email Account
POP3
#48
I did not set any of the registry keys, and I do not have SP1.

I want the From account to always be the Selected account, no defaulting. But it's not working for my POP3 accounts, in spite of having separate .pst files. What am I missing?

James
 
Outlook version
Outlook 2016 32 bit
Email Account
Office 365 Exchange
#49
Assuming "selected account" means "account assigned to selected pst", it should work perfectly. Does each pop account have its own pst file?
 
Outlook version
Outlook 2010 64 bit
Email Account
POP3
#50
Yes, I mean the email account assigned to the selected .pst file.

And yes, I have created separate .pst files for each POP3 account.

It's not working. Only the "Default" account gets used as the default From account when I create a new email.

This is only a problem for my POP3 accounts, IMAP works fine.

James
 
Outlook version
Outlook 2010 64 bit
Email Account
POP3
#51
I found the issue:

It works if I select the original folder for the POP3 account, but if I select the version of the folder that is in my favorites it does not work. Though it does work for IMAP accounts.

So there is a bug in Outlook (I certainly consider it a bug) that for POP3 accounts listed in Favorites, this default From account feature is not working - it always uses the Outlook Default Account, not the account specified for the .pst file.

Let me know if you consider this a bug too. I always use the favorites, because mostly all I care about are Inboxes, and I have several email addresses I need to monitor.\

James
 
Outlook version
Outlook 2016 32 bit
Email Account
Office 365 Exchange
#52
Try removing the folder from favorites and then re-adding it. If it does not behave as expected after that, then it's a bug and i'll see if i can repro.
 
Outlook version
Outlook 2010 64 bit
Email Account
POP3
#53
The problem was that I added the parent folder to the favorites, not the Inbox. With the Inbox in Favorites it works. But the parent folder (the parent of Inbox and everything else) seemed to work just fine for everything else in Favorites. It was acting just like an inbox, except in this manner.

Not sure if this is a bug now - only a bug if parent folder in Favorites is supposed to be just like Inbox in Favorites.

Thanks,

James
 
Outlook version
Outlook 2010 64 bit
Email Account
POP3
#54
On a slightly different note:

An incredibly annoying feature of Outlook 2010 is that if I right-click on a Folder (and I do mean folder, like a parent folder for a .pst file) in my Favorites and select "Delete", it deletes the entire email account. It should only delete the Favorites item, the shortcut, whatever you want to call it. I just had to re-configure an entire email account because I was testing this defaulting mechanism and I wanted to remove a folder from my favorites.

Thanks,

James
 

jgcp

Member
Outlook version
Outlook 2010 32 bit
Email Account
POP3
#55
I have outlook 2010 , use 3 pop3 and send out emails over an smtp account from gmail. I do not use Exchange server. The Sent From address always appears as the smtp address rather than the pop3 address I've set up to appear as the Sent From address. When clicking reply to a mail the correct reply to address is used. It makes all my mail look incredibly unprofessional. I have one pst file for all accounts. Any ideas on how can I fix this?

Thanks

Janet
 

Diane Poremsky

Senior Member
Outlook version
Outlook 2016 32 bit
Email Account
Office 365 Exchange
#56
If you have the display name and address set to the one you want to use, your isp could be forcing the address change. Some isp's don't allow users to send using other addresses, only the one assigned to the account can be used as the From address.

Go to Account Settings and double click on the Account to open it. The name and address at the top, in the User Information section is what Outlook uses in the From field. Unless your isp doesn't allow it.
 
Outlook version
Outlook 2010 32 bit
Email Account
Exchange Server
#57
This is why they made the change. :)
How hard would it have been to make this a configurable option? Its usefulness depends completely on how a user elects to configure their e-mail environment. In some cases the feature makes total sense. In other cases it doesn't. It annoys me when developers think they know best and create extra work for their users, ignoring the realities of how their tools are used.

-Joe
 
Outlook version
Outlook 2016 32 bit
Email Account
Office 365 Exchange
#58
This was fixed in Outlook 2010 SP1 - see http://www.slipstick.com/outlook/2010/multiple-accounts-and-the-default-account/ for specifics - you will need to add a reg key to enable it.

HKEY_CURRENT_USER\Software\Policies\Microsoft\Office\14.0\outlook\options
Value Name: ForceAccountSelection
Value type: REG_DWORD: 1 for force, 0 to disable.

there is a 'reg file' at the link above that will set the key for you.
 
Outlook version
Outlook 2010 32 bit
Email Account
Exchange Server
#59
Thanks for the information. While useful, this appears to be a facilitated workaround rather than a "fix". We can't expect users in enterprise systems to be making registry adjustments to change their Outlook configuration. Does anyone know if Microsoft is going to make this an option in the account configuration GUI? That's where it belongs.

Thanks,

Joe
 
Outlook version
Outlook 2016 32 bit
Email Account
Office 365 Exchange
#60
I do not believe it will be in the ui but for enterprise systems, it can but pushed out in a logon script or in a group policy. (Which is how all reg keys should be pushed out in an enterprise.)
 
Status
Not open for further replies.
Top