Active SynC Issue in Exchange 2010 on CAS Array

Status
Not open for further replies.
Z

Zahoor Hakeem



HI All,

Last few days I m trying hard to workout the solution on activeSYC solution. I have exchange 2010 with 3 CAS on Array. and I have two TMG on Array. I have publised the Rules for OWA, outlookanywhere and active sync also. My OWA and outlook anywhere works fine but I am sctraching my head on active syn. Can any body tel me where I am getting stucked I have getting the following error while testing the Active sync conection from Exchange test anaylyzer.
ExRCA is testing Exchange ActiveSync.
The Exchange ActiveSync test failed.
Test Steps
ExRCA is attempting the Autodiscover and Exchange ActiveSync test (if requested).
Testing of Autodiscover for Exchange ActiveSync failed.
Test Steps
ExRCA is attempting each method of contacting the Autodiscover service.
The Autodiscover service couldn't be contacted successfully by any method.
Test Steps
Attempting to test potential AutoDiscover URL https://ABC.Com/AutoDiscover/AutoDiscover.xml
Testing of this potential Autodiscover URL failed.
Test Steps
Attempting to resolve the host name ABC.Com in DNS.
Host successfully resolved
Additional Details
IP(s) returned: 203.199.X.1

Testing TCP Port 443 on host ABC.Com to ensure it is listening and open.
The specified port is either blocked, not listening, or not producing the expected response.
Tell me more about this issue and how to resolve it
Additional Details
A network error occurred while communicating with remote host
Exception details:
Message: No connection could be made because the target machine actively refused it 203.199.X.1:443
Type: System.Net.Sockets.SocketException
Stack trace:
at System.Net.Sockets.TcpClient.Connect(String hostname, Int32 port)
at Microsoft.Exchange.Tools.ExRca.Tests.TcpPortTest.PerformTestReally()
Attempting to test potential AutoDiscover URL https://autodiscover.ABC.Com/AutoDiscover/AutoDiscover.xml
Testing of this potential Autodiscover URL failed.
Test Steps
Attempting to resolve the host name autodiscover.ABC.Com in DNS.
Host successfully resolved
Additional Details
IP(s) returned: 203.199.X.2

Testing TCP Port 443 on host autodiscover.ABC.Com to ensure it is listening and open.
The port was opened successfully.
ExRCA is testing the SSL certificate to make sure it's valid.
The certificate passed all validation requirements.
Test Steps
The certificate name is being validated.
Successfully validated the certificate name
Additional Details
Found hostname autodiscover.ABC.Com in Certificate Subject Alternative Name entry

Certificate trust is being validated.
The test passed with some warnings encountered. Please expand the additional details.
Additional Details
Only able to build certificate chain when using the Root Certificate Update functionality from Windows Update. Your server may not be properly configured to send down the required intermediate certificates to complete the chain. Consult the certificate installation instructions or FAQ's from your Certificate Authority for more information.

The certificate date is being confirmed to ensure the certificate is valid.
Date validation passed. The certificate hasn't expired.
Additional Details
Certificate is valid: NotBefore = 8/19/2010 9:18:13 AM, NotAfter = 8/20/2015 6:03:21 PM"

The IIS configuration is being checked for client certificate authentication.
Client certificate authentication wasn't detected.
Additional Details
Accept/Require Client Certificates not configured.

ExRCA is attempting to send an Autodiscover POST request to potential Autodiscover URLs.
Autodiscover settings weren't obtained when the Autodiscover POST request was sent.
Test Steps
Attempting to Retrieve XML AutoDiscover Response from url https://autodiscover.ABC.Com/AutoDiscover/AutoDiscover.xml for user test.u1@ABC.Com
Failed to obtain AutoDiscover XML response.
Tell me more about this issue and how to resolve it
Additional Details
An HTTP 403 error was received because ISA Server denied the specified URL.


ExRCA is attempting to contact the Autodiscover service using the HTTP redirect method.
The attempt to contact Autodiscover using the HTTP Redirect method failed.
Test Steps
Attempting to resolve the host name autodiscover.ABC.Com in DNS.
Host successfully resolved
Additional Details
IP(s) returned: 203.199.X.2

Testing TCP Port 80 on host autodiscover.ABC.Com to ensure it is listening and open.
The specified port is either blocked, not listening, or not producing the expected response.
Tell me more about this issue and how to resolve it
Additional Details
A network error occurred while communicating with remote host
Exception details:
Message: A connection attempt failed because the connected party did not properly respond after a period of time, or established connection failed because connected host has failed to respond 203.199.X.2:80
Type: System.Net.Sockets.SocketException
Stack trace:
at System.Net.Sockets.TcpClient.Connect(String hostname, Int32 port)
at Microsoft.Exchange.Tools.ExRca.Tests.TcpPortTest.PerformTestReally()


ExRCA is attempting to contact the Autodiscover service using the DNS SRV redirect method.
Failed to contact AutoDiscover using the DNS SRV redirect method.
Test Steps
Attempting to locate SRV record _autodiscover._tcp.ABC.Com in DNS.
The Autodiscover SRV record wasn't found in DNS.

Thanks & Regards
Zahoor Hakeem
 
B

Brian Desmond -MVP-



Your problem is in this piece. You need to get Autodiscover working first. Follow that part of the setup doc and give this another try.
ExRCA is attempting to send an Autodiscover POST request to potential Autodiscover URLs. Autodiscover settings weren't obtained when the Autodiscover POST request was sent. Test Steps Attempting to Retrieve XML AutoDiscover Response from url https://autodiscover.ABC.Com/AutoDiscover/AutoDiscover.xml for user test.u1@ABC.Com Failed to obtain AutoDiscover XML response. Tell me more about this issue and how to resolve it Additional Details An HTTP 403 error was received because ISA Server denied the specified URL.

Active Directory, 4th Edition - www.briandesmond.com/ad4/
 
Z

Zahoor Hakeem



Thanx Brain for the Reply,

I can find the Autodiscover.xml filesin the IIS virtual directory which activesync is hitting for.. Now if i am giving another shot on active sync device it is prompting me password conitnously even entering the correct password it is not getting through.

My question is. is this problem of certificate that active sync device is not fetching the certificate or vitual directory in IIS?

Thanks & Regards

Zahoor
 
B

Brian Desmond -MVP-



So is the autodiscover test passing ExRCA now?

Your authentication issue sounds like either authentication on the vdir is misconfigured or you're not supplying the username in the correct format. Also possible ActiveSync is disabled on your test account.

Active Directory, 4th Edition - www.briandesmond.com/ad4/
 
Z

Zahoor Hakeem



Thanx Brian,

I resolved the Issue, there was three mitakes during installation.
I have three cas server in array out of which only from one server I was able to generate Autodiscovery virutal directory underneth the ISS autodiscover folder. Second my authentication was windows based which should be BASIC as in my TMG web rule i have set the authentication to BASIC.

Second during the web rule creation manualy I have set the /Microsfot-ActiveSync/* path two times in TMG webule-> path folder. after removing the one enty i was able to sync tha mails.

Thanks & Regards
Zahoor Hakeem
 
Status
Not open for further replies.
Thread starter Similar threads Forum Replies Date
S Exchange 2010 - Active Sync issue - Samsung Galaxy S Exchange Server Administration 2
Z Active Sync/ OMA issue with a single user Using Outlook 4
W active sync Using Outlook 2
E Using with Active Sync, Outlook become unresponsive Using Outlook 5
K publish exchange active sync behind TMG Exchange Server Administration 4
S Active Sync Device ID Using Outlook 2
P Ex2010 active sync Exchange Server Administration 4
R Hi, Is Outlook 2010 compatible thru active sync with Windows Mobile 6.1 Professional. Using Outlook 4
F Active Sync proxying not works in a Exchange 2010/2007 Coexistence Exchange Server Administration 1
A CAS Proxying with Active Sync when migrate from Exchange 2007 to 2010 Exchange Server Administration 1
V Restoring calender files that were deleted by Active sync Using Outlook 1
M Exchange 2010 Active Sync Device Recovery Password is not VISIBLE in OWA Exchange Server Administration 4
P Exchange 2010 SP1 and HTC Desire Active-Sync Exchange Server Administration 5
S Active Sync - Allow Contacts and Calendars but not Email to sync to phone Exchange Server Administration 2
S Outlook isn't running, I can't get active sync to connect with my cell to transfer my information Using Outlook 2
A Exchange Active sync event id 3005 Using Outlook 4
Y How to configure the Active Sync on Exchange 2010 Exchange Server Administration 4
O Active Sync and Sprint Evo Exchange Server Administration 3
B one account is not getting email through active-sync Exchange Server Administration 2
J Can Android 2.1 or earlier sync with exchange server via active sync? Exchange Server Administration 3
P Exchange 2010 Active Sync not secured Exchange Server Administration 2
D Publishing OWA, Active Sync, Outlook Anywhere. Exchange Server Administration 8
A Active sync problem - related to improper decomission of Exchange 2007 when migrating to Exchange 2010 Exchange Server Administration 2
G Error Active Sync in Exchange Server 2010 Exchange Server Administration 12
P Automate Outlook Start - No Active Explorer Object Found Using Outlook 10
S Active Directory Management Tools for Administrators New Slipstick.com Articles 0
G Problems with Active Directory Rights Management Services (AD RMS) in Outlook 2013 Exchange Server Administration 0
Diane Poremsky Import Images into the Active Directory New Slipstick.com Articles 0
S How to send an OUTLOOK task to a contact out of my active directory? Using Outlook 2
E Outlook rule only active certain times of day Using Outlook 6
R HELP!!! Email template with active excel spreadsheet Using Outlook 1
C active/passive broadband connections to maintain various IT services Exchange Server Administration 2
R Went from outlook 2003 to 2010 - can't retrieve active for contacts Using Outlook 0
J Setup mail for Exchange 2010 through Active Directory on Server 2008 R2 Standard Exchange Server Administration 3
T Copied Contact Does Not Update With Active Directory Information Changes Immediately. How Do I Force Update? Using Outlook 1
B Re: Exchange OOF / EWS Problem - The user and the mailbox are in different Active Directory sites Exchange Server Administration 0
M 'Send link by E-mail' doesn't provide active link.__ Using Outlook 1
J When a database move from active host in a DAG, user are prompted for credentials Exchange Server Administration 8
D Using Inbox as 'Active' tray, with both incoming and 'sent' mail, with senders and receivers displayed. Using Outlook 1
U Outlook 2010 Ignore Conversation Feature, list of Active Ignored Using Outlook 1
D how to give perrmission on calender to user in ACTIVE DIRECTORY Using Outlook 0
J OWA not working when active database moved Exchange Server Administration 3
S Web Links are not active when using Outlook Web Access 2007 Using Outlook 1
P How can I convert an Outlook 2010 folder to a .pdf with active links like I could in Outlook 2007? Using Outlook 3
T The Microsoft Exchange Active Directory Topology service on server localhost can't be contacted via Exchange Server Administration 2
P Will 'ldap modify' command work on some Active Directory fields? Using Outlook 2
S Active Passive DAG seperate DNS namespace Exchange Server Administration 7
B Active Active Site Resilience Exchange Server Administration 3
E Event ID 9514 - Two objects in Active Directory have the same proxy address Exchange Server Administration 3
C Active Directory error applying Exchange 2010 SP1 Exchange Server Administration 4
Similar threads


















































Top