MAPI_E_NOT_FOUND Accessing Public Folders

  • Thread starter Chris Gebhardt CHPD
  • Start date Views 2,840
C

Chris Gebhardt CHPD

Greetings all!

I am accessing an Exchange 2007 server from Outlook 2003. I have updated everything from WindowsUpdate.com. The problem I get is my Public Folders are not showing. If I click on Public Folders and then All Public Folders, nothing.

HOWEVER

When I go to OWA, the Public Folders open just fine. I have tried to access the Public Folders from MFCMAPI and an error shows 0x8004010F MAPI_E_NOT_FOUND.

Using MFCMAPI, I go to Public Folder Table. It shows all the public folders but the same error message is displayed.

I am at a complete loss. The OAB downloads just fine.

///Chris\\\
 
C

Chris Gebhardt CHPD

Thanks for the response. Let me give some more information.

After failing to connect to the Public Folders, I uninstalled Office 2003 and reinstalled it. No difference.

I deleted out my profiles as well. No difference.

Then I thought I'd get crafty and installed Office 2003 on a different system. I expected this to work figuring there was a registry setting controlling access or a corrupt profile on the laptop. Nope, No difference on a completely different machine!

To clarify, others can access the PF just fine. I am the system administrator so it is even more frustrating when I can't access them via Outlook but regular users can! Even if I setup e-mail on a machine whose user CAN access PF, I still can not on their machine.

All of this testing has led me to believe it is a server issue but just with me. We are only using one server, Exchange 2007 SP1.

Thanks for the help!

///Chris\\\
 
A

AndyD_ [MVP]

So this only affects you?

What do you mean by " system administrator" ? What security groups is your account a member of?
 
C

Chris Gebhardt CHPD

Yes, this only affects my user and only affects Outlook client, not OWA.

I am the Administrator of the Domain. I am part of the Administrators group. But I have been part of that group for two years without issue. Nothing has changed on the group membership side.

///Chris\\\
 
A

AndyD_ [MVP]

Is security inheritance disabled for your account? Most likely it is. Recheck inheritance and test. ( Inheritance will be disabled again after about an hour automatically)

When did this start?
 
C

Chris Gebhardt CHPD

Yes.

This started about three months ago. I did not upgrade anything before then. Just simple Windows updates.

///Chris\\\
 
A

AndyD_ [MVP]

Ok, can you re-enable inheritance and test? (Give it some time to replicate the changes)

One thing to note, mailbox-enabling accounts that are members of elevated security groups is not recommened.
 
C

Chris Gebhardt CHPD

Andy,

I am a little confused on what you are asking me to do. Where do I re-enable inheritance? On what object? My user name?

Also, not sure what you mean by mailbox-enabling accounts that are members of elevated security groups. I am a user as well as an administrator. Are you saying I should remove my username from the Administrators group and just use the actual Administrator user to make any modifications?

Thanks for your help. This issue is driving me crazy and I have a project that I need to complete with access to PF.

///Chris\\\
 
C

Chris Gebhardt CHPD

I removed myself from all advanced security groups, restarted Outlook, and no change.
 
A

AndyD_ [MVP]

Ok, now in ADUC, under the security tab for your account, check the advanced button and check the box that allows inheritance and then wait a bit and test.

You may have to enable Advanced Features under the View menu in ADUC to see the security tab.

If it still doesnt work, you may want to check the public folder objects for any security denies though if it works in OWA, there may not be any.

After that, a call to Microsoft support may be required.
 

Top