How to get to the OWA 2010 logon page when integrated authentication is enabled

Status
Not open for further replies.
R

Rob.Ford



Hi,

Our users browse to the OWA URL and get the mailbox of the currently logged on user, that's great. It's the way we set it up and want it.

However, we also have a requirement to enter credentials for alternative mailboxes. This won't work no matter what we'ved tried.

We've tried things like the following URL:

https://webmailurl/owa/auth/logon.aspx?ReplaceCurrent

That gives us the logon page but then we get "The webpage cannot be found" after entering alternative credentials. Are there any other verbs that can be passed to logon.aspx or any other method to do this?

Cheers,

Rob
 
B

Busbar [MVP]

if you have windows integrated auth configured you cannot use FBA, my suggestion is to delegate the access to the mailboxes to users, configure FBA and ask users to use open mailbox button in OWA and open the other mailbox.Regards, Mahmoud Magdy Watch Arabic Level 300 Videos about Exchange 2010 here: http://vimeo.com/user3271816 Read pretty advanced Exchange stuff I post here: http://www.enowconsulting.com/ese/blog.asp, follow my blog: http://autodiscover.wordpress.com , corp blog: http://ingazat.wordpress.com, Follow me on twitter http://www.twitter.com/_busbar and if you Liked my post please mark it as helpful and accept it as an answer
 
R

Rob.Ford

There really should be a way of doing this, an alternative url or way of calling logon.aspx. Delegating access is not a solution. I'll look at setting up 2nd OWA virtual directories with different auth settings.
 
B

Busbar [MVP]

R

Rob.Ford



Damn, I'm pretty sure this worked ok for 2007 but in 2010 both websites write their authentication method in "C:\Program Files\Microsoft\Exchange Server\V14\ClientAccess\owa\web.config" and not the separate web.config for the website. They trample over each and break each other.

I wonder if this is fixed in SP1?
 
B

Busbar [MVP]

R

Rob.Ford

I did, but Exchange is writing to the same web.config file for both of them.
 
G

Gavin-Zhang

Hi Bob.Ford,
Please follow below and make a test:
1. Open "Internet Explorer".
2. Find "Tools" from the menu.
3. Select "Options".
4. Navigate to "Security" tab.
5. Hit "Internet" and click "Custome Level'.
6. Find "User Authentication" and select "Automatic logon with current user name and passowrd" or "Prompt for user name and password".
Also repeat step 6 for "Local intranet".
Regards!
Gavin
 
Status
Not open for further replies.
Top