DNS Query Failed

  • Thread starter Daniel Felipe Lucas
  • Start date
Status
Not open for further replies.
D

Daniel Felipe Lucas

Hi Peoples,

I have single forest and one domain controler 2008R2, I had installed HUB transport and MailBox and CAS of Exchange Server 2010 on Windows2008R2.

My domain is abc.local and i have a external domain abc.com, i created in exchange a accepted domain " abc.com" and a send conector for abc.com.

But, when i send a message for a any external domains (gmail, hotmail), in the queue viewer appears a erros DNS Query Failed.

I read any threads in this forum, tried any possibilitys in the exchange and DNS.

I try many time , I do it below:

- created a external relay

- mx records in dns

- host A point to my Mail Host (abc.com)

- Checked a box for External DNS Lookup in the Send Connector

- Disable IPv6 (but when i restart a server, exchange appear a error, and I reactivate a IPv6)

- Delete ::1 in the Hosts.txt

Anybody can help me please?

Regards,

Daniel Felipe
 
M

[MT]

1) Can you resolved the external mx record (hotmail, gmail)?

2) What is the dns query error message?

3) If you able to resolve the mx, and when you perform a smtp telnet, do you receiving error?

Reference

http://technet.microsoft.com/en-us/library/bb676467.aspx

MT | MCITP ----- Please vote helpful or mark as answer if it's answered your question, this help us follow up the question status.
 
S

Sheeraz Ahmed

On Exchange server use command prompt and simple ping the domain name hotmail or gmail.ocm does it resolves the name..

Surely it will not as i can see.. just make sure you have DNS forwarders in you DNS server and also you DNS server is allowed on the firwall..

Sheeraz Ahmed sheezi4u@hotmail.com
 
D

Daniel Felipe Lucas

Hi Guys,

Thanks for the reply.

1 - I can resolve the external mx record normally (cmd -> nsllokup set q=mx)

2 - The DNS Erros Message is: 451 4.4.0 DNS Query Failed

3 - I can send message normally with a telnet from abc.com to abc.local.

I read any threads in this foruns and my problem continues.

=/

Best regards,

Daniel Felipe.
 
S

Sheeraz Ahmed

The problem indicates there is something in DNS have you tried to resolve the DNS name of multiple domain names as the name which you have resolved might be in cache..

What about relaying mail to an ISP SMTP server does it work fine..

Sheeraz Ahmed sheezi4u@hotmail.com
 
D

Daniel Felipe Lucas

Hi Sheeraz,

Thanks for the reply, but i don´t know whats my problem.

In my DNS i created a Host A to my external domain SMTP Ip.

And created a MX Records poiting to this Host.

If i change the send connector to a " Use domain name system (DNS) MX records to route..." the email send.

But a error message returns is:

[xxx.xxx.xxx.xxx] The IP you're using to send mail is not authorized to send email directly to our servers. Please use the SMTP relay at your service provider instead. Learn more at http://mail.google.com/support/bin/answer.py?answer=10336 u16si99258yba.82

Received: from SRVPLS.pls.local ([fe80::xx:12xd:d996:xxxx]) by SRVPLS.pls.local ([fe80::xx:12xd:d996:xxxx%11]) with mapi; Sun, 10 Oct 2010 19:47:34 -0300 From: teste teste <teste@abc.com.br> To: " felipeluchc@gmail.com" <felipeluchc@gmail.com> Subject: teste domino Thread-Topic: teste domino Thread-Index: ActozSB2j/QEIhEtSc63yxWSqifcAw== Date: Sun, 10 Oct 2010 22:47:33 +0000 Message-ID: <1B3E7C888C6C8E4B80FB4ED596FE281A0F1536@SRVPLS.pls.local> Accept-Language: pt-BR, en-US Content-Language: pt-BR X-MS-Has-Attach: X-MS-TNEF-Correlator: Content-Type: multipart/alternative; boundary=" _000_1B3E7C888C6C8E4B80FB4ED596FE281A0F1536SRVPLSplslocal_" MIME-Version: 1.0

Best regards,

Daniel Felipe.
 
J

Jonas Andersson [MCITP]

Hi

Contact you ISP and ask them for the smarthost address you can use to send mails

That address should be configured on your send connector

Hope it helps you :)

Jonas Andersson MCTS: Microsoft Exchange Server 2007/2010 | MCITP: EMA 2007/2010 | MCSE/MCSA Blog: http://www.testlabs.se/blog
 
D

Daniel Felipe Lucas

Hi Jonas,

Thanks for the reply.

But the problems continues.

If I configure the send connector with a smtp.domain.com the errors appears, but if I configure de send connector with a IP of the smtp.domain.com the messages out of queue but appear a message:

felipeluchc@gmail.com
bart0008.localdomain #503 5.0.3 <unknown[189.16.17.50]>: Client host rejected: Para envio de mensagens e necessaria autenticacao/This mail server requires authentication ##

felipeluchc@hotmail.com
bart0008.localdomain #503 5.0.3 <unknown[189.16.17.50]>: Client host rejected: Para envio de mensagens e necessaria autenticacao/This mail server requires authentication ##

Cabe&ccedil;alhos de mensagem originais:

Received: from SRVPLS.pls.local ([fe80::51c5:124d:d996:d4bd]) by SRVPLS.pls.local ([fe80::51c5:124d:d996:d4bd%11]) with mapi; Mon, 11 Oct 2010 11:27:41 -0300 From: teste teste <teste@pls.com.br> To: " felipeluchc@gmail.com" <felipeluchc@gmail.com> CC: " felipeluchc@hotmail.com" <felipeluchc@hotmail.com> Subject: asdf Thread-Topic: asdf Thread-Index: ActpUHYEMCwjmWgySei75Q1DXEFIIg== Date: Mon, 11 Oct 2010 14:27:40 +0000 Message-ID: <1B3E7C888C6C8E4B80FB4ED596FE281A0F39B5@SRVPLS.pls.local> Accept-Language: pt-BR, en-US Content-Language: pt-BR X-MS-Has-Attach: X-MS-TNEF-Correlator: Content-Type: multipart/alternative; boundary=" _000_1B3E7C888C6C8E4B80FB4ED596FE281A0F39B5SRVPLSplslocal_" MIME-Version: 1.0
 
D

Daniel Felipe Lucas

I tried to create a HOST A to IP of the smtp.domain.com

And create a MX records to HOST A.

But, when i send a message the errors appears again: DNS QUERY FAILED.

I don&acute;t know more steps to resolve this problem.

Help me?

Thanks,

Regards,

Daniel Felipe.
 
D

Daniel Felipe Lucas

your ISP or the SMTP service provider should use SMTP authentication..
Sheeraz Ahmed sheezi4u@hotmail.com
But in the send connector i put the email and password to authentication.

Regards,

Daniel Felipe.
 
D

Daniel Felipe Lucas

I triyng to configure a Hosts and Mx&acute;s in the DNS, but I don&acute;t know the correct form to input.

Somebody help me?

Thanks,

Daniel Felipe.
 
D

Dave Kawula - TriCon

Run a tool like mxtoolbox.com on your domain name space. If you are coming up with errors that is what you other email servers you are sending -- Look at.

My first guess is that your reverse lookup is not setup properly on your external IP.

You haven't setup Smarthosting with your ISP and changed your MX Records to reference their IP's instead of yours.

You propably haven't created SPF records for your domain name space.

This is a very common issue.

I have a new rule of thumb -- I use a service like www.appriver.com for inbound and outbound mail. It cost me .75 per mailbox per month and I " Never have issues like this" The setup takes less than 20 minutes and will save you a lot of grief in trying to host your own email for a small company. The other benefit is that if your ISP ever goes down they will queue your mail for you.

Anyways -- Just my two cents.

Thanks,

Daave Kawula Principal Consultant TriCon Technical Services Inc www.triconts.com dkawula@triconts.com www.insidetheregistry.com
 
D

Daniel Felipe Lucas

Hi Guys,
After long days I managed to solve my problem.
My internal DNS server could not resolve external DNS.
I inserted a DNS forwarder on my internal DNS and the name can be resolved.

Thank&acute;s a lot...

Regards,

Daniel Felipe.
 
Status
Not open for further replies.
Thread starter Similar threads Forum Replies Date
S DNS query failed error in exchnage 2010 only while sending email to hotmail.com Exchange Server Administration 7
T 451 4.4 dns query failed on exchange 2010 hub transport server Exchange Server Administration 1
D 451 4.4.0 DNS Query Failed. Exchange Server Administration 3
T Exchange 2003, NDR, DNS problems Exchange Server Administration 3
B Promoting and demoting dns w/ exchange 2007 sp2 environment Exchange Server Administration 1
R Dynamic DNS update requirement for Exchange 2010 (SP1 RU1) on server 2008 r2 Exchange Server Administration 8
S Cluster Name failed to update the DNS record Exchange Server Administration 2
J Missing HUB DNS record results in mail piling in queue, no failover? Exchange Server Administration 2
F OWA internal and external address is trying to resolve on an external DNS server on the internet Using Outlook 2
S Exchange 2003 coexistence with Exchange 2010 (Edge, OWA, Certificate, DNS considerations) Exchange Server Administration 3
B Transition for OA/OWA/AS and DNS Exchange Server Administration 3
S Active Passive DAG seperate DNS namespace Exchange Server Administration 7
P DNS Round Robin on CAS Array Exchange Server Administration 5
S internal dns name on certificate Exchange Server Administration 1
P External DNS Question; 2003-2010 Migration Exchange Server Administration 5
B DNS Settings for Exchange 2010 - a slightly different scenario Exchange Server Administration 3
B Configuring DNS when migrating to Exchange 2010 from Exchange 2003 Exchange Server Administration 3
P How Do I get this to work? DNS/Exchange question Exchange Server Administration 12
A Exchange 2010 DAG with non Microsoft DNS (and non-dynamic updates) Exchange Server Administration 4
M How to Break / Stop Autodiscover Outlook 2007 to Exchange 2003 using DNS Using Outlook 3
K Exchange 2010 only allows me to setup Outlook accounts when using it as my DNS servers Exchange Server Administration 11
M WMI query for Get Disk IO performance in exchange Exchange Server Administration 0
B Select / activate first email item in the searched query Using Outlook 1
Q Mail account setup query Using Outlook 0
B query outlook using vba Outlook VBA and Custom Forms 13
T Query About "Delay Delivery" Function Using Outlook 6
S Subject add ticket number from URL query Outlook VBA and Custom Forms 2
P Calendar permissions query Using Outlook 1
R 'Display as' email query Using Outlook 1
T Query about one aspect of migrating .pst files from Outlook 2003 to Outlook 2013 Using Outlook 5
C 'Show as conversation' query Using Outlook 0
C Unusual Signature & Spell Check Query Using Outlook 1
A Advanced find query facilty Help please Using Outlook 2
C Outlook local calendar & iCloud calendar syncing query Using Outlook 3
D outlook 2003/2007 macro query Using Outlook 2
L Exchange TLS query Exchange Server Administration 3
S PSO Issue Query Exchange Server Administration 4
S Search using query builder Using Outlook 2
D Peculiar Outlook message format query Using Outlook 1
V Problem with Search-Mailbox Query Exchange Server Administration 6
M Expand query builder permanently - outlook 2007 Using Outlook 3
S Hub/CAS dual role - load balancing query Exchange Server Administration 3
J Powershell Query Exchange Server Administration 8
R High Online RPC Operations - Query Rows Exchange Server Administration 4
R Can I get Outlook addresses from Access 2007 query? Using Outlook 1
E Server sizing query Exchange Server Administration 1
N Query regarding meeting forwarding Using Outlook 1
C Query:3 Node DAG dependencies Exchange Server Administration 2
B distribution list query Using Outlook 1
M Read Receipt Query Using Outlook 1
Similar threads


















































Top