Unable to remove failed DAG member from a two-node DAG group

Status
Not open for further replies.
M

MosesMusa

I have a simple test lab with two DAG members, each with CAS/MBX/HT roles. The FSW is installed on a NON-Exchange server. I am testing restore of a failed DAG member using Setup /m:RecoverServer. I am following MS TechNet library notes titled " Recover a Database Availability Group Member Server" . I successfully removed all replicated DB copies from the failed server using " Remove-MailboxDatabaseCopy" . The next step was to remove the failed DAG member from the DAG group using " Remove-DatabaseAvailabilityGroupServer" . This cmdlet failed with the following error:

There was a problem changing the quorum model for database availability group. Error: Cluster API SetClusterQuorumResource() failed with 0x1725. Error: A quorum of cluster nodes was not present to form a cluster

Question: Does the above error mean I cannot remove a DAG member from a DAG group consisting of a two-node cluster, even though the FSW is online??? Currently the DAG cluster is operating fine with only one DAG member + FSW. I am using the " Node and File Share Majority" quorum model. This was automatically configured when I created the DAG. Any inputs greatly appreciated as I am in a deployment time crunch.

Additional Info: I was even considering simply building a new Exchange server and add it to the DAG, then remove the currently failed DAG member. I figure this will take care of the quorum error.
 
B

Bharani.Billapati

This looks to me like some cluster error. Check in cluster administrator about the status of cluster. You can try by removing the member from there and then remove the member server from DAG object in adsiedit.

Thanks

Bharani
 
M

Michel de Rooij

So, your 1-node is running ok? Have you tried (forcefully) evicting the failed node (DAG member) and reconfiguring the DAG? Instructions in here (partial failed cluster section):
http://technet.microsoft.com/en-us/library/dd351049.aspx

PS: Try to use Exchange EMC/EMS to reconfigure DAGs/Failover clustering, try to avoid cluster admin - its not Exchange aware.
Michel de Rooij,
MCITP Ent.Msg 2007+2010| MCTS W2008, Ex2007+2010 Conf, OCS2007 Conf | MCSE+Msg2k3 | MCSE+Inet2k3 | Prince2 Fnd | ITIL
I blog on http://eightwone.wordpress.com/ and tweet on http://twitter.com/mderooij
 
G

Gulab Mallah

Michael is right, you will have to remove it from Failover Cluster Management.

-Gulab
 
M

MosesMusa

Michel, yes, the 1-node is working fine together with the non-Exchange FSW. As a rule, I don"t use Cluster Admin to manage Exchange DAGs. Occasionally I use Failover Cluster Manager to view the status of cluster core resources.

I am now working with MS tech support to try and resolve the issue. They decided I use " Remove-DatabaseAvailabilityGroupServer" with " -ConfigurationOnly" option to remove the failed server i.e.

Remove-DatabaseAvailabilityGroupServer -Identity DAG_NAME -MailboxServer SERVER_NAME -ConfigurationOnly

This seems to work - i.e. removes the failed server from DAG group. Not sure if there are any gotchas yet, as I am in process of rebuilding the failed server using Setup /m:RecoverServer. Will try to rejoin it to the DAG once Exch is installed and see what happens.
 
M

MosesMusa

After removing the failed DAG member from the DAG group using ConfigurationOnly option, I was able to successfully re-install Exchange 2010 SP1 using /m:RecoverServer. However when i tried to re-add the server back to the DAG using " Add-DatabaseAvailabilityGroupServer " , it failed with the following error:

A server-side database availability group administrative operation failed. Error: The operation failed. CreateCluster errors may result from incorrectly configured static addresses. Error: An error occurred while attempting a cluster operation. Error: Node exch02 is already joined to a cluster. [Server: EXCH01.exchlab.local]

FYI: When I ran the Get-DatabaseAvailabilityGroup cmdlet, it showed only 1 DAG member (the surviving DAG member server). It does not show the DAG member I removed using the ConfigurationOnly parameter (i.e. server exch02 referenced in the above error ).
 
G

Gulab Mallah

Evict this node from cluster (Failover Cluster Management) than add it

-Gulab
 
M

MosesMusa

I checked in Failover Cluster Manager and confirmed that exch02 node still showed. I am somewhat wary of using Failover Cluster Manager to manage Exchange DAGs so I used the following cmdlet to force removal of the failed node:

Get-ClusterNode exch02 | Remove-ClusterNode –Force

It worked OK and I was able to add back the rebuilt Exchange DAG member to the DAG group, then created DB copies. In summary the failed DAG member has now been successfully restored. Thanks to everyone who contributed.

TIP: For newbies like me, to run “Get-ClusterNode” in EMS, you may need to first import the Clusters module using “import-module failoverclusters”.
 
Status
Not open for further replies.
Thread starter Similar threads Forum Replies Date
S Unable to remove rule outlook 2010 Using Outlook 0
G Outlook calendar entry corrupted. Constant pop up when you open outlook. Unable to delete or remove. Using Outlook 2
D Unable to remove the series of reoccurring appointment Using Outlook 2
H Unable to remove the last exchange 2003 server in the organization Exchange Server Administration 2
J Office for Mac 2011: Unable to remove duplicates and POP3 account pulls all e-mails each time Using Outlook 1
A Unable to remove additional delegated/associated mailbox from outlook 2010 - Exchange 2010 SP1 Exchange Server Administration 9
A 2010 SP1 - Unable to remove mobile phone partnership Exchange Server Administration 2
K Unable to retrieve information from Exchange 2010 Public Folder after remove server replication Exchange Server Administration 16
P unable to remove mobile device partnership Exchange Server Administration 3
A Unable to save recurring Meeting to Documents folder due to error Using Outlook 2
O Outlook 365 - suddenly unable to send using Gmail POP3 Using Outlook 10
S Outlook 2010 unable to change default font Using Outlook 7
Q Unable to Sync Quicken reminder with Outlook 2016 64Bit Using Outlook 1
L Wierd Office 365 Contact unable to edit body of random contacts Using Outlook 5
X Unable to send an email from one account to another on same PC Using Outlook 2
Mark Foley Unable to subscribe to published calendar in Outlook 2010 Using Outlook 4
S Unable to Edit Contact Information in Certain Contact Folders Using Outlook 3
P Deleted Items - Unable to Iterate All of Items Outlook VBA and Custom Forms 1
G Unable to dismiss reminders from share point list calendar shared in Outlook Using Outlook 2
R Unable to install without email account Using Outlook 4
E Unable to open Outlook 2010 after adding new email account Using Outlook 4
A Outlook 2016- unable to have all subfolders expanded when opening outlook Using Outlook 11
avant-guvnor Unable to view certain emails in Outlook 2016 Using Outlook 16
M Unable to Configure Gmail Account in Outlook 2007 Using Outlook 1
D Unable to Send On Behalf of Another User Exchange Server Administration 0
J Unable to link email messages in BCM using a single microsoft office 365 account in outlook 2013 BCM (Business Contact Manager) 1
Tim King Outlook 365 unable to change accounts Using Outlook 0
R Unable to send mail using Cox.net Using Outlook 1
T Unable to 'Upload a file' using popup 'Browse' button Using Outlook 0
D Unable to add email address to contact Using Outlook 3
O OL2000: Unable to create IMAP account Using Outlook 2
wallisellener Unable to reply/post/create new thread using Chrome BCM (Business Contact Manager) 5
Rupert Dragwater unable to change font sizes in some replies Using Outlook 3
C Unable to see meeting attendees Outlook 2010 Using Outlook 5
M Unable to email from Word or Excel Using Outlook 11
O Unable to check name. Using Outlook 3
T Unable to create contacts subfolder in EAS profile Using Outlook.com accounts in Outlook 6
UncleBill Unable to delete items from gmail IMAP Trash using Outlook 2010 Outlook VBA and Custom Forms 5
B Unable to search delegated mailfile Using Outlook 3
K Unable to activate QueryBuilder in Outlook 2010 (32bit) with Windows 7 (64bit) Using Outlook 1
C Unable to forward email with URL Using Outlook 2
R New computer, OL2010 unable to display shared calendar appointments Exchange Server Administration 3
S unable to send email from my second address (outlook 2007) Using Outlook 2
A "Unable to display the folder" error when accessing Group mailbox Using Outlook 0
C Outlook 2010, two exchange mailboxes configured.Unable to see 2ndrymeeting req Using Outlook 2
H Outlook 2010 unable to send iCloud account e-mail after iOS 7 upgrade Using Outlook 12
B Unable to apply rule on Exchange server functional account Exchange Server Administration 1
J Archives: Unable to locate emails Using Outlook 1
S Unable to send or reeceive email in new Exchange 2010 Exchange Server Administration 0
B Unable to Accept meetings that are already Tentatively accepted Using Outlook 2
Similar threads


















































Top