Cannot upgrade "Public Folders" & "GAL"

Status
Not open for further replies.
D

DarrenWCC

Hello

I have a problem with upgrading Public Folders and Default Global Address List. Others have posed this issue here but it has not been resolved so I am raising it again in the hope that someone can please help.

My cmdlets and errors are:

Set-AddressList " Public Folders" -RecipientFilter {RecipientType -eq " PublicFolder" }
Invoke-Command : Cannot bind parameter 'RecipientFilter' to the target. Exception setting " RecipientFilter" : " Invalid filter syntax. For a description of the filter paraeter syntax see the command help.
" RecipientType -eq PublicFolder" at position 19."
At C:\Users\DAdmin\AppData\Roaming\Microsoft\Exchange\RemotePowerShell\mail.wcc.qld.edu.au\mail.wcc.qld.edu.au.psm1:43213 char:29
+ $scriptCmd = { & <<<< $script:InvokeCommand `
+ CategoryInfo : WriteError: :)) [Set-AddressList], ParameterBindingException
+ FullyQualifiedErrorId : ParameterBindingFailed,Microsoft.Exchange.Management.SystemConfigurationTasks.SetAddressList

Set-GlobalAddressList " Default Global Address List" -RecipientFilter {(Alias -ne $null -and (ObjectClass -eq 'user' -or ObjectClass -eq 'contact' -or ObjectClass -eq 'msExchSystemMailbox' -or ObjectClass -eq 'msExchDynamicDistributionList' -or ObjectClass -eq 'group' -or ObjectClass -eq 'publicFolder'))}
You can't peform this operation on default global address list " Default Global Address List" .
+ CategoryInfo : InvalidOperation: (\Default Global Address List:ADObjectId) [Set-GlobalAddressList], InvalidOperationException
+ FullyQualifiedErrorId : 7804D023,Microsoft.Exchange.Management.SystemConfigurationTasks.SetGlobalAddressList

Any help to resolve will be greatly appreciated. By the way, I have tried double and single quotes in thet cmdlet.

Thanks
Darren
 
S

Steve Goodman

Hi Darren,

For the first issue, have you tried it on one of the Exchange servers, and if unsuccessful, it might be worth trying on an Exchange server, opening a non exchange, elevated powershell prompt, then running Add-PSSnapIn Microsoft.Exchange.Management.PowerShell.E2010 then trying again. May at least rule out any remoting issues.

To address the second issue check out this post by Paul Cunningham.

Steve

Steve Goodman
Check out my Blog for more Exchange info or find me on Twitter
 
D

DarrenWCC

Steve

Interesting. For the Public Folder issue, I found another link which had the cmdlet text:
Set-AddressList " Public Folders" -RecipientFilter { RecipientType -eq 'PublicFolder' }
When I ran that with the slightly different spacing, it upgraded the Public Folders and I can now open their properties in Exch 2010 EMC.

For the GAL, I followed the instructions in the referenced post. In adsiedit, I set msExchRecipientFilterFlags from 2 to 0 then ran the Set-GlobalAddressList cmdlet which ran quickly and without errors. As instructed, I then set msExchRecipientFilterFlags back to 3 (not 2 as originally set). Out of interest, I re-ran the Set-GlobalAddressList cmdlet again and got the same error. However, my reading of the post indicates that you can set this value only once. Apparently I set it after the work-around in adsiedit and then cannot set it again (as expected??).

Does this mean the GAL is now upgraded? How can I check?

I am thinking it is all done...!!!

Thanks
Darren
 
Status
Not open for further replies.
Thread starter Similar threads Forum Replies Date
J Post SP3 upgrade - outlook 2003/2010 clients cannot connect Using Outlook 1
D Outlook 2003 cannot open Word docs after Windows 7 upgrade from Vista. Using Outlook 2
H Outlook Connector &amp; Java Script cannot upgrade Using Outlook 2
M Cant get Exchange 2010 Update Roll up 4 to install. Error: the upgrade patch cannot be installed by Exchange Server Administration 8
S Error after upgrade: Cannot open default e-mail folders Using Outlook 3
H Cannot Upgrade exchange 2010 sp1 on Mailbox role servers Exchange Server Administration 6
V Cannot perform the requested operation - Upgrade MS Exchange' Using Outlook 5
G Cannot Move Autocomplete File to New Computer Using Outlook 15
rubaboo The vew cannot be found Outlook VBA and Custom Forms 0
A Cannot copy this folder because it may contain private items Using Outlook 0
L Cannot open PST file for first session each day Using Outlook 6
David in Mississippi New (Feb 2020) install of Outlook 365 - Cannot specify PST for different accounts Using Outlook 0
Marc2019 Need help please! Cannot Setup my outlook email account on my Mac Outlook 2011 Using Outlook.com accounts in Outlook 2
noshairwan Registry cannot be found, Outlook Security Using Outlook 2
Marc2019 Cannot input Vietnamese Characters on my MSOutlook 2016 in Windows 7 Using Outlook 0
T Cannot remove needless PST Using Outlook 1
Marc2019 Cannot setup Outlook Account on Mac Os 10.6.8 Using Outlook 3
N pst files are recreating automaticaly and cannot be deleted Using Outlook 6
Mark Foley Cannot enable add-in in outlook 2010 Using Outlook 0
T "cannot find the calendar folder for this item" - calendar items stuck in outbox Using Outlook 0
A Created a new user account and the local account cannot see email Using Outlook 3
iwshim outlook 2013 - I cannot see the "Manage Add-ins" Using Outlook 2
T Cannot connect to main BT email account, sub accts okay Using Outlook 0
O The page that you are trying to access cannot be loaded. Using Outlook 0
M Daily Task List Minimized Cannot Display Using Outlook 2
geofferyh Cannot get Macro to SAVE more than one message attachment??? Outlook VBA and Custom Forms 5
DariTrevino MIcrosoft Outlook PST file cannot repair Using Outlook 1
B One email cannot be sent or received (but leaves outbox!) Using Outlook 1
C Outlook 2016 cannot delete, email showing in root Exchange Server Administration 5
S Outlook.com cannot edit some contacts Using Outlook.com accounts in Outlook 5
B Search: Cannot find which Folder Contains a Message Using Outlook 3
C Outlook - cannot save subject line changes Using Outlook 2
M cannot change delivery folders with IMAP accounts Using Outlook 0
S Appointment-Cannot set Categories because ConversationID is not set Outlook VBA and Custom Forms 1
Fozzie Bear Cannot post "Sneaky URL"!! Using Outlook.com accounts in Outlook 2
Commodore Search cannot complete the indexing of your Outlook data Using Outlook 6
S Outlook 2010 Cannot Open Attachments Using Outlook 14
A Cannot Figure Out This VBA Outlook VBA and Custom Forms 2
A Cannot Figure Out One Thing on VBA Outlook VBA and Custom Forms 2
Brian Murphy Exchange Online Everything a Transport Rule should do and cannot Exchange Server Administration 1
A Error: The name cannot be matched to a name in the address list Using Outlook.com accounts in Outlook 0
K Other Shared Calendar on Outlook cannot change items Using Outlook.com accounts in Outlook 7
T Outlook 2016 cannot connect after transition to Outlook Mail Using Outlook.com accounts in Outlook 4
L Cannot Connect to BCM database BCM (Business Contact Manager) 9
A Cannot connect to BCM database BCM (Business Contact Manager) 3
Diane Poremsky The custom form cannot be opened. Outlook will use an Outlook form instead. New Slipstick.com Articles 0
T Cannot access outlook.com accounts in Outlook 2016 Using Outlook 1
T Outlook 2016 mp3 attach "this file cannot be preview because there is no previewer installed for it" Using Outlook 1
S Outlook data file cannot be accessed message Using Outlook 5
O Cannot open or save calendar items Using Outlook 0
Similar threads


















































Top