steps in configuring ms exchange to send and recieve emails from different domain?

Status
Not open for further replies.
N

newb33

good day to all experts :D

hi im in a final process to complete my simple lab in ms exchange 2010 and im just wondering on how,what or where should i configure on send and receiving message from a different domain or internet.

ex. pc1(domain = testing1.com) sending/receiving email to pc2 (domain = testing2.com)

regards and pls help in this simple matter :D

god bless
 
A

Aivar75

By default exchage 2010 doesnt make send connectors and you must do them manually via shell or emc

for incoming connections there are by default 2 connectors (default and client) made under server configuration-> hub-> select server and you see on bottom selection page.

if you dont want to make an send connector to use mx default is * then just make new send connector and select address space as @domain2.com and use smart host to send directly emails to pc2. (or if you have dns configured use mx for that also.)

or you mean that 1 exchange server handles 2 dfferent email domains?

and for receive connector just select " default connector " -s proerties anonymous tab, and your exchange server accepts incoming emails.
 
N

newb33

thank you for your reply :D

" if you dont want to make an send connector to use mx default is * then just make new send connector and select address space as @domain2.com and use smart host to send directly emails to pc2. (or if you have dns configured use mx for that also.)"

mx is the smtp right? so if i use the mx default it will send/recieve emails from a different domains?

" or you mean that 1 exchange server handles 2 dfferent email domains?"

actually i have 2pcs both have exchange servers. :D

thank you again ^^
 
A

Aivar75

if you make a new send connector and use domain " *" then and use dns/mx as resolver it will send to any recipient domains via mx lookup, and if you use remote domain * and use smarthost and select remote server to send emails, all outgoing email will be sent to that smarthost.

for your test environment, if you want only to send emails back and forth with only those 2 servers, make new send connector with * and use smarthost and put ip address of remote exchange server and that should be all (so pc1 sends all outgoing emails whatever the @domain.com or @somethingelse.com recipient is to pc2 and vice versa).
 
N

newb33

thanks again avira, I'll try this when i got back from school.
i'll ask again if something went wrong ^^

good day :D
 
N

newb33

i tried setting up a connector which i will send an email outside my server. i want to send an email to my yahoo accnt but it didn't send >.<

here is my setup in organization>hub transport>tab of send connectors> create send connectors>name internet and select under it the internet> i add smtp and put * and check the included sub>next and select use domain server " mx" > source server and select my own server> and hit finish.

i already fix my dns server and its working fine, im waiting for 15 mins and still no email has come to my yahoo >.<

help again and thnx :D
 
A

Aivar75

hi

after you sent a test email, did you tracked it also? or it shows in email queue, both tools are available in emc under tools,

also via shell... get-queue command (to see messages in mail queue)

and get-messagetrackinglog to see if email is sent outside or got ndr.

Just in case check your yahoo mail junk email ... might be there also.

also check from firewall do you have port 25 open from that email server, or just telnet some email server port 25 to see if port is open.
 
N

newb33

here's the result of get-queue:

[PS] C:\Windows\system32>Get-Queue
Identity DeliveryType Status MessageCount NextHopDomain
-------- ------------ ------ ------------ -----------
archie\8 DnsConnec... Con... 4 yahoo.com
archie\Submission Undefined Ready 0 Submission

after i type again th command here's the result:
[PS] C:\Windows\system32>Get-Queue
Identity DeliveryType Status MessageCount NextHopDomain
-------- ------------ ------ ------------ -----------
archie\8 DnsConnec... Retry 4 yahoo.com
archie\Submission Undefined Ready 0 Submission

in the queue viewer:

next hop domain delivery type status message count next try last error

yahoo.com dnsConnectorDelivery retry 4 n541 4.4.0 primary targetip address responded with " 421 4.2.1 unable to connect " attempted failove to alternate host, but that did not suceed. either... connect

>.< i have been searching for hours on how am i gonna work this >.

i didnt receive anything in my yahoo accnt and the port 25 is open, i could telnet it :D

thanks again sir ^^
 
A

Aivar75

hi

by any chance you have some antivirus program installed on exchange server what might block smtp traffic?

because 4.4.0 primary targetip address responded with " 421 4.2.1 unable to connect " attempted failove to alternate host, but that did not suceed. either... connect refers that your erxchange server is unable to connect to yahoo.com mx server on port25.

have you tried any other email server, hotmail, gmail etc?
 
N

newb33

hi ^^

i dont have any antivirus in my pc1 and i already disabled its own firewall. i tried it on gmail and still nothing comes T T.

also i noticed in my outlook that the message didn't send and it was delayed.

thanks
 
A

Aivar75

hi

please be so kind and run command get-sendconnector | fl ,and paste output, might be something in the connector ...
 
N

newb33

[PS] C:\Windows\system32>get-sendconnector | fl
AddressSpaces : {SMTP:*;1}
AuthenticationCredential :
Comment :
ConnectedDomains : {}
ConnectionInactivityTimeOut : 00:10:00
DNSRoutingEnabled : True
DomainSecureEnabled : False
Enabled : True
ForceHELO : False
Fqdn :
HomeMTA : Microsoft MTA
HomeMtaServerId : PC1
Identity : internet
IgnoreSTARTTLS : False
IsScopedConnector : False
IsSmtpConnector : True
LinkedReceiveConnector :
MaxMessageSize : 10 MB (10,485,760 bytes)
Name : internet
Port : 25
ProtocolLoggingLevel : None
RequireTLS : False
SmartHostAuthMechanism : None
SmartHosts : {}
SmartHostsString :
SmtpMaxMessagesPerConnection : 20
SourceIPAddress : 0.0.0.0
SourceRoutingGroup : Exchange Routing Group (DWBGZMFD01QNBJR)
SourceTransportServers : {PC1}
UseExternalDNSServersEnabled : False
thank you
 
A

Aivar75

connector seems fine, tho one thing you could to is set Fqdn: value to your mx name whats registered outside. ie mail.domain.com or whatever you ave registered.

as remote domains will try to make reverse check on the ip address and see if sender is what he claims to be.

other than that its ok. as i assume if you sent test emails to hotmail and gmail as well they are in queue with same error message?
 
N

newb33

" other than that its ok. as i assume if you sent test emails to hotmail and gmail as well they are in queue with same error message?"

yes they have the same error gmail and yahoo and it seems they were stuck and cant get out. hmm what could be the problem? T T

next hop domain delivery type status message count next try last error

yahoo.com dnsConnectorDelivery retry 6 n541 4.4.0 primary targetip address responded with " 421 4.2.1 unable to connect " attempted failove to alternate host, but that did not suceed. either... connect

next hop domain delivery type status message count next try last error

gmail.com dnsConnectorDelivery retry 1 n541 4.4.0 primary targetip address responded with " 421 4.2.1 unable to connect " attempted failove to alternate host, but that did not suceed. either... connect

thanks again
 
A

Aivar75

still would like to do some tests for me while logged on exchange server

try to telnet to 2 places.

telnet mx1.hotmail.com 25

if success you should see message like this:

220 bay0-mc2-f39.Bay0.hotmail.com Sending unsolicited commercial or bulk e-mail
to Microsoft's computer network is prohibited. Other restrictions are found at h
ttp://privacy.msn.com/Anti-spam/. Violations will result in use of equipment loc
ated in California and other states. Tue, 2 Nov 2010 04:05:12 -0700

telnet a.mx.mail.yahoo.com 25

if success you should see from cmd windows line like this:

220 mta124.mail.ac4.yahoo.com ESMTP YSmtp service ready
 
N

newb33

for hotmail:

C:\Users\Administrator>telnet mx1.hotmail.com 25
Connecting To mx1.hotmail.com...

yahoo:

C:\Users\Administrator>telnet a.mx.mail.yahoo.com 25
Connecting To a.mx.mail.yahoo.com...Could not open connection to the host, on po
rt 25: Connect failed

omg >.<

ty
 
A

Aivar75

yay

finally , seems you have port 25 closed :), probably from your firewall side (not on pc1 firewall) but router/firewall probably same box what is your default gw atm. and thats why you cant send emails outside. open port 25 from your router/firewall to allow emails sent to outside from pc1 and everything starts working.
 
N

newb33

this is my default gateway which the isp provided to me 222.127.84.1

in my network my router ip is 192.168.20.1

pc1 192.168.20.2 which is dc

pc2 192.168.20.3

http://www.canyouseeme.org/

i used this site to see if my port 25 is open or not and:

Error: I could not see your service on 222.127.84.75 on port (25 )
Reason:<small> Connection timed out</small>

i'll try and search on how am i gonna open the port 25

thank you again sir you are very helpful god bless you :D
 
N

newb33

one last question before i closed this thread ^^. im sorry if im bothering you guys so much i kind on need this.

i resolved the sending of mails from outside (thanks avira for your help ^^) now, the problem is that when i tried to reply from yahoo to my exchange server account it does not receive. it just bounce back to my yahoo account:

it seems yahoo cant find my domain >.< although i check the hub transport default receiver to anonymous in server configuration.

im at loss here T T

thanks again and im very grateful for your help
 
A

Aivar75

hi

good that you managed to fix your problem, for the next problem theres couple issues to check

1. have you opened port 25 outside world to your exchange server internal ip port 25?

2. have you registered mx record for your domain in external dns? ie mail.domain.com mx 10 (also do ptr record)

3. recipient policy in exchange, are you making email addresses @domain.com and do you accept @domain.com domain at all.

probably nr 3 works as you have managed to send test emails from pc1 to pc2 and vice vesa.
 
Status
Not open for further replies.
Top