Migration Exchange 2003 to 2010: OUT OFFICE ISSUE

  • Thread starter Jungle_men
  • Start date Views 4,212
Status
Not open for further replies.
J

Jungle_men

Hi people,

Im in the proccess of migrate exchange 2003 to 2010. I have an Issue with OOF assistant in the mailboxes moved to the new exchange 2010. When you select Out of Office assistan, it is displayed that cannot connect to the server. The situation is:

[PS] C:\Windows\system32>Get-PublicFolder -identity " \non_ipm_subtree\schedule+ free busy" -recurse | fl name, replicas (from the new CAS and HUB exchange 2010 server). (SRV-MAIL is the legacy one):
Name : SCHEDULE+ FREE BUSY
Replicas : {}
Name : EX:/o=MAIL-TEST/ou=Exchange Administrative Group (FYDIBOHF23SPDLT)
Replicas : {Public Folder Database, SRV-MAIL\First Storage Group\Public Store Folder (SRV-MAIL)}
Name : EX:/o=MAIL-TEST/ou=Primer grupo administrativo
Replicas : {Public Folder Database, SRV-MAIL\First Storage Group\Public Store Folder (SRV-MAIL)}

[PS] C:\Windows\system32>Test-OutlookWebServices | fl
WARNING: There was an error and its beeing makins a watson dump: Error finding the mailboxes.
Mailbox = 'extest_4de50c2c7b624@test.local'.
Error finding the mailboxes. Mailbox = 'extest_4de50c2c7b624@test.local'.
+ CategoryInfo : NotSpecified: :)) [Test-OutlookWebServices], MailboxNotFoundException
+ FullyQualifiedErrorId : Microsoft.Exchange.Monitoring.MailboxNotFoundException,Microsoft.Exchange.Management.Sys
temConfigurationTasks.TestOutlookWebServicesTask

I think i have running public and system replication folders:
[PS] C:\Windows\system32>Get-PublicFolder -identity " \non_ipm_subtree\" -recurse | fl name, replicas
Name : NON_IPM_SUBTREE
Replicas : {}
Name : EFORMS REGISTRY
Replicas : {}
Name : Events Root
Replicas : {Public Folder Database}
Name : EventConfig_SRV-MAIL
Replicas : {SRV-MAIL\First Storage Group\Public Store Folder (SRV-MAIL)}
Name : OFFLINE ADDRESS BOOK
Replicas : {}
Name : /o=MAIL-TEST/cn=addrlists/cn=oabs/cn=msExchOAB71673539
Replicas : {Public Folder Database, SRV-MAIL\First Storage Group\Public Store Folder (SRV-MAIL)}
Name : OAB Version 2
Replicas : {Public Folder Database, SRV-MAIL\First Storage Group\Public Store Folder (SRV-MAIL)}
Name : OAB Version 3a
Replicas : {Public Folder Database, SRV-MAIL\First Storage Group\Public Store Folder (SRV-MAIL)}
Name : OAB Version 4
Replicas : {Public Folder Database, SRV-MAIL\First Storage Group\Public Store Folder (SRV-MAIL)}
Name : /o=MAIL-TEST/cn=addrlists/cn=oabs/cn=OAB Exch
Replicas : {Public Folder Database}
Name : OAB Version 2
Replicas : {Public Folder Database}
Name : OAB Version 3a
Replicas : {Public Folder Database}
Name : OAB Version 4
Replicas : {Public Folder Database}
Name : EX:/o=MAIL-TEST/ou=Exchange Administrative Group (FYDIBOHF23SPDLT)
Replicas : {Public Folder Database, SRV-MAIL\First Storage Group\Public Store Folder (SRV-MAIL)}
Name : EX:/o=MAIL-TEST/ou=First Storage Group
Replicas : {Public Folder Database, SRV-MAIL\First Storage Group\Public Store Folder (SRV-MAIL)}
Name : OWAScratchPad{23903A23-DBC4-4B88-90DB-523A283EE6EA}
Replicas : {}
Name : OWAScratchPad{DCE0185E-BEEE-4D67-B350-C0BA5E3FAD35}
Replicas : {SRV-MAIL\First Storage Group\Public Store Folder (SRV-MAIL)}
Name : SCHEDULE+ FREE BUSY
Replicas : {}
Name : EX:/o=MAIL-TEST/ou=Exchange Administrative Group (FYDIBOHF23SPDLT)
Replicas : {Public Folder Database, SRV-MAIL\First Storage Group\Public Store Folder (SRV-MAIL)}
Name : EX:/o=MAIL-TEST/ou=First Storage Group
Replicas : {Public Folder Database, SRV-MAIL\First Storage Group\Public Store Folder (SRV-MAIL)}
Name : schema-root
Replicas : {}
Name : Default
Replicas : {SRV-MAIL\First Storage Group\Public Store Folder (SRV-MAIL)}
Name : microsoft
Replicas : {}
Name : exchangeV1
Replicas : {SRV-MAIL\PFirst Storage Group\Public Store Folder (SRV-MAIL)}
Name : StoreEvents{23903A23-DBC4-4B88-90DB-523A283EE6EA}
Replicas : {}
Name : globalevents
Replicas : {}
Name : internal
Replicas : {}
Name : StoreEvents{DCE0185E-BEEE-4D67-B350-C0BA5E3FAD35}
Replicas : {SRV-MAIL\First Storage Group\Public Store Folder (SRV-MAIL)}
Name : globalevents
Replicas : {SRV-MAIL\First Storage Group\Public Store Folder (SRV-MAIL)}
Name : internal
Replicas : {SRV-MAIL\First Storage Group\Public Store Folder (SRV-MAIL)}

The public folders still in both exchange servers, and public folder hierarchy wasnt be modified yet...

any suggestion?...

thanks in advanced
 
J

Jungle_men

Well,

Currently, both of Anonymous and Integrated authentication (no more) are the only that are enabled on EWS directory...

any more suggestion?

should I enable forms authentication?...
 
J

Jungle_men

Another clue:

In the IIS/EWS virtual directory log, when i launched the OOF from Outlook:

2010-11-29 15:03:18 192.168.100.95 POST /EWS/Exchange.asmx ;RC:36450482-2198-4fc7-9399-39099da07dab;Init>>Conn:0,HangingConn:0,AD:30000/30000/0%,CAS:54000/54000/0%,AB:30000/30000/0%,RPC:36000/36000/0%,FC:1000/0,Policy:DefaultThrottlingPolicy_2c9793fb-0586-4675-8a12-d19e44f3006f,Norm,Sub:5000/0;SoapAction=GetUserOofSettingsResponse;MailboxRPCRequests=0;MailboxRPCLatency=0;ADRequests=0;ADLatency=0;TimeInGetUserOOFSettings=0;ErrorCode=ErrorNonPrimarySmtpAddress;[C]Queues:0msec/Execute:0msec;End(0ms)

So, as I didnt upgrade the address policy to Exchange 2010, probably is not detecting a configure smtp address???

That was another question that I posted here in the forum...i didnt upgrade the address policy from Exchange 2003 to 2010 because I have yet mailboxes in the exchange 2003, and I dont know if there could be issues with that users...
 
Z

zeisii

Like Leif was already pointing to another thread, it might not be PF or authentication issue but Proxy settings in IE on the Workstation...see Santosh Sivaraman post - http://social.technet.microsoft.com/Forums/en/exchange2010/thread/94c5828f-07ab-4646-a551-6c4cf868d2d9

Check that there is no Proxy used or if it is - bypass Proxy for the CAS server (OL client traffic which is going towards CAS server EWS, crashes on the Proxy server, if CAS is not bypassed with exception)

Seen this couple of times in customer environments...

/jc

/jc
 
J

Jungle_men

Some clues about my issue:

Only three mailboxes migrated to the new Exchange 2010 server. One uses the Outlook 2010, and two the Outlook 2003 (so I think its about some hot fix of Outlook). All same issue, can´t configure OOF from Outlook, but yes from OWA.

We haven´t got proxy configure, we have the correct permisions on the EWS directory...but still having same problem..

Any more suggestion?...
 
J

Jungle_men

And, when i launched https://srv-mail.domain.local/EWS/Exchange.asmx, im asked about user/password domain (with certificate error...), and then its displayed a page like:

<?xml version=" 1.0" encoding=" utf-8" ?>

- <wsdl:definitions xmlns:soap=" http://schemas.xmlsoap.org/wsdl/soap/" xmlns:tns=" http://schemas.microsoft.com/exchange/services/2006/messages" xmlns:s=" http://www.w3.org/2001/XMLSchema" targetNamespace=" http://schemas.microsoft.com/exchange/services/2006/messages" xmlns:wsdl=" http://schemas.xmlsoap.org/wsdl/" xmlns:t=" http://schemas.microsoft.com/exchange/services/2006/types" >

- <wsdl:types>

- <xs:schema xmlns:xs=" http://www.w3.org/2001/XMLSchema" >
<xs:import namespace=" http://schemas.microsoft.com/exchange/services/2006/messages" schemaLocation=" messages.xsd" />
</xs:schema>
</wsdl:types>

- <wsdl:message name=" UploadItemsSoapIn" >
<wsdl:part name=" request" element=" tns:UploadItems" />
<wsdl:part name=" Impersonation" element=" t:ExchangeImpersonation" />
<wsdl:part name=" MailboxCulture" element=" t:MailboxCulture" />
<wsdl:part name=" RequestVersion" element=" t:RequestServerVersion" />
</wsdl:message>

- <wsdl:message name=" UploadItemsSoapOut" >
<wsdl:part name=" UploadItemsResult" element=" tns:UploadItemsResponse" />
<wsdl:part name=" ServerVersion" element=" t:ServerVersionInfo" />
</wsdl:message>

- <wsdl:message name=" ExportItemsSoapIn" >
<wsdl:part name=" request" element=" tns:ExportItems" />
<wsdl:part name=" Impersonation" element=" t:ExchangeImpersonation" />
<wsdl:part name=" MailboxCulture" element=" t:MailboxCulture" />
<wsdl:part name=" RequestVersion" element=" t:RequestServerVersion" />
</wsdl:message>

- <wsdl:message name=" ExportItemsSoapOut" >
<wsdl:part name=" ExportItemsResult" element=" tns:ExportItemsResponse" />
<wsdl:part name=" ServerVersion" element=" t:ServerVersionInfo" />

and so .....etc...

thanks...
 
J

Jungle_men

Solved,

Once the certified was installed, started to work.

thanks to all people
 
Status
Not open for further replies.
Top