Exchange 2010 SP1 Event id 9040 : Unable to save watermarks

Status
Not open for further replies.
M

matyke

Dear all,

I'm getting quite periodically (each 2-5 minutes) this error in event log. Can anybody guide me what's wrong?
Service MSExchangeMailSubmission. An exception has been handled on behalf of an assistant. A report will be sent for the following exception: Microsoft.Exchange.Assistants.AIGrayException ---> Microsoft.Exchange.Common.GrayException ---> Microsoft.Mapi.MapiExceptionPartialCompletion: MapiExceptionPartialCompletion: Unable to save watermarks. (hr=0x40680, ec=0)
Diagnostic context:
Lid: 1494 ---- Remote Context Beg --
Lid: 10804 StoreEc: 0xFFFFF9BF
Lid: 25094
Lid: 13710 StoreEc: 0x89B
Lid: 14672 StoreEc: 0x40680
Lid: 2031 StoreEc: 0x40680
Lid: 18009 StoreEc: 0x40680
Lid: 1750 ---- Remote Context End --
Lid: 32361 StoreEc: 0x40680
at Microsoft.Mapi.MapiExceptionHelper.ThrowIfErrorOrWarning(String message, Int32 hresult, Boolean allowWarnings, SafeExInterfaceHandle iUnknown, Exception innerException)
at Microsoft.Mapi.MapiEventManager.SaveWatermarks(Watermark[] watermarks)
at Microsoft.Exchange.Assistants.EventAccess.<>c__DisplayClassd.<SaveWatermarks>b__c()
at Microsoft.Exchange.Assistants.EventAccess.CallEventManager(EventManagerFunction function)
at Microsoft.Exchange.Assistants.EventControllerPrivate.UpdateIdleWatermarksForAssistant(Guid[] idleMailboxes, Guid assistantId)
at Microsoft.Exchange.Assistants.EventControllerPrivate.DisposeOfIdleDispatchers()
at Microsoft.Exchange.Assistants.EventController.<UpdateWatermarks>b__4()
at Microsoft.Exchange.Assistants.Util.<>c__DisplayClass1.<CoreCatchMeIfYouCan>b__0()
at Microsoft.Exchange.Common.IL.ILUtil.DoTryFilterCatch(TryDelegate tryDelegate, FilterDelegate filterDelegate, CatchDelegate catchDelegate)
--- End of inner exception stack trace -
at Microsoft.Exchange.Common.GrayException.ExceptionCatcher(Object exception)
at Microsoft.Exchange.Common.IL.ILUtil.DoTryFilterCatch(TryDelegate tryDelegate, FilterDelegate filterDelegate, CatchDelegate catchDelegate)
at Microsoft.Exchange.Common.GrayException.MapAndReportGrayExceptions(UserCodeDelegate tryCode)
at Microsoft.Exchange.Assistants.Util.CoreCatchMeIfYouCan(CatchMe function)
at Microsoft.Exchange.Assistants.Util.CatchMeIfYouCan(CatchMe function)
--- End of inner exception stack trace -
at Microsoft.Exchange.Assistants.Util.TraceAndThrow(CatchMe function, AIException aiException)
at Microsoft.Exchange.Assistants.Util.CatchMeIfYouCan(CatchMe function)
at Microsoft.Exchange.Assistants.Base.CatchMeIfYouCan(CatchMe function).
Event Xml:
<Event xmlns=" http://schemas.microsoft.com/win/2004/08/events/event" >
<System>
<Provider Name=" MSExchange Assistants" />
<EventID Qualifiers=" 16388" >9040</EventID>
<Level>4</Level>
<Task>1</Task>
<Keywords>0x80000000000000</Keywords>
<TimeCreated SystemTime=" 2010-12-01T14:24:55.000000000Z" />
<EventRecordID>73855</EventRecordID>
<Channel>Application</Channel>
<Computer>euprg1nt501.das4net.com</Computer>
<Security />
</System>
<EventData>
<Data>MSExchangeMailSubmission</Data>
<Data>Microsoft.Exchange.Assistants.AIGrayException ---&gt; Microsoft.Exchange.Common.GrayException ---&gt; Microsoft.Mapi.MapiExceptionPartialCompletion: MapiExceptionPartialCompletion: Unable to save watermarks. (hr=0x40680, ec=0)
Diagnostic context:
Lid: 1494 ---- Remote Context Beg --
Lid: 10804 StoreEc: 0xFFFFF9BF
Lid: 25094
Lid: 13710 StoreEc: 0x89B
Lid: 14672 StoreEc: 0x40680
Lid: 2031 StoreEc: 0x40680
Lid: 18009 StoreEc: 0x40680
Lid: 1750 ---- Remote Context End --
Lid: 32361 StoreEc: 0x40680
at Microsoft.Mapi.MapiExceptionHelper.ThrowIfErrorOrWarning(String message, Int32 hresult, Boolean allowWarnings, SafeExInterfaceHandle iUnknown, Exception innerException)
at Microsoft.Mapi.MapiEventManager.SaveWatermarks(Watermark[] watermarks)
at Microsoft.Exchange.Assistants.EventAccess.<&gt;c__DisplayClassd.<SaveWatermarks&gt;b__c()
at Microsoft.Exchange.Assistants.EventAccess.CallEventManager(EventManagerFunction function)
at Microsoft.Exchange.Assistants.EventControllerPrivate.UpdateIdleWatermarksForAssistant(Guid[] idleMailboxes, Guid assistantId)
at Microsoft.Exchange.Assistants.EventControllerPrivate.DisposeOfIdleDispatchers()
at Microsoft.Exchange.Assistants.EventController.<UpdateWatermarks&gt;b__4()
at Microsoft.Exchange.Assistants.Util.<&gt;c__DisplayClass1.<CoreCatchMeIfYouCan&gt;b__0()
at Microsoft.Exchange.Common.IL.ILUtil.DoTryFilterCatch(TryDelegate tryDelegate, FilterDelegate filterDelegate, CatchDelegate catchDelegate)
--- End of inner exception stack trace -
at Microsoft.Exchange.Common.GrayException.ExceptionCatcher(Object exception)
at Microsoft.Exchange.Common.IL.ILUtil.DoTryFilterCatch(TryDelegate tryDelegate, FilterDelegate filterDelegate, CatchDelegate catchDelegate)
at Microsoft.Exchange.Common.GrayException.MapAndReportGrayExceptions(UserCodeDelegate tryCode)
at Microsoft.Exchange.Assistants.Util.CoreCatchMeIfYouCan(CatchMe function)
at Microsoft.Exchange.Assistants.Util.CatchMeIfYouCan(CatchMe function)
--- End of inner exception stack trace -
at Microsoft.Exchange.Assistants.Util.TraceAndThrow(CatchMe function, AIException aiException)
at Microsoft.Exchange.Assistants.Util.CatchMeIfYouCan(CatchMe function)
at Microsoft.Exchange.Assistants.Base.CatchMeIfYouCan(CatchMe function)</Data>
</EventData>
</Event>

Martin
 
J

Jeremy Wood

I'm having the exact same error. I've noted one other post with a person having this. They moved the users to a different store, deleted and recreated it. This person had things in a test lab and my machines are in production, so that's not really an option.

I'd be interested to see what the answer is to this.

----Jer
 
J

Jeremy Wood

From what I have been able to put together so far, the MAPI error 0x40680 means it was unable to delete something. So this would definitely fall in line with the throttle based managed folders that I am currently working on.

Now I just have to figure out why it can't delete the item.

----Jer
 
M

matyke

Hello Jeremy,

I didn't create any managed folders policy, it's just fresh installation of exchange 2010 sp1 server. Is there possibility to identify which mailbox is affected with this issue?

Martin
 
J

Jeremy Wood

Martin;

I'm not 100% sure this error is associated with the managed folders. I didn't notice the error until I started configuring the managed folders. It's very possible the error was there before.

The hr=0x40680 error from what I can find through searching show an error deleting an item via MAPI. That is how I connected the 2 together. However, it would appear that other people are having problems with retention tag based managed folders not deleting messages as well. So I could be completely wrong.

I have been unable to determine which mailbox is causing the error so far.

----Jer
 
M

matyke

Hi all,

I tried to move all mailboxes to new database and delete old database and it helps. Strange watermarks error in event log stop appearing.

But I found other strange thing, my database was pretty weird. When I count size of all mailboxes it was around 11 GB, but edb file was 60GB!!! When I was migrating mailboxes, one mailbox was showing in moverequeststatistics size of mailbox was 10GB, but after migration in new database mailbox size was only 600MB.

When all mailboxes was migrated (even arbitration mailboxes), mailbox database cleaned (so no disconneted mailboxes showed in EMC), I tried to offline defragment edb file with eseutil, and after all that edb file was still 54GB without any mailbox at all!!!

So there was really something strange in database which cause this errors. My solution was to create new databases and move mailboxes to new one.

Martin
 
Status
Not open for further replies.
Similar threads
Thread starter Title Forum Replies Date
K Backup recommendation for Exchange 2010 SP1 on Hyperv 2008 R2 Exchange Server Administration 3
M Exchange 2010 SP1 DAG & CA ARCserve Backup r15 Exchange Server Administration 1
A Exchange 2010 SP1 Edge Server ( Content Filtering ) Exchange Server Administration 0
F AD RMS with Exchange 2010 SP1 Exchange Server Administration 4
D Exchange Server 2010 SP1 Hosted Mode, service@ mailbox creation Exchange Server Administration 1
I Event ID 2937 after update to Exchange 2010 SP1 ArbitrationMailbox Exchange Server Administration 4
M Exchange 2010 SP1 Hosted Mode - how to move mailbox from old organization? Exchange Server Administration 1
S Owa failed to initialize after install of rollup 2 for Exchange 2010 SP1 Exchange Server Administration 9
P Journaling deployment Exchange 2010 SP1 RU1 Exchange Server Administration 1
I Event ID 2937 after update to Exchange 2010 SP1 Exchange Server Administration 8
G Exchange 2010 upgrade with SP1, language pack issue Exchange Server Administration 5
R Dynamic DNS update requirement for Exchange 2010 (SP1 RU1) on server 2008 r2 Exchange Server Administration 8
P Number of database on a server in DAG Exchange 2010 sp1 Exchange Server Administration 3
N Exchange 2007 SP1 + Outlook 2007/2010 - Autodiscover for Outlook Anywhere and Out of Office not working Using Outlook 1
A NetBackup 7.0 configuration for Exchange 2010 SP1 Exchange Server Administration 3
D Exchange 2010 SP1 OWA "reply" or "forward" error Exchange Server Administration 3
K Question about Exchange 2010 SP1 RU2 update Exchange Server Administration 3
J Exchange 2010 SP1 fails at Mailbox Error Unable to load exrpc32.dll Exchange Server Administration 4
D Exchange 2010 SP1 Policy to Delete mail in deleted items older than 30 days Exchange Server Administration 2
à Validating build of Exchange 2010 SP1 Exchange Server Administration 1
D Exchange 2010 SP1 topology prep error Exchange Server Administration 3
I Exchange 2010 sp1 Address Book service won't start after static RPC port reconfiguration Exchange Server Administration 2
D Installing SP1 for Exchange 2010 Exchange Server Administration 2
B Blank email list views on Outlook 2010 / 2007 with Exchange 2010 SP1 (on Citrix and Desktops) Using Outlook 7
S Exchange 2010 SP1 OWA Error Exchange Server Administration 2
P Mircrosoft Exchange 2010 SP1 Email Purge Exchange Server Administration 2
P Error 4999 after Exchange 2010 SP1 - No BES server Exchange Server Administration 12
D Upgraded to Exchange 2010 SP1 and now random Outlook clients are requesting authentication Exchange Server Administration 1
Q Don't have right permissions to assign "send as" rights in Exchange 2010 SP1 Exchange Server Administration 7
M Proper way to install Exchange 2010 SP1 on a CAS Array Exchange Server Administration 3
C Exchange 2010 SP1 "RPC can't be started because of the EMSMDB interface is already registered by Exchange Server Administration 4
N Failed Exchange 2010 SP1 Installation PowerShell "unauthorized operation" Exchange Server Administration 2
L Does Exchange 2010 SP1 update any Schema objects Exchange Server Administration 2
T After updating Exchange 2010 from RTM to SP1, OWA clients cannot move or delete emails Using Outlook 4
A The cluster network name is not online Exchange 2010 sp1 DAG Exchange Server Administration 8
P Exchange 2010 SP1 Cross Site CAS connection disable Exchange Server Administration 2
A Exchange 2010 SP1 RU1 Calendar Retention Exchange Server Administration 1
M Do Database Storage Limits in Exchange 2010 SP1 affect Archive mailboxes? Exchange Server Administration 5
L Exchange 2010 SP1 Pre-Req error Exchange Server Administration 2
W Exchange 2010 SP1 Install- Required HotFixes Exchange Server Administration 3
N Second Mailbox, Mails stuck in Outbox Outlook 2010, Exchange 2010 SP1 Using Outlook 8
S Determine Managed Folder Policy for Mailbox in Powershell Exchange 2010 SP1 Exchange Server Administration 4
C Installing Exchange 2010 SP1 in a Sub domain... Exchange Server Administration 5
K Exchange 2010 SP1 RU1 - Get-PublicFolderDatabase bug / documentation issue? Exchange Server Administration 6
D Ms Exchange 2010 - Sp1 Upgrade at Prerequisites on Hub Transport Role Exchange Server Administration 8
M Error Publishing Exchange 2010 SP1 OWA through ISA 2006 SP2 Exchange Server Administration 14
C Managed Folder does not show up in Outlook in Exchange 2010 Sp1 Rollup 1 Exchange Server Administration 3
J After Applying Exchange 2010 Sp1 Rollup the Build numbers in EMC remain unchanged 14.1.218.15 Exchange Server Administration 1
M how to upgrade exchange 2010 to exchange 2010 sp1 Exchange Server Administration 2
J Mailbox Export Import issue on Exchange 2010 SP1 Exchange Server Administration 4

Similar threads

Top