CANNOT get rid of Exchange 2010 error "An IIS directory entry couldn't be created. The error message

Status
Not open for further replies.
J

Jude Quintana

3 Domain Controllers on Windows 2003 sp2 servers(all updates applied to meet exchange 2010 pre-requisites)

2 exchange 2003 sp2 on Windows 2003 sp2 servers (all updates applied to meet exchange 2010 pre-requisites)

2 exchange 2010 sp1 rollup 1 on Windows 2008 R2 sp2 servers

-----------------------We are migrating exchange 2003 to exchange 2010. We have built exchange 2010 with CAS, HUB, MAILBOX roles and OWA, etc enabled on server16 and everything seems to be working fine and CAN manage OWA. We decided to add a secondary exchange 2010 server with CAS, HUB, MAILBOX roles and OWA , etc enabled on server26 (with all the permissions being the same as on server16). However, when we go to the EMC -> 'Server Configuration' -> 'Client Access' -> 'Select Server26' -> 'Select properties on owa from Outlook WebApp tab', I get the error:

" An IIS directory entry couldn't be created. The error message is Access is denied.

> HResult = -2147024891 It was running the command 'Get-OwaVirtualDirectory -Identity 'Server26\owa(Default Website)" .

NOTE: that OWA is working on server26, just CANNOT manage it.

Output from EMS:

[PS] C:\Windows\system32>get-owavirtualdirectory -verbose

VERBOSE: [21:42:14.725 GMT] Get-OwaVirtualDirectory : Initializing Active Directory server settings for the remote

Windows PowerShell session.

VERBOSE: [21:42:14.725 GMT] Get-OwaVirtualDirectory : Active Directory session settings for 'Get-OwaVirtualDirectory'

are: View Entire Forest: 'False', Default Scope: 'municipal.net', Configuration Domain Controller:

'SERVER1.municipal.net', Preferred Global Catalog: 'SERVER1.municipal.net', Preferred Domain Controllers: '{

SERVER1.municipal.net }'

VERBOSE: [21:42:14.725 GMT] Get-OwaVirtualDirectory : Runspace context: Executing user:

municipal.net/Users/Administrator, Executing user organization: , Current organization: , RBAC-enabled: Enabled.

VERBOSE: [21:42:14.725 GMT] Get-OwaVirtualDirectory : Beginning processing &

VERBOSE: [21:42:14.756 GMT] Get-OwaVirtualDirectory : Current ScopeSet is: { Recipient Read Scope: {{, }}, Recipient

Write Scopes: {{, }}, Configuration Read Scope: {{, }}, Configuration Write Scope(s): {{, }, }, Exclusive Recipient

Scope(s): {}, Exclusive Configuration Scope(s): {} }

VERBOSE: [21:42:14.756 GMT] Get-OwaVirtualDirectory : Resolved current organization: .

VERBOSE: [21:42:14.756 GMT] Get-OwaVirtualDirectory : Searching objects of type " ADOwaVirtualDirectory" with filter

" $null" , scope " SubTree" under the root " $null" .

VERBOSE: [21:42:14.803 GMT] Get-OwaVirtualDirectory : Previous operation run on domain controller

'SERVER1.municipal.net'.

VERBOSE: [21:42:14.803 GMT] Get-OwaVirtualDirectory : Preparing to output objects. The maximum size of the result set

is " unlimited" .

An IIS directory entry couldn't be created. The error message is Access is denied.

> HResult = -2147024891
+ CategoryInfo : NotInstalled: (SERVER16\owa (Default Web Site):ADObjectId) [Get-OwaVirtualDirectory], II
SGeneralCOMException
+ FullyQualifiedErrorId : E00EF6F9,Microsoft.Exchange.Management.SystemConfigurationTasks.GetOwaVirtualDirectory

Name Server OwaVersion

---- ------ --------
owa (Default Web Site) SERVER26 Exchange2010

VERBOSE: [21:42:15.006 GMT] Get-OwaVirtualDirectory : Ending processing &

-----------------------We've scoured the ends of the internet and have tried all kinds of potential solutions below WITHOUT SUCCESS:

through active directorty added Exchange Trusted Subsystem to local Administrator on both exchange 2010 and exchange 2003. Added computers (All 4 exchange servers) to the Exchange Trusted Subsystem Group. Restarted all servers.

on both exchange 2003 servers and DC windows2003 servers, dcomcnf -> Component Services -> My computer properties -> default impersonation level was already at 'Impersonate' (although the DCs were initially at 'Identify' but changed them to 'Impersonate' as well, not sure if that matters)

reset owa-virtual directory through the EMC on server26.

Tried adding full control permissions for Exchange Trusted Subsystem on both the inetpub directory and on the default website under IIS on server26.

made sure all modules below were installed for exchange 2010 on server26:

Add-WindowsFeature NET-Framework,RSAT-ADDS,Web-Server,Web-Basic-Auth,Web-Windows-Auth,Web-Metabase,Web-Net-Ext,Web-Lgcy-Mgmt-Console,WAS-Process-Model,RSAT-Web-Server,Web-ISAPI-Ext,Web-Digest-Auth,Web-Dyn-Compression,NET-HTTP-Activation,RPC-Over-HTTP-Proxy

-----------------------Since there's an obvious permissions issue not sure these other issues below are directly related. Its as if it doesnt have sufficient permissions to talk to itself even though we are domain administrator (with local administrator having Exchange Trusted Subsystem permissions)

when trying to enable outlook anywere on server26 i get the following error:

Summary: 1 item(s). 0 succeeded, 1 failed.

Elapsed time: 00:00:00

SERVER26

Failed

Error:

Web object 'IIS://SERVER26.municipal.net/W3SVC/1/ROOT' can't be found.

Access is denied.

Click here for help... http://technet.microsoft.com/en-US/...=14.1.218.11&t=exchgf1&e=ms.exch.err.Ex16603D

Exchange Management Shell command attempted:

enable-OutlookAnywhere -Server 'SERVER26' -ExternalHostname 'anywhere2.estes.org' -DefaultAuthenticationMethod 'Basic' -SSLOffloading $false

Elapsed Time: 00:00:00

-----------------------when creating public folder on server26:

Summary: 2 item(s). 0 succeeded, 1 failed.

Elapsed time: 00:00:00

New Public Folder 26

Failed

Error:

Failed to connect to target server " SERVER26" . Error: WMI exception occurred on server 'SERVER26.municipal.net': Access is denied. (Exception from HRESULT: 0x80070005 (E_ACCESSDENIED))

Exchange Management Shell command attempted:

new-publicfolderdatabase -Server 'SERVER26' -Name 'Public Folder 26' -EdbFilePath 'D:\Program Files\Microsoft\Exchange Server\V14\Mailbox\Public Folder 26\Public Folder 26.edb' -LogFolderPath 'D:\Program Files\Microsoft\Exchange Server\V14\Mailbox\Public Folder 26'

Elapsed Time: 00:00:00

Mount Public Folder 26

Cancelled

-----------------------We've run out of ideas and are in dire need of anyone that can help. Any ideas?

Thanks,

Jude
 
J

Jude Quintana

UPDATE:

So server26 (secondary exchange 2010 server) in the 'Microsoft Exchange On-Premises' properties was pointing to server16. So we told it to point to itself. Now we can manage OWA, enable outlook anywhere and create public folder without a problem. However, now when i try to manage owa on server16 from server26 im getting the access denied when trying to run get-owavirtualdirectory although i can manage owa on server16 without a problem. I'm very confused am i missing something in how 2 exchange 2010 servers are supposed to coexist and talk to eachother? are the EMCs only supposed to manage themselves?

Thanks,

Jude
 
Status
Not open for further replies.
Similar threads
Thread starter Title Forum Replies Date
I Many empty Contacts folders.. cannot get rid of them Using Outlook 4
S Custom Field Cannot Be Displayed In Views Outlook VBA and Custom Forms 2
G Cannot Move Autocomplete File to New Computer Using Outlook 15
rubaboo The vew cannot be found Outlook VBA and Custom Forms 0
A Cannot copy this folder because it may contain private items Using Outlook 0
L Cannot open PST file for first session each day Using Outlook 6
David in Mississippi New (Feb 2020) install of Outlook 365 - Cannot specify PST for different accounts Using Outlook 0
Marc2019 Need help please! Cannot Setup my outlook email account on my Mac Outlook 2011 Using Outlook.com accounts in Outlook 2
noshairwan Registry cannot be found, Outlook Security Using Outlook 2
Marc2019 Cannot input Vietnamese Characters on my MSOutlook 2016 in Windows 7 Using Outlook 0
T Cannot remove needless PST Using Outlook 1
Marc2019 Cannot setup Outlook Account on Mac Os 10.6.8 Using Outlook 3
N pst files are recreating automaticaly and cannot be deleted Using Outlook 5
Mark Foley Cannot enable add-in in outlook 2010 Using Outlook 0
T "cannot find the calendar folder for this item" - calendar items stuck in outbox Using Outlook 0
A Created a new user account and the local account cannot see email Using Outlook 3
iwshim outlook 2013 - I cannot see the "Manage Add-ins" Using Outlook 2
T Cannot connect to main BT email account, sub accts okay Using Outlook 0
O The page that you are trying to access cannot be loaded. Using Outlook 0
M Daily Task List Minimized Cannot Display Using Outlook 2
geofferyh Cannot get Macro to SAVE more than one message attachment??? Outlook VBA and Custom Forms 5
DariTrevino MIcrosoft Outlook PST file cannot repair Using Outlook 1
B One email cannot be sent or received (but leaves outbox!) Using Outlook 1
C Outlook 2016 cannot delete, email showing in root Exchange Server Administration 5
S Outlook.com cannot edit some contacts Using Outlook.com accounts in Outlook 5
B Search: Cannot find which Folder Contains a Message Using Outlook 3
C Outlook - cannot save subject line changes Using Outlook 2
M cannot change delivery folders with IMAP accounts Using Outlook 0
S Appointment-Cannot set Categories because ConversationID is not set Outlook VBA and Custom Forms 1
Fozzie Bear Cannot post "Sneaky URL"!! Using Outlook.com accounts in Outlook 2
Commodore Search cannot complete the indexing of your Outlook data Using Outlook 6
S Outlook 2010 Cannot Open Attachments Using Outlook 14
A Cannot Figure Out This VBA Outlook VBA and Custom Forms 2
A Cannot Figure Out One Thing on VBA Outlook VBA and Custom Forms 2
Brian Murphy Exchange Online Everything a Transport Rule should do and cannot Exchange Server Administration 1
A Error: The name cannot be matched to a name in the address list Using Outlook.com accounts in Outlook 0
K Other Shared Calendar on Outlook cannot change items Using Outlook.com accounts in Outlook 7
T Outlook 2016 cannot connect after transition to Outlook Mail Using Outlook.com accounts in Outlook 4
L Cannot Connect to BCM database BCM (Business Contact Manager) 9
A Cannot connect to BCM database BCM (Business Contact Manager) 3
Diane Poremsky The custom form cannot be opened. Outlook will use an Outlook form instead. New Slipstick.com Articles 0
T Cannot access outlook.com accounts in Outlook 2016 Using Outlook 1
T Outlook 2016 mp3 attach "this file cannot be preview because there is no previewer installed for it" Using Outlook 1
S Outlook data file cannot be accessed message Using Outlook 5
O Cannot open or save calendar items Using Outlook 0
J Can Click to Drag Custom Form Field But Cannot Drop When Designing in Outlook 2007 Outlook VBA and Custom Forms 2
Diane Poremsky Cannot start Microsoft Office Outlook Error Message New Slipstick.com Articles 0
wallisellener "The database name cannot exceed 50 characters" BCM (Business Contact Manager) 2
J Your IMAP server wants to alert you to the following: cannot remove system folder Using Outlook 3
G Calendar folder cannot be found (tasks folder cannot be found) Using Outlook 2

Similar threads

Top