Exchange 2010 SP1 OWA Error

Status
Not open for further replies.
S

syndoc1

We are getting the following error after logging into OWA. Prior to SP1 OWA was working fine. We have a separate CA server. The other roles are on another server. Both servers have been upgraded to SP1. The clients are working fine and so are " i" devices. OWA is the only app that is getting this error.

We have about 2300 mailboxes.

I have checked to make sure there is no host name configured in IIS under the bindings.

I have reset owa vd.

Nothing has worked so far.

Any help would be greatly appreciated.

Thanks

Request
Url:?ae=Item&a=Preview&t=IPM.Conversation&id=CID.tWcm0DpTSTeKgqim4tgO9Q%3d%3d.LgAAAABTm%2fEazM0vQ7

LSnjNhbdpoAQCMuorgKyP9Q5G8i8%2b1GKvcAAAANBYHAAAB.AQAAAAA0FgMAAAAAHyUAAAAAAAA%3d&calist=

16&canary=09d3167999f847c289b0cf519eb7ef0f&SP=1&subpage=ReadConversation.ascx

User host address: x.x.x.x
User:
EX Address: /o=/ou=First Administrative Group/cn=Recipients/cn=
SMTP Address:
OWA version: 14.1.255.0
Mailbox server:
Exception
Exception type: System.IO.FileNotFoundException
Exception message: Could not load file or assembly 'Microsoft.RightsManagementServices.Core, Version=6.1.0.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35' or one of its dependencies. The system cannot find the file specified.
Call stack

Microsoft.Exchange.Security.RightsManagement.RightsManagementException.IsPermanentFailure()

Microsoft.Exchange.Security.RightsManagement.RightsManagementException..ctor(RightsManagementFailureCode failureCode, LocalizedString message)

Microsoft.Exchange.Security.RightsManagement.Errors.ThrowOnErrorCode(Int32 hr, LocalizedString contextMessage)

Microsoft.Exchange.Security.RightsManagement.DrmClientUtils.GetServiceLocation(SafeRightsManagementSessionHandle sessionHandle, ServiceType serviceType, ServiceLocation serviceLocation, String issuanceLicense)

Microsoft.Exchange.Data.Storage.RightsManagement.RmsConfiguration.FirstOrgServiceLocationsCache.Refresh(Boolean throwExceptions)

Microsoft.Exchange.Data.Storage.RightsManagement.RmsConfiguration.FirstOrgServiceLocationsCache..ctor()

Microsoft.Exchange.Data.Storage.RightsManagement.RmsConfiguration.Load(Boolean isDataCenter)

Microsoft.Exchange.Data.Storage.RightsManagement.RmsClientManager.InitializeIRMConfig()

Microsoft.Exchange.Data.Storage.RightsManagement.RmsClientManager.Initialize()

Microsoft.Exchange.Data.Storage.RightsManagement.RmsClientManager.InitializeIfNeeded()

Microsoft.Exchange.Data.Storage.RightsManagement.RmsClientManager.get_IRMConfig()

Microsoft.Exchange.Clients.Owa.Core.UserContext.get_IsIrmEnabled()

Microsoft.Exchange.Clients.Owa.Premium.ConversationUtilities.LoadConversation(UserContext userContext, OwaStoreObjectId owaConversationId, PropertyDefinition[] requestedProperties)

Microsoft.Exchange.Clients.Owa.Premium.ReadConversation.OnLoad(EventArgs e)

System.Web.UI.Control.LoadRecursive()

System.Web.UI.Control.LoadRecursive()

System.Web.UI.Control.LoadRecursive()
System.Web.UI.Page.ProcessRequestMain(Boolean includeStagesBeforeAsyncPoint, Boolean includeStagesAfterAsyncPoint)
 
S

syndoc1

After talking to MS Support they had me run this command: Set-OwaVirtualDirectory " servername\owa (default web site)" -IRMEnabled $false

Replacing servername with your server name.

This solved the strange error we were getting.

Still not sure SP1 was a good idea to install just yet.

JS
 
S

Saamee

Even i had the same issue in Dev environment, but not with Prod. I had to run the same command to fix it.
 
Status
Not open for further replies.
Similar threads
Thread starter Title Forum Replies Date
K Backup recommendation for Exchange 2010 SP1 on Hyperv 2008 R2 Exchange Server Administration 3
M Exchange 2010 SP1 DAG & CA ARCserve Backup r15 Exchange Server Administration 1
A Exchange 2010 SP1 Edge Server ( Content Filtering ) Exchange Server Administration 0
F AD RMS with Exchange 2010 SP1 Exchange Server Administration 4
D Exchange Server 2010 SP1 Hosted Mode, service@ mailbox creation Exchange Server Administration 1
I Event ID 2937 after update to Exchange 2010 SP1 ArbitrationMailbox Exchange Server Administration 4
M Exchange 2010 SP1 Hosted Mode - how to move mailbox from old organization? Exchange Server Administration 1
S Owa failed to initialize after install of rollup 2 for Exchange 2010 SP1 Exchange Server Administration 9
P Journaling deployment Exchange 2010 SP1 RU1 Exchange Server Administration 1
I Event ID 2937 after update to Exchange 2010 SP1 Exchange Server Administration 8
G Exchange 2010 upgrade with SP1, language pack issue Exchange Server Administration 5
R Dynamic DNS update requirement for Exchange 2010 (SP1 RU1) on server 2008 r2 Exchange Server Administration 8
P Number of database on a server in DAG Exchange 2010 sp1 Exchange Server Administration 3
N Exchange 2007 SP1 + Outlook 2007/2010 - Autodiscover for Outlook Anywhere and Out of Office not working Using Outlook 1
A NetBackup 7.0 configuration for Exchange 2010 SP1 Exchange Server Administration 3
D Exchange 2010 SP1 OWA "reply" or "forward" error Exchange Server Administration 3
K Question about Exchange 2010 SP1 RU2 update Exchange Server Administration 3
J Exchange 2010 SP1 fails at Mailbox Error Unable to load exrpc32.dll Exchange Server Administration 4
D Exchange 2010 SP1 Policy to Delete mail in deleted items older than 30 days Exchange Server Administration 2
à Validating build of Exchange 2010 SP1 Exchange Server Administration 1
D Exchange 2010 SP1 topology prep error Exchange Server Administration 3
I Exchange 2010 sp1 Address Book service won't start after static RPC port reconfiguration Exchange Server Administration 2
D Installing SP1 for Exchange 2010 Exchange Server Administration 2
B Blank email list views on Outlook 2010 / 2007 with Exchange 2010 SP1 (on Citrix and Desktops) Using Outlook 7
P Mircrosoft Exchange 2010 SP1 Email Purge Exchange Server Administration 2
P Error 4999 after Exchange 2010 SP1 - No BES server Exchange Server Administration 12
D Upgraded to Exchange 2010 SP1 and now random Outlook clients are requesting authentication Exchange Server Administration 1
Q Don't have right permissions to assign "send as" rights in Exchange 2010 SP1 Exchange Server Administration 7
M Proper way to install Exchange 2010 SP1 on a CAS Array Exchange Server Administration 3
M Exchange 2010 SP1 Event id 9040 : Unable to save watermarks Exchange Server Administration 5
C Exchange 2010 SP1 "RPC can't be started because of the EMSMDB interface is already registered by Exchange Server Administration 4
N Failed Exchange 2010 SP1 Installation PowerShell "unauthorized operation" Exchange Server Administration 2
L Does Exchange 2010 SP1 update any Schema objects Exchange Server Administration 2
T After updating Exchange 2010 from RTM to SP1, OWA clients cannot move or delete emails Using Outlook 4
A The cluster network name is not online Exchange 2010 sp1 DAG Exchange Server Administration 8
P Exchange 2010 SP1 Cross Site CAS connection disable Exchange Server Administration 2
A Exchange 2010 SP1 RU1 Calendar Retention Exchange Server Administration 1
M Do Database Storage Limits in Exchange 2010 SP1 affect Archive mailboxes? Exchange Server Administration 5
L Exchange 2010 SP1 Pre-Req error Exchange Server Administration 2
W Exchange 2010 SP1 Install- Required HotFixes Exchange Server Administration 3
N Second Mailbox, Mails stuck in Outbox Outlook 2010, Exchange 2010 SP1 Using Outlook 8
S Determine Managed Folder Policy for Mailbox in Powershell Exchange 2010 SP1 Exchange Server Administration 4
C Installing Exchange 2010 SP1 in a Sub domain... Exchange Server Administration 5
K Exchange 2010 SP1 RU1 - Get-PublicFolderDatabase bug / documentation issue? Exchange Server Administration 6
D Ms Exchange 2010 - Sp1 Upgrade at Prerequisites on Hub Transport Role Exchange Server Administration 8
M Error Publishing Exchange 2010 SP1 OWA through ISA 2006 SP2 Exchange Server Administration 14
C Managed Folder does not show up in Outlook in Exchange 2010 Sp1 Rollup 1 Exchange Server Administration 3
J After Applying Exchange 2010 Sp1 Rollup the Build numbers in EMC remain unchanged 14.1.218.15 Exchange Server Administration 1
M how to upgrade exchange 2010 to exchange 2010 sp1 Exchange Server Administration 2
J Mailbox Export Import issue on Exchange 2010 SP1 Exchange Server Administration 4

Similar threads

Top