cannot uninstall EX2003 after transition to EX2010

Status
Not open for further replies.
R

rookie2010

Hi,

I did a transition from a singel Ex2003 server to an single Ex2010 multi-role server.

Mailboxes, Public Folders and everything is moved to the Ex2010 server.

When I tried to uninstall the Ex2003 from the Add/Remove programs, I get the following error messages.

Setup failed while installing sub-component Exchange ActiveSync with error code 0x80072030 (please consult the installation logs for a detailed description). You may cancel the installation or try the failed setup again.

Setup failed while installing sub-component Exchange OMA Browse with error code 0x80072030 (please consult the installation logs for a detailed description). You may cancel the installation or try the failed setup again.

and

When I use ASDIEDIT in the AD, the object is empty (" /dc=domain/cn=Configuration/cn=Services/cn=Microsoft Exchange/cn=org/cn=Administrative Groups/cn=First Administrative Group/cn=services/cn=server/cn=Protocols/cn=HTTP" ). I think those objects are moved to Ex2010 server and therefore those objects that setup is looking for is gone.

I tried to reinstall Ex2003 and uninstall it again and it did not work.

I do not want to manually remove the entries in AD because it may leave a lot of mess laying around in the AD.

Please help.

Best regards
 
E

Ed Crowley [MVP]

Did you consult the installation logs for a more detailed explanation?Ed Crowley MVP " There are seldom good technological solutions to behavioral problems."
 
C

Christian Weihs

Hi rookie2010,

How many time you want to spend in solving this issues? The fastest way is to
shut the system down an delete the server object with adsi from the AD.
No more is necessary...
http://support.microsoft.com/kb/833396/en-us

Did you reinstall Exchange with /DisasterRecovery. There could be some trouble
with the ClientApps folder - please check in IIS.

Best regards
Christian
 
R

rookie2010

I just use adsi to delete the EX2003 server object under
Configuration Container
CN=Configuration, DC=<var>Domain_Name</var> ,DC=com
CN=Services
CN=Microsoft Exchange
CN=<var>Your_Organization_Name
</var> CN=Administrative Groups
CN=<var>Your_Administrative_Group_Name_Or_Exchange5.5_Site_Name</var>
CN=Servers

I also found an object have the EX2003 server name and it is mailGateway class under
Configuration Container
CN=Configuration, DC=<var>Domain_Name</var> ,DC=com
CN=Services
CN=Microsoft Exchange
CN=<var>Your_Organization_Name
</var> CN=Connections
I wonder should I delete it also?
 
R

rookie2010

Dear Joe,

I was following the article, http://technet.microsoft.com/en-us/library/bb288905(EXCHG.80).aspx , and got an error on step 4 " Uninstall Exchange 2003 or Exchange 2000 by using Add or Remove Programs from Control Panel " and the error was

" Setup failed while installing sub-component Exchange ActiveSync with error code 0x80072030 (please consult the installation logs for a detailed description). You may cancel the installation or try the failed setup again."

Any ideas? Thanks,
 
N

Novak Wu

Hi,

When removing Exchange server 2003, please assure the following services are started.

IIS Admin Service

World Wide Web Publishing Service

Simple Mail Transport Protocol (SMTP)

Network News Transfer Protocol Service (NNTP)

If the error message persists, you have to remove Exchange 2003 manually via the following article which was mentioned by Christian:

http://support.microsoft.com/kb/833396

Thanks.

Novak


 
Status
Not open for further replies.
Top