Exchange 2010 SP1 fails at Mailbox Error Unable to load exrpc32.dll

Status
Not open for further replies.
J

JO.Chicago

Hello,

I have 2 servers, one with CAS, HUB and UM and another with MBX role. The first one upgraded fine to SP1, but the MBX server failed with the error below:

- The Admin RPC connection is being established with server " mailboxservername" .
- MapiExceptionLowLevelInitializationFailure: Unable to load exrpc32.dll or one of its dependent DLLs (extrace.dll, exchmem.dll, msvcr90.dll, etc)

So, right now only the CAS/HUB/UM server is in SP1, and the MBX in RTM. The system is still operational, hope no issues come up until I resolve that problem.

Please advice.

Thanks.
 
N

Novak Wu

Hi,

Based on my research, I suggest you remove the Discovery Search Mailbox and reboot the Mailbox server, and then run setup /m:upgrade to install SP1 again.

If the issue persists, please post the error message in the Event Log and ExchangeSetup.log for research.

Thanks.

Novak


 
J

JO.Chicago

Hi,

I had done already what Novak suggested and received the same error. Looking at the beginning of the ExchangeSetup.log file, I find several lines that seem to be a problem and similar lines repeat quite a bit. It seems that there are problems finding the information about the Mailbox Role server in Active Directory. There are no errors being logged with Active Directory and the 2 servers seem to be working just fine otherwise.

Any additional ideas?

Thanks

----------Exchange configuration container for the organization is 'CN=Microsoft Exchange,CN=Services,CN=Configuration,DC=MyDomain,DC=int'.
Exchange organization container for the organization is 'CN=MyExOrganization,CN=Microsoft Exchange,CN=Services,CN=Configuration,DC=MyDomain,DC=int'.
Setup will search for an Exchange Server object for the local machine with name '<MailboxRoleServerName>'.
No Exchange Server with identity '<MailboxRoleServerName>' was found .
The following roles have been unpacked:
The following datacenter roles are unpacked:
The following roles are installed:
The local server does not have any Exchange files installed.
---------------**************
Setup will run the task 'test-setuphealth'
Setup launched task 'test-setuphealth -DomainController '<DomainControllerServerHost>' -DownloadConfigurationUpdates $true -ExchangeVersion '14.0.639.21' -Roles 'LanguagePacks' -ScanType 'PrecheckInstall' -SetupRoles 'LanguagePacks','AdminTools','Mailbox' -TargetDir 'C:\Program Files\Microsoft\Exchange Server\V14' -LanguagePackDir 'G:\' -LanguagesAvailableToInstall $true -SufficientLanguagePackDiskSpace $true -LanguagePackVersioning $true'
Cannot find information about the local server <MailboxRoleServerHost> in Active Directory . This may be related to a change in the server name.
Active Directory session settings for 'test-SetupHealth' are: View Entire Forest: 'True', Configuration Domain Controller: '<DomainControllerServerHost>', Preferred Global Catalog: '<DomainControllerServerHost>', Preferred Domain Controllers: '{ <DomainControllerServerHost> }'
Runspace context: Executing user: magid.int/Users/Network Administrator, Executing user organization: , Current organization: , RBAC-enabled: Disabled.
Beginning processing.
Current ScopeSet is: {Domain Read Scope: {, }, Domain Write Scope(s): {, }, Configuration Scope: {, }, Server Configuration Scope(s): {, }, , Exclusive Scope: {, }}
Resolved current organization: .
Active Directory session settings for 'Get-OrganizationConfig' are: View Entire Forest: 'True', Configuration Domain Controller: '<DomainControllerServerHost>', Preferred Global Catalog: '<DomainControllerServerHost>', Preferred Domain Controllers: '{ <DomainControllerServerHost> }'
Runspace context: Executing user: magid.int/Users/Network Administrator, Executing user organization: , Current organization: , RBAC-enabled: Disabled.
Beginning processing.
Current ScopeSet is: {Domain Read Scope: {, }, Domain Write Scope(s): {, }, Configuration Scope: {, }, Server Configuration Scope(s): {, }, , Exclusive Scope: {, }}
Resolved current organization: .
Searching objects of type " OrganizationConfig" with filter " $null" , scope " SubTree" under the root " $null" .
Previous operation run on domain controller '<DomainControllerServerHost>'.
Preparing to output objects. The maximum size of the result set is " unlimited" .
Ending processing.
Ending processing.
**************
 
N

Novak Wu

Hi,

Please assure the log is generated when installing SP1. Usually, the above error message is generated when installing Exchange 2010 server. Meanwhile, please stop the Windows Management Instrumentation are restart it, and then setup SP1 again.

If the issue persists, please open Event Viewer and post the latest error message here for research.

Thanks.

Novak


 
J

JO.Chicago

Hello Novak,

Below are the event logs from my previous attempts.

I haven't tried yet your suggestion, can you clarify the previous post? Did you mean just to restart the WMI service right before trying to install SP1?

Thanks.

------------------------------------Log Name: Application
Source: Application Error
Date: 12/11/2010 8:14:25 AM
Event ID: 1000
Task Category: (100)
Level: Error
Keywords: Classic
User: N/A
Computer: <MAILBOXROLESVR>
Description:
Faulting application name: wmiprvse.exe, version: 6.1.7600.16385, time stamp: 0x4a5bc794
Faulting module name: unknown, version: 0.0.0.0, time stamp: 0x00000000
Exception code: 0xc0000005
Fault offset: 0x0000000180025ea0
Faulting process id: 0xd6c
Faulting application start time: 0x01cb6ab5f6ff38a0
Faulting application path: C:\Windows\system32\wbem\wmiprvse.exe
Faulting module path: unknown

------------------------------------ Log Name: Application
Source: Microsoft-Windows-PerfNet
Date: 12/11/2010 8:18:07 AM
Event ID: 2004
Task Category: None
Level: Error
Keywords: Classic
User: N/A
Computer: <MAILBOXROLESVR>
Description:
Unable to open the Server service performance object. The first four bytes (DWORD) of the Data section contains the status code.

------------------------------------Log Name: Application
Source: MSExchange Common
Date: 12/11/2010 8:18:16 AM
Event ID: 106
Task Category: General
Level: Error
Keywords: Classic
User: N/A
Computer: <MAILBOXROLESVR>
Description:
Performance counter updating error. Counter name is RPC Requests, category name is MSExchange RpcClientAccess. Optional code: 3. Exception: The exception thrown is : System.InvalidOperationException: The requested Performance Counter is not a custom counter, it has to be initialized as ReadOnly.
at System.Diagnostics.PerformanceCounter.Initialize()
at System.Diagnostics.PerformanceCounter.set_RawValue(Int64 value)
at Microsoft.Exchange.Diagnostics.ExPerformanceCounter.set_RawValue(Int64 value)
Last worker process info : System.UnauthorizedAccessException: Access to the registry key 'HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\ExchangeServer\v14\Transport' is denied.
at Microsoft.Win32.RegistryKey.Win32Error(Int32 errorCode, String str)
at Microsoft.Win32.RegistryKey.CreateSubKey(String subkey, RegistryKeyPermissionCheck permissionCheck, RegistrySecurity registrySecurity)
at Microsoft.Exchange.Diagnostics.ExPerformanceCounter.GetLastWorkerProcessInfo()

------------------------------------Log Name: Application
Source: MSExchange Common
Date: 12/11/2010 8:18:16 AM
Event ID: 106
Task Category: General
Level: Error
Keywords: Classic
User: N/A
Computer: <MAILBOXROLESVR>
Description:
Performance counter updating error. Counter name is RPC Packets/sec, category name is MSExchange RpcClientAccess. Optional code: 3. Exception: The exception thrown is : System.InvalidOperationException: The requested Performance Counter is not a custom counter, it has to be initialized as ReadOnly.
at System.Diagnostics.PerformanceCounter.Initialize()
at System.Diagnostics.PerformanceCounter.set_RawValue(Int64 value)
at Microsoft.Exchange.Diagnostics.ExPerformanceCounter.set_RawValue(Int64 value)
Last worker process info : System.UnauthorizedAccessException: Access to the registry key 'HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\ExchangeServer\v14\Transport' is denied.
at Microsoft.Win32.RegistryKey.Win32Error(Int32 errorCode, String str)
at Microsoft.Win32.RegistryKey.CreateSubKey(String subkey, RegistryKeyPermissionCheck permissionCheck, RegistrySecurity registrySecurity)
at Microsoft.Exchange.Diagnostics.ExPerformanceCounter.GetLastWorkerProcessInfo()

------------------------------------{There are other 20 similar errors, all referring to RPC performance counters...}

------------------------------------Log Name: Application
Source: MSExchange MailTips
Date: 12/11/2010 8:18:25 AM
Event ID: 14003
Task Category: MailTips
Level: Error
Keywords: Classic
User: N/A
Computer: <MAILBOXROLESVR>
Description:
Unable to create Group Metrics distribution share.
Share: GroupMetrics
Directory: C:\Program Files\Microsoft\Exchange Server\V14\GroupMetrics
Message: 00000842

------------------------------------Log Name: Application
Source: MSExchangeRepl
Date: 12/11/2010 8:18:26 AM
Event ID: 4098
Task Category: Action
Level: Error
Keywords: Classic
User: N/A
Computer: magidchiMSX3.magid.int
Description:
The Microsoft Exchange Replication service couldn't find a valid configuration for database '6a1aa859-9bea-41ea-a043-a68bedf6ec5e' on server '<MAILBOXROLESVR>'. Error:

------------------------------------Log Name: Application
Source: MSExchangeRepl
Date: 12/11/2010 8:18:26 AM
Event ID: 3154
Task Category: Service
Level: Error
Keywords: Classic
User: N/A
Computer: magidchiMSX3.magid.int
Description:
Active Manager failed to mount database Public Folder Database 1925960887 on server magidchiMSX3.magid.int. Error: An Active Manager operation failed with a transient error. Please retry the operation. Error: A transient error occurred during discovery of the database availability group topology. Error: Database action failed with transient error. Error: A transient error occurred during a database operation. Error: MapiExceptionNetworkError: Unable to make admin interface connection to server. (hr=0x80040115, ec=-2147221227)

------------------------------------{After the error above, there is an error logged per each database exactly as the one above...}

--------------------------------------------------------------------
 
Status
Not open for further replies.
Similar threads
Thread starter Title Forum Replies Date
K Backup recommendation for Exchange 2010 SP1 on Hyperv 2008 R2 Exchange Server Administration 3
M Exchange 2010 SP1 DAG & CA ARCserve Backup r15 Exchange Server Administration 1
A Exchange 2010 SP1 Edge Server ( Content Filtering ) Exchange Server Administration 0
F AD RMS with Exchange 2010 SP1 Exchange Server Administration 4
D Exchange Server 2010 SP1 Hosted Mode, service@ mailbox creation Exchange Server Administration 1
I Event ID 2937 after update to Exchange 2010 SP1 ArbitrationMailbox Exchange Server Administration 4
M Exchange 2010 SP1 Hosted Mode - how to move mailbox from old organization? Exchange Server Administration 1
S Owa failed to initialize after install of rollup 2 for Exchange 2010 SP1 Exchange Server Administration 9
P Journaling deployment Exchange 2010 SP1 RU1 Exchange Server Administration 1
I Event ID 2937 after update to Exchange 2010 SP1 Exchange Server Administration 8
G Exchange 2010 upgrade with SP1, language pack issue Exchange Server Administration 5
R Dynamic DNS update requirement for Exchange 2010 (SP1 RU1) on server 2008 r2 Exchange Server Administration 8
P Number of database on a server in DAG Exchange 2010 sp1 Exchange Server Administration 3
N Exchange 2007 SP1 + Outlook 2007/2010 - Autodiscover for Outlook Anywhere and Out of Office not working Using Outlook 1
A NetBackup 7.0 configuration for Exchange 2010 SP1 Exchange Server Administration 3
D Exchange 2010 SP1 OWA "reply" or "forward" error Exchange Server Administration 3
K Question about Exchange 2010 SP1 RU2 update Exchange Server Administration 3
D Exchange 2010 SP1 Policy to Delete mail in deleted items older than 30 days Exchange Server Administration 2
à Validating build of Exchange 2010 SP1 Exchange Server Administration 1
D Exchange 2010 SP1 topology prep error Exchange Server Administration 3
I Exchange 2010 sp1 Address Book service won't start after static RPC port reconfiguration Exchange Server Administration 2
D Installing SP1 for Exchange 2010 Exchange Server Administration 2
B Blank email list views on Outlook 2010 / 2007 with Exchange 2010 SP1 (on Citrix and Desktops) Using Outlook 7
S Exchange 2010 SP1 OWA Error Exchange Server Administration 2
P Mircrosoft Exchange 2010 SP1 Email Purge Exchange Server Administration 2
P Error 4999 after Exchange 2010 SP1 - No BES server Exchange Server Administration 12
D Upgraded to Exchange 2010 SP1 and now random Outlook clients are requesting authentication Exchange Server Administration 1
C Managed Folder does not show up in Outlook in Exchange 2010 Sp1 Rollup 1 Exchange Server Administration 3
L Unable to apply SP1 to Exchange 2010 Exchange Server Administration 5
N MS outlook 2010 is keep on prompting user name and password from the EXCHANGE SERVER 2007 SP1 64 BIT Using Outlook 24
I Exchange 2010 UCM not accepting calls from Nortel CS 1000 after upgrade to SP1 Exchange Server Administration 1
G New-MailboxImportRequest isn't finishing. Can't work out why. Exchange 2010 SP1 Exchange Server Administration 26
T Exchange 2010 SP1 mail universal security group changes? Exchange Server Administration 6
A Cannot delete mail in OWA only after upgrading Exchange Server 2010 to SP1 Exchange Server Administration 30
M Exchange 2010 SP1 adding retention policy via outlook 2010 Exchange Server Administration 7
T Exchange 2010 SP1 BUG - Import IsArchive Exchange Server Administration 41
Diane Poremsky Organizational Forms Library in Exchange 2010 New Slipstick.com Articles 0
V Recover exchange 2010 edb Exchange Server Administration 2
B Exchange 2010 / Outlook 20070 "client error in synchronization log" Exchange Server Administration 1
T Renaming an Resource in Exchange 2010 Exchange Server Administration 1
P Outlook 2010 MS Exchange Calendar to Android- ical or webdav? Using Outlook 1
Fozzie Bear Outlook 2010 or 2013 Dual Configuration Exchange + IMAP Exchange Server Administration 6
H In Exchange 2010, how to block an email containing an attachment that has foreign characters Exchange Server Administration 1
Digitally Hip Outlook 2010 (32) and Exchange 2010 (sp3) sender info not displaying in Outlook Using Outlook 1
A give User Read Only access to secondary mailbox in Exchange 2010 via AD Exchange Server Administration 1
N Outlook 2010 exchange - auto-move emails from @domain Exchange Server Administration 1
V Outlook 2013 cant stay connected to exchange 2010 Exchange Server Administration 5
D cleaning up old Exchange 2003 data on Exchange 2010 Exchange Server Administration 2
L Weird Inbox problems Outlook 2010/13 and Exchange Exchange Server Administration 2
R Exchange 2013/Outlook 2010 Slow Startups Exchange Server Administration 8

Similar threads

Top