Password change OWA redirect error

  • Thread starter Viet Tran
  • Start date Views 1,078
Status
Not open for further replies.
V

Viet Tran



Hello,

Here's my exchange environment.

MBX--CAS--Load Balancer --- Client

I am using a load balancer to handle SSL offload. I turned off all SSL on CAS server. (my Load Balancer handle SSL) - everything works great.

I am having a problem with Password change feature redirection in OWA. I enable Password change via a registry edit, and flag the test account for password change on next login. Upon login in it redirect me to "http://mail.contoso.com/owa/auth/expiredpassword.aspx?url=/owa/auth.owa" - of course, at this point I get an error because it's "http". If manually type "https" on the same URL then the password change screen shows up. At this point I can proceed with the password change. Example below.

"http://mail.contoso.com/owa/auth/expiredpassword.aspx?url=/owa/auth.owa"
Any assistance how to flag it so that the redirection for password change is flag for "https" is greatly appreciated.

Thank you,
Viet
 
J

Justin.King



You mentioned you have configured SSL offloading. If you did this via the registry changes in Exchange then all pages will be returned as http:// .... as expected. If you are SSL offloading however this should be fine, as your Reverse Proxy system should be translating that back to https before it reaches the client.

You should take a close look at your hardware in front of exchange. Make sure it is not passing through the client IP and is instead using it's own IP so response traffic gets returned to this box and it can SSL offload properly.
 
V

Viet Tran

Thanks Justin. I have to force a HTTPS re-write on the Load Balancer to make it work.
 
Status
Not open for further replies.
Top