Exchange 2010 - problem sending mail from one server

Status
Not open for further replies.
V

Vespa Alex

Hello.
We currently have two Exchange 2003 Standard Edition servers - one at Site A (local office) and one at Site C (remote office)
- and we are in the process of upgrading to Exchange 2010.
We have a total of three new Servers (all of which are running as Virtual Machines).
Exchange2010A is a Mailbox, Hub Transport and Client Access server at Site A (local office)
Exchange2010B is a Mailbox, Hub Transport and Client Access server at Site B (local datacentre)
Exchange2010C is a Hub Transport and Client Access server also at Site B
The plan is to migrate user mailboxes from both our old servers onto the new ones and then have a replicated copy of the databases in case our building burns down.
We have set up appropriate connectors to link the old and new halves of the organisation and created a Mailbox Database on 2010A. A test user has been created on this server and I can send and receive mail between them and an existing mailbox on both of our old servers, plus an external recipient.
I've then set up a DAG and created a replica of the database on the 2010B server and this worked ok - I can manually move the active database copy to the other machine for a controlled swap, and if one machine is shut down then the other assumes the master role.
The problem is that when the database is on the 2010B server, although users can connect ok via OWA or Outlook 2010, any messages that they send aren't delivered and eventually time out. As far as I can see, the two servers are configured the same, but clearly something is different.
<edit - fixed a problem with the ECP>

I've looked at one of the failed messages and I can see " '451 4.4.0 Primary target IP address responded with: " 451 5.7.3 Cannot achieve Exchange Server authentication." Attempted failover to alternate host, but that did not succeed. Either there are no alternate hosts, or delivery failed to all alternate hosts"

Can someone help me find where I've gone wrong as I'm now going round in circles.

Thanks
 
G

Gulab Mallah

Check the send connector and make sure that Anonymus permission is checked and restart MS Exchange Transport service.

Gulab | Skype: gulab.mallah
 
V

Vespa Alex

I've double checked that it's set to use anonymous rather than Exchange authentication , but still have the problem.
 
N

Novak Wu

Hi,

Please delete RGC between Exchange 2003 and 2010 and recreate it using the New-Routinggroupconnector command:

New-RoutingGroupConnector -Name " 2010-2003" -SourceTransportServers " Ex2010Hub1.contoso.com" -TargetTransportServers " Ex2003BH1.contoso.com" -Cost 1 -Bidirectional $false -PublicFolderReferralsEnabled $true

and

New-RoutingGroupConnector -Name " 2010-2003" -SourceTransportServers " Ex2003BH1.contoso.com" -TargetTransportServers " Ex2010Hub1.contoso.com" -Cost 1 -Bidirectional $false -PublicFolderReferralsEnabled $true

Please check the results running below cmdlet:

Get-RoutingGroupConnector| FL

Please also assure the SMTP Virtual Server is listening on the 25 port, and the Basic Authentication and Integrated Windows Authentication are checked.

If the problem still appears, please run the exchange best practices analyzer on 2k10 to check the mail flow and run get-sendconnector |fl command in EMS, then post the information on the forum.

Thanks.

Novak


 
V

Vespa Alex

Hello.

In the end this turned out to be a firewall problem rather than an Exchange one.

There is a Cisco ASA between the two servers and it was the inspect esmtp command in the config causing it. Removed this and it started working.
 
N

Novak Wu

Hi,

Thank you for sharing the solution to us. This can help other forum users in future who has the same problem.

Regards,

Novak


 
Status
Not open for further replies.
Thread starter Similar threads Forum Replies Date
S Internet Mail SMTP Connector Problem on Exchange 2010 after Migration Exchange Server Administration 2
S vb.net exchange 2010 problem with enable-mailbox command Exchange Server Administration 2
A Exchange 2007 <-> 2010 OWA not working together redirecting problem Exchange Server Administration 1
P Exchange 2010 Installation Problem Exchange Server Administration 9
D INSUFF_ACCESS_RIGHTS problem with Certain Settings Exchange 2010 Exchange Server Administration 4
B Re: Exchange 2007 and CAS from Exchange 2010 problem Exchange Server Administration 15
M Re: Exchange 2007 and CAS from Exchange 2010 problem Exchange Server Administration 2
I Exchange 2007 and CAS from Exchange 2010 problem Exchange Server Administration 4
T ActiveSync proxy problem from Exchange 2010 CAS to Exchange 2007 CAS Exchange Server Administration 5
J Exchange 2010 / 2003 OWA Problem Exchange Server Administration 2
I Outlook 2010 and work Exchange account problem - but fine on iPhone? Using Outlook 2
J Exchange 2010 behind TMG 2010 - odd per-user problem Exchange Server Administration 4
C Now the problem I see is that I get an error when installing the Exchange 2010 SP 1. I attach a scre Exchange Server Administration 10
Z Problem for adding Exchange 2010 Public Folder database as Public Folder Refferal on Exchange 2007 f Exchange Server Administration 3
A POP3 Service problem in Exchange 2010 (microsoft.exchange.pop3.exe crashes) Exchange Server Administration 7
T Exchange 2007 to 2010 transition, SSL transfer question/problem. Exchange Server Administration 3
A Problem Setting up Outlook Anywhere for Exchange 2010 Exchange Server Administration 17
D Problem with installing Exchange 2010, AD problems? Exchange Server Administration 16
U Exchange 2010 Recovery Database: WMI Problem? Exchange Server Administration 3
M Exchange 2010 SP1 upgrade problem Exchange Server Administration 6
S OWA2010 Problem after installation of Exchange 2010 SP1 Rollup1 Using Outlook 4
B Exchange 2010 DAG and Outlook 2003 Problem Exchange Server Administration 4
M Exchange 2010 Queue viewer Problem Exchange Server Administration 8
S Problem connection Outlook 2010 to Exchange 2003 via POP3 Using Outlook 2
R Problem exporting Exchange 2010 selsigned certificate Exchange Server Administration 3
I A problem occurred while you were trying to use your mailbox. - Exchange 2010 Enterprise Exchange Server Administration 4
P MS Exchange 2003 -&gt; 2010 Upgrade problem Exchange Server Administration 2
R Problem installing Unified Messaging on Exchange 2010 SP1 Exchange Server Administration 3
A Problem installing SP1 for Exchange 2010 Exchange Server Administration 8
D Activation key problem with Exchange 2010 Version: 14.00.0702.000 Exchange Server Administration 7
D Outlook 2010 connection to exchange 2007 problem Using Outlook 3
S CAS access problem with new Outlook 2003 profile to Exchange 2010 Exchange Server Administration 1
A Problem with integration of Exchange 2010 with OCS 2007 R2 Exchange Server Administration 23
A Problem with permissions in Exchange 2010 Exchange Server Administration 2
J Problem uninstall Exchange 2010 Exchange Server Administration 10
J Exchange 2003 to 2010 Mail Flow problem during transition Exchange Server Administration 3
G Exchange 2010 submission : undefined problem. Exchange Server Administration 2
I PROBLEM - Deleted All Queue Logs on Exchange 2010 Exchange Server Administration 3
S Exchange 2010 update rollup 4 - installation problem Exchange Server Administration 5
C Problem with Outlook 2007 and Exchange 2010 Exchange Server Administration 2
X No Free/busy for SOME users with Outlook 2010 / Exchange 2007 using Outlook 2003 no problem Using Outlook 1
T Exchange 2010 SP1 Mailbox export date filter problem - bug? Exchange Server Administration 9
R problem installing exchange 2010 sp1 -failed due to $error.Clear(); Exchange Server Administration 3
M Exchange 2010 ECP sign out problem Exchange Server Administration 7
B Problem installing exchange 2010 (CAS Role) Exchange Server Administration 16
P Another Exchange 2010 Install Problem Exchange Server Administration 7
H Exchange 2010 Journaling Problem Exchange Server Administration 3
M Outlook 2007 and Exchange 2010: autentification problem Exchange Server Administration 6
E Problem with OWA after installing Exchange 2010 in an Exchange 2003 Organization. Exchange Server Administration 6
N Exchange 2010/2007 co existence recieving email problem Exchange Server Administration 6
Similar threads


















































Top