Exchange 2010 DAG Failover Issue - Database Activation Fails because Content Index Catalog Failed

  • Thread starter The Black Shrike
  • Start date Views 2,870
Not open for further replies.

The Black Shrike

I am unable to test a DAGs failover because when simulating a failure of the LIVE server, the mailbox database wont activate on the DR server…information as follows:
Our organisations runs Exchange 2003, and we are transitioning to Exchange 2010.
I have setup a test lab to configure and test DAGs prior to implementing it on our production servers.
In this lab I have 2 Exchange Servers, EX1 and EX2 running Exchange 2010 SP1 (Update Rollup 2), a file Share Witness and a DC all in the same subnet.
I have setup and configured the DAG and added a Mailbox Database named MBX1 which is only Active on EX1 and therefore replicated to EX2. The Copy Status shows MBX1 as mounted on EX1 and Healthy on EX2.
On EX2 I have blocked the “DatabaseCopyAutoActivationPolicy” by running the following (Set-MailboxServer -Identity 'EX2' -DatabaseCopyAutoActivationPolicy Blocked)
I am testing the failover and failback process but I seem to be hitting a brick wall.
To simulate a failure and then failover I perform the following:
On EX1 disable both NIC"s (MAPI and REPLICATION)
On EX2, once EX1 is no longer reachable I run the following:
Move-ActiveMailboxDatabase –identity "MBX1" –ActivateOnServer "EX2" –MountDialOverride "None" –skiplagchecks
The problem is the MBX1 cannot be activated on EX2 because it says the “content index catalog files are failed”… full error message……
An Active Manager operation failed. Error: The database action failed. Error: An error occurred while trying to validate the specified database copy for possible activation. Error: Database copy "MBX1" on server "EX2" has content index catalog files in the following state: "Failed"
I have spent some hours on this issue now but still can"t crack it. Prior to simulating the failover, I check the Content index and it says “Healthy” on EX1 and EX2, its only when I try to simulate the failover that the content index changes to failed on EX2.
There seems to be a number of similar issues on Google, etc. But they all seem to be more specific to activating a mailbox database when both servers are still online, whereas that is not the case for me, as the source server is offline and therefore unreachable.
For example:
I have tried reseeding, resetting the index, etc, but nothing works.
If I change the “DatabaseCopyAutoActivationPolicy” on EX2 back to “Unrestricted” (Set-MailboxServer -Identity 'EX2' -DatabaseCopyAutoActivationPolicy Unrestricted) and simulate the failure, then MBX1 automatically activates on EX2.
Therefore, the Activation issue only seems to occur when the “DatabaseCopyAutoActivationPolicy” is set to blocked on EX2. But I have no idea why they should behave differently?
Many thanks in advance!

AndyD_ [MVP]

Try the Move-ActiveMailboxDatabase command with the SkipClientExperienceChecks switch and see if that works.

The Black Shrike

Bang on the money :) Thanks AndyD_

After using the " SkipClientExperienceChecks" parameter I was able to activate the database!
Not open for further replies.