Re: Windows cannot access the specified device, path, or file.

Status
Not open for further replies.
J

Jaffy890

Hi Everybody with unsolved problems! I found the unerversal solution to your " Windows Cannot Access the speficed device, path, or file" problems.

1. Okay, go to the drive that cannot be opened(the one that says every time you click it," Windows Cannot Access the Spefified device, path or file)

2. Right - Click it. There should be something that says, " Auto Play" . Click the first one. If the first one doesn't work, click the second one.
 
A

AMD Avenger

Ran into this today myself. One more things future readers may need to check is Group Policy. I joined a machine to a domain and experienced this error when trying to run a particular program. I could copy in other programs to the same folder and they'd run. The logged in user had full permissions and even ownership over the folder and all items within it. It didn't even matter if I logged in as a domain admin account. The error persisted.
In the end, what it ended up being was a GPO blocking 16-bit applications. Restrictions like that (or others within GP) may be to blame. Windows won't tell you WHY it is blocking access to a file. It just says that it is doing so, unfortunately.
(For my specific problem, you're looking at Computer Configuration\Administrative Templates\Windows Components\Application Compatibility\Prevent Access to 16-bit applications in whatever GPO applies. If you're on a domain, ask your domain admin. If you're on a workgroup PC, fire up gpedit.msc via the run command [Win+R if you're on Win7 and haven't enabled Run in your task bar], and prod around. Chances are slim that a workgroup PC would be effected by this since only you'd have ever set permissions in that case.)
 
B

Bellz1993

Hi,

Yeah i have just got this error today also. It occured when i was playing a program off an external hard-drive then i took out the hard-drive and put it in another computer; the program at this point was still working. After i took the hard-drive out of my second computer and went to put it back into the other and run the program it came up with the error " windows cannot access the specified device,path or file ...." this hasn't happened to me before it only happened when i used my external hard-drive on my two computers now im getting the same error message when trying to run the program on either computer. I have looked for the IE Enhanced Security component; its not there. I have also tried running the program off the harddrive through safemode and it still gives me the same error.

Please help
 
P

PatAndM

Ok this will be a long post, and for starters I wanted to point something out to everyone - there is two separate discussions going on in this thread. On one side you have a discussion about servers and people using thin clients or Citrix having this error code and changing Internet Explorer to resolve this conflict. Then on the other side all the stand alone home users with XP and Vista and 7 trying to figure out what is going on with their install that has the exact same error code. Microsoft in their infinite wisdom has given this error code to relate to multiple different errors hence the confusion.

Now here is my story, with out a resolution yet.

Ok, so I ran into a real nasty trojan virus, that is now resolved and gone. However, when I went into the process of being able to resolve this issue a sticky byproduct was this permissions issue. This is how it happens, I download a video with Firefox or any browser Opera, IE whatever. Then after I have downloaded it into the proper location I can see it within the downloads list from the browser, should I double click to launch the video with WMV it will fail with that error " Windows cannot access the specified device, path, or file. You may not have the appropriate permission to access the item" . However, should I open the directory and then launch from the true download location, rather in the list of the files within the browser download list it will launch fine. This is the problem I can utilize the programs directly launching them from explorer, however should I try and launch a program from inside another program it will fail to launch.

This is a Vista 64 bit installation, and I am pretty tech savvy individual. What I have tried thus far is to take owner ship of the directory since trusted installer was the owner previously. After I had done that I went into the permissions of the exe and sought to make sure that the file was open for everyone to be able to modify and have full control - it was. After that I also tried launching the browsers as admin privileges to see if it would still launch. It will not it refuses to allow calls to this directory. That being said it is also a big problem when I use Corel DVD Moviefactory, because this program is trying to launch other programs from this directory to run. So, I need to figure out why is it that I am not able to have programs make calls to this directory and try and launch exe files and fail, yet the permissions are fine and I can launch them from directly clicking on the item in a directory?

Further clarification as to what happens:

Firefox downloads to Harvester\downloads
All my pictures, movies, executable, rar/zip, reside in this directory " downloads"
In the browser Firefox there is a " downloads" [contrl+J] list that shows what you have downloaded through the browser
All of these items are able to double click and execute from this list with out having to navigate to the " downloads" directory
When executing a WMV file it will fail and error out with the " Windows cannot access the specified device, path, or file. You may not have the appropriate permission to access the item" error.
However, navigating to this directory will allow me to launch all programs with out any problem, the difference is I am launching from the file rather than through a program making a call to the x86 directory to launch the file. If I have an item that doesn't require a program to launch from the x86 directory it will launch ok through Firefox, ex InfanView, HJsplit, etc.
This is a problem with other programs making calls to external programs residing in the x86 directory like Corel Moviefactory 7. While running it will make the same error " Windows cannot access the specified device, path, or file. You may not have the appropriate permission to access the item" when trying to make a new DVD, because it utilizes something in that directory an external program.
This happens with Opera as well, don't know about IE I don't use it.

What I have done thus far:

Removed my firewall that was MS native firewall

Removed my anti-virus and malware software - AVG, MalwareBytes, Windows Defender, Windows Security Essentials, Spybot Search and Destroy, Spy cop, and a few others

Went and took ownership of the directory

Tried registry hacks

Altered AVG to exclude the (x86) directory

Re-installed AVG and MalwareBytes to see if I can repair the file

Shared the (x86) directory for everyone and inherited the permissions

Tried CLI restoring of default permissions

Tried to make changes in safe mode still shut down.

This is where I am now....waiting for a scan to end to reboot and check to see if I was able to make any progress.
 
N

Nick_hey

Hi All, i found another solution to this. if you are in a Terminal Server session to the affected server, open Task Manager and check who is logged on under Users.

You may have to log everyone off except yourself.

Might be best to try this solution first before you go uninstalling anything :)
 
Status
Not open for further replies.
Thread starter Similar threads Forum Replies Date
I Re: Windows cannot access the specified device, path, or file. Using Outlook 0
N Re: Windows cannot access the specified device, path, or file. Using Outlook 0
T Re: Windows cannot access the specified device, path, or file. Using Outlook 0
J Windows 7. I cannot access some 'attachments' emails via MS Outlook. Using Outlook 3
T windows cannot access the specified device path or file. you may not have the appropriate permission Using Outlook 2
J I open my Windows 7 outlook. I just get a message saying it cannot open. I have had it running for 5 months already and do not know how to access E- Using Outlook 1
W Accidently typed in wrong Windows Live ID during Outlook setup, now cannot change to the correct Live ID and unable to have any access to Microsoft Ou Using Outlook 2
D Windows cannot access the specified device, path, or file. Exchange Server Administration 183
Marc2019 Cannot input Vietnamese Characters on my MSOutlook 2016 in Windows 7 Using Outlook 0
R Cannot Synchronize Outlook To Windows Live Hotmail Account Using Outlook.com accounts in Outlook 2
J I use Windows XP with Microsoft Outlook 2003 and I cannot get int the Microsoft Exchange server. Using Outlook 1
A outlook 2010, windows 7, exchange server: "The action cannot be completed. The connection to Micro Using Outlook 1
D Outlook 2003 cannot open Word docs after Windows 7 upgrade from Vista. Using Outlook 2
L Cannot open Outlook 2010 Student, operating system Windows XP Using Outlook 6
D Cannot email from Windows document Using Outlook 6
B Cannot configure email in Outlook 2010 with Windows 7 Using Outlook 1
P I cannot get Outlook 2007 to work with my MSN account. Also using Windows 7. I followed all the instructions at Microsoft support and nothing solved Using Outlook 1
N Outlook 2010 on Windows 7 64bit Cannot Receive Hotmail Emails Using Outlook 2
M I cannot send emails using outlook using windows 7 Using Outlook 2
S cannot install exchange 2010 on windows 2003 R2 Exchange Server Administration 2
T When clicking on link from any received email, I get an error message of Windows Cannot Open this Fi Using Outlook 2
E Cannot connect Windows Live Hotmail to Outlook 2010 Using Outlook 2
H Outlook 2003 in Windows 7 will not send and receive: Message "object cannot be found" Using Outlook 4
J Cannot get my calendar 2010 to sync with my Windows live Hotmail account Using Outlook 3
M The Add-in 'ACT! 2006 Extensions' (C\Windows\system32\Act7Ext.dll) cannot be loaded and has been disabled by Outlook Using Outlook 1
B Cannot Send and Receive email after installing on a new hard drive partition and a new hard drive with Windows 7. Using Outlook 2
N mapi32.dll corrupt-cannot open outlook 2003-want to make copy of contacts before I restore windows V Using Outlook 3
K Windows 7 Cannot select drop down entry from the TO field when composing an email using Outlook 2010 Using Outlook 1
R Cannot star Microsoft Office Outlook, cannot open teh outlook windows Using Outlook 2
C Cannot send/receive email with Outlook 2003 on new Windows 7 laptop Using Outlook 6
D User is connected via HTTP. Outlook 2010, Windows 7. When clicking on the inbox receives the following message:__Outlook cannot display this view Using Outlook 1
B Cannot update or view hyperlinks in outlook 2007 on windows 7 system. Using Outlook 10
J Cannot connect Windows 7, Outlook 2007 to Exchange Server 2007 Using Outlook 6
J Outlook 2010 Mail Indexing Not Working (Windows Search Email Indexer Add-in cannot be enabled) Using Outlook 3
A Cannot import Outlook files from Windows XP Using Outlook 2
M Outlook 10 Windows 7, yes I used Windows Easy Transfer to move my data and now I cannot click the Outlook address book tab selection Show this folder Using Outlook 1
M Windows 7, Outlook 2010, cannot add Contact Folder as an email address book. Using Outlook 12
O cannot delete junk messages in Windows Live Mail Using Outlook 1
W When entering outlook 2007 I get a message that states windows cannot open outlook 2007 Using Outlook 1
B microsoft outlook out box has had 4 messages in to be sent for 2 weeks other messages are sent not these4 .windows vista microsoft 2007 .I cannot dele Using Outlook 1
M Cannot Start Office 2007 with Windows 7 (64 Bit)-Error 'Cannot Start MS Office. Using Outlook 1
I Exchange 2010 Initialization failed (The windows remote shell cannot process the request) Exchange Server Administration 21
B iCloud for Windows 11.2 disconnects by itself after 30-45 minutes Using Outlook 9
DoctorJellybean Windows Security Credentials appears once a day Using Outlook 2
D iCloud Add-in not working in Outlook 2013 and Outlook 2016 After Windows Upgrade & iCloud Upgrade Using Outlook 2
M Outlook 2010 Problem with OutLook 2010 32 bit, after Windows Auto Update Using Outlook 3
S Outlook 2007 Calendar instant search problem. Windows 7 Using Outlook 4
S Outlook 2007 Calendar instant search problem. Windows 7 Using Outlook 0
O Windows 1803 update : QAT and toolbar changed, language pack gone... Using Outlook 5
Mark Foley Color Categories on IMAP mail lost when installing new Windows 7 workstation Using Outlook 12
Similar threads


















































Top