Outlook 2010, CRM 4.0 Client for outlook (rollup 13) gets undeliverable response replying to CRM linked email

Status
Not open for further replies.
K

Keith Dorken



Having moved to Exchange 2010 recently, and upgraded everyone to Office 2010, and put the latest rollup of CRM 4.0 (#13) in, AND redeployed the CRM to a new server and new SQL server database, we are unable to REPLY to an email in our Outlook INBOX that has been linked to a CRM record (using the CRM for Outlook client procedures). If you reply BEFORE linking the email to the CRM, the message is sent. However, a reply done AFTER linking to CRM results in an undeliverable response from our external mail server (the one the exchange server contacts to send the actual email) due to an INVALID message id.

The message ID of the emails that fail do NOT have the proper form GUID@server.domain.ca but are simply a GUID (no @server.domain.ca).

I would like to know who to blame in this problem; is it the CRM client for outlook?, Is it outlook? or is it Exchange? Who is responsible in a message being sent from Outlook to inserting the messageID into the message?

An example of the header is shown here:

<!-- [if gte mso 10]> <mce:style>

Received: from Exchange.ourdomain.ca ([2002:c066:b0c::c066:b0c]) by
Exchange.ourdomain.ca([2002:c066:b0c::c066:b0c]) with mapi id 14.01.0255.000;
Wed, 27 Oct 2010 14:57:47 -0400
From: Keith Dorken <kadorken@ourdomain.ca >
To: "User, A" <AUser@somewhere.ca >
Subject: RE: WEB REQUESTS CRM:00030566
Thread-Topic: WEB REQUESTS CRM:00030566
Thread-Index: Act2Bk9oKhX1ZFGQSWWDIrKV4tvjtQAAKQNQAAB3NGA=
Date: Wed, 27 Oct 2010 18:57:45 +0000
Message-ID: <0FAD1313-FCE1-DF11-AECC-001FC630CF47> <<<<<<<<<<< NOTE THE MESSAGE ID ! >>>>>>>>>>>>>>>>>>>>
References: <201010271839.o9RIdaoh003882@mail.ourdomain.ca >
<B16BCA36A08EFC4D90BFDE0D081F501A803D603DAA@senders.domain.local >
In-Reply-To: <B16BCA36A08EFC4D90BFDE0D081F501A803D603DAA@senders.domain.local >
Accept-Language: en-CA, en-US
Content-Language: en-US
X-MS-Has-Attach:
X-MS-TNEF-Correlator:
x-originating-ip: [2002:c066:b71::c066:b71]
Content-Type: text/plain; charset="utf-8"
Content-Transfer-Encoding: base64
MIME-Version: 1.0

TIA to anyone who can point me in a direction to look.
 
A

Alexey_D

Yesterday i found the same problem with the same configuration. Message-id have bad format. I try reinstall oulook client with different rollup, but nothing change. In Exchache log i see the bad message-id from client. So i think the problem is in Outlook client. Do you find the solution?MCP
 
K

Keith Dorken



No; I have done further testing and determined that it is the Microsoft CRM add-in that is responsible (that is, if you disable the CRM add-in, then replies to a message tagged with CRM 'stuff' will be sent properly; as soon as you reenable the CRM add-in, replies on the same message get an invalid Message-ID.

I am reposting my question over to the CRM dynamics forum as it seems to be 'their' problem, and calling Microsoft support to get this resolved.
 
Status
Not open for further replies.
Thread starter Similar threads Forum Replies Date
à Outlook 2010 and Dynamics CRM Using Outlook 2
T Why does outlook 2010 convert only some forum notifications to plain text? Using Outlook 2
I Error saving screenshots in a custom form in outlook 2016, outlook 365 - ok in outlook 2013, outlook 2010 Outlook VBA and Custom Forms 5
M Outlook 2010 Problem with OutLook 2010 32 bit, after Windows Auto Update Using Outlook 3
M PST import from Outlook 2007 to 2010 - Address Book contacts all in 1 group Using Outlook 3
D Outlook 2010 account setup fails in particular domain Using Outlook 3
B Outlook 2010 is Auto Purging when not configured for that Using Outlook 1
W Outlook 2010 Reading Pane Slows Startup Using Outlook 3
S Outlook 2010 unable to change default font Using Outlook 7
B Outlook 2010 Can not find a certain file in M/S Outlook 2010. Using Outlook 1
Mark Foley Cannot enable add-in in outlook 2010 Using Outlook 0
W Outlook 2010 some sent items marked unread now (was Ok before) Using Outlook 0
RBLampert Updating from Outlook 2010 to Outlook 365 Using Outlook 0
L What are the risks of opening an Outlook 2016 .pst file in Outlook 2010? Using Outlook 4
S Unable to remove rule outlook 2010 Using Outlook 0
N Outlook 2010 Flag blocked for Safe Senders List???? Using Outlook 7
dweller Outlook 2010 Rule Ignores VBA Script Outlook VBA and Custom Forms 2
Mark Foley Unable to subscribe to published calendar in Outlook 2010 Using Outlook 4
K Maximum Categorize Shortcuts In Outlook 2010? Using Outlook 1
E Unable to open Outlook 2010 after adding new email account Using Outlook 4
RBLampert Outlook 2010 no longer (?) shrinks large images Using Outlook 4
N Outlook 2010 will not send nor receive Using Outlook 4
U Outlook 2010 'freezes' before moving emails Using Outlook 2
P Outlook 2010 trusted emails going to spam folder Using Outlook 18
E Outlook 2010 Subject sort uses Thread-Topic for grouping Using Outlook 2
King Mustard Maximum Categorize shortcuts in Outlook 2010? Using Outlook 1
C Outlook 2010 keeps asking for username and password Using Outlook 1
M Duplicate Primary Mail Accounts outlook 2010 Using Outlook 0
T Compacting Outlook 2010 OST results in old emails being re-sent Using Outlook 6
K Outlook 2010 duplicate download emails 1 inbox 1 PST no updates Using Outlook 3
D create an html table in outlook custom form 2010 using vba in MsAccess Outlook VBA and Custom Forms 7
Potty Ash MS Outlook 2010 custom form - validation or formula to request user to check a checkbox Outlook VBA and Custom Forms 16
RBLampert Outlook 2010 sends to/receives from some Gmail addresses but not others Using Outlook 3
e_a_g_l_e_p_i Question about address book in Outlook 2010 Using Outlook 9
e_a_g_l_e_p_i Is there a good third party SPAM filter that intergrates with Outlook 2010 Using Outlook 7
e_a_g_l_e_p_i Another reinstall of Outlook 2010 issue Using Outlook 10
S Outlook 2010 Cannot Open Attachments Using Outlook 14
Justo Horrillo Issue with rules in Outlook 2010 Using Outlook 4
L Upgrade from Outlook 2010-any reason to? Using Outlook 1
C Attached Files outlook 2010 Using Outlook 1
C Attached files on Outlook 2010 Sp1 & Exc 2013 are missing Exchange Server Administration 1
EaglePI Outlook 2010 need help with rules Using Outlook 0
K can not reinstall outlook 2010 Exchange Server Administration 0
T outlook 2010 mail item count doesnt match display Outlook VBA and Custom Forms 3
Werewolf Workaround for the missing Activities tab in Contact Folder Properties in Outlook 2010? Using Outlook 2
G Can't open .pst. Message could not access default folder (Outlook 2010 (.pst). Before that was backi Using Outlook 0
N Outlook 2010 on re-imaged computer missing calendar/contacts Using Outlook 0
V Hotmail account on Outlook 2010 Using Outlook 2
E How to send automatic emails in outlook 2010 Using Outlook 1
I Outlook 2010, 2013 will not open .msg or .eml files Using Outlook.com accounts in Outlook 1
Similar threads


















































Top