cannot access OWA or connect to exchange 2007 via outook.

Status
Not open for further replies.
A

Aleel Mohammed



Hi,

I would like a little help on some issues we are experiencing with a recently installed set of exchange 2007 servers. The first server has the mailbox, CAS and HUB roles installed and the second server has the Edge Transport installed. The mailbox server was installed into an existing active directory domain and the Edge Transport server is a member of a workgroup. The existing domain apparantly had exchange 2003 attributes in active directory from a failed exchange 2003 installation. We removed the exchange 2003 organization and then was able to install a new exchange 2007 SP1 organization. We then updated the exchange 2007 SP1 server to Service Pack 3. The problem we are experiencing now is that a new mailbox enabled user can not access OWA or connect to exchange via outlook. Network connectivity to the servers are fine. I have also noticed that the Exchange performance troubleshooter tool "multiple users are complaining of delays" test reports there is an error accessing active directory. Exchange best practices analyzer reports everything is fine

the following shows the error message when you try to logon to OWA

Exception

Exception type: Microsoft.Exchange.Data.Storage.StoragePermanentException

Exception message: There was a problem accessing Active Directory.

Call stack

Microsoft.Exchange.Data.Storage.ExchangePrincipal.Save()

Microsoft.Exchange.Clients.Owa.Core.RequestDispatcher.DispatchLanguagePostLocally(OwaContext owaContext, OwaIdentity logonIdentity, CultureInfo culture, String timeZoneKeyName, Boolean isOptimized)

Microsoft.Exchange.Clients.Owa.Core.RequestDispatcher.DispatchLanguagePostRequest(OwaContext owaContext)

Microsoft.Exchange.Clients.Owa.Core.RequestDispatcher.PrepareRequestWithoutSession(OwaContext owaContext, UserContextCookie userContextCookie)

Microsoft.Exchange.Clients.Owa.Core.RequestDispatcher.InternalDispatchRequest(OwaContext owaContext)

Microsoft.Exchange.Clients.Owa.Core.RequestDispatcher.DispatchRequest(OwaContext owaContext)

System.Web.HttpApplication.SyncEventExecutionStep.System.Web.HttpApplication.IExecutionStep.Execute()

System.Web.HttpApplication.ExecuteStep(IExecutionStep step, Boolean& completedSynchronously)

Inner Exception

Exception type: Microsoft.Exchange.Data.Directory.ADOperationException

Exception message: Active Directory operation failed on N8-ET0RMJS27M-1.judiciarytt.org. This error is not retriable. Additional information: Insufficient access rights to perform the operation. Active directory response: 00002098: SecErr: DSID-03150A45, problem 4003 (INSUFF_ACCESS_RIGHTS), data 0

Call stack

Microsoft.Exchange.Data.Directory.ADSession.AnalyzeDirectoryError(PooledLdapConnection connection, DirectoryRequest request, DirectoryException de, Int32 totalRetries, Int32 retriesOnServer)

Microsoft.Exchange.Data.Directory.ADSession.ExecuteModificationRequest(ADRawEntry entry, DirectoryRequest request, ADObjectId originalId)

Microsoft.Exchange.Data.Directory.ADSession.Save(ADObject instanceToSave, IEnumerable`1 properties)

Microsoft.Exchange.Data.Storage.ExchangePrincipal.Save()

Inner Exception

Exception type: System.DirectoryServices.Protocols.DirectoryOperationException

Exception message: The user has insufficient access rights.

Call stack

System.DirectoryServices.Protocols.LdapConnection.ConstructResponse(Int32 messageId, LdapOperation operation, ResultAll resultType, TimeSpan requestTimeOut, Boolean exceptionOnTimeOut)

System.DirectoryServices.Protocols.LdapConnection.SendRequest(DirectoryRequest request, TimeSpan requestTimeout)

Microsoft.Exchange.Data.Directory.PooledLdapConnection.SendRequest(DirectoryRequest request, LdapOperation ldapOperation)

Microsoft.Exchange.Data.Directory.ADSession.ExecuteModificationRequest(ADRawEntry entry, DirectoryRequest request, ADObjectId originalId)

http://technet.microsoft.com/en-us/library/bb885050%28EXCHG.80%29.aspx - we have tried this solution, with no luck

Does anyone have any ideas on what maybe causing this problem?

regards,

Aleel
 
N

Novak Wu



Hi,

Based on my research, this error can occur if the msExchVersion attribute is not configured correctly on the user object in Active Directory. Please refer to the following article to troubleshoot the issue.

http://support.microsoft.com/kb/941146

Thanks.


 
D

Dev Ranjan [Exchange Specialist]



Dear Aleel,

As Novak said, it is none other than the attributes issue as per me as well. Whenever the attributes get affected, you experience such problems and also it wouldn't show in exchange BPA.
 
H

HereToHelp



could be permissions, try checking again

Get-Mailbox alias| Get-MailboxPermission | where-object { $_.accessrights -like "*FullAccess*"}

if you see deny - True for a group that your user belongs to then go to EMC and grant that group full mailbox access, see if that takes care of it. If that group or user already has permission try removing an Reading it as this will force replication and might take care of the issue.

MCSE | MCITP - Server 2008 | MCITP - Exchange 2007 | MCTS - Exchange 2010
 
A

Aleel Mohammed



Hi Novak,

Thanks for the reply. If i can recall, i believe i tried the "Set-Mailbox <User_Name> -ApplyMandatoryProperties" command and the output said "The command completed successfully but no settings of......have been modified". Another thing i noticed when exchange was installed, was that 2 legacy mailboxes appeared in the EMC, which i then deleted. the Administrator account was none existant.

After much frustration i decided to reinstall exchange. Exchange now works and the administrator mailbox appeared automatically within the EMC.

I'm not sure what went wrong with the installation....but it works now.

thanks again

Aleel
 
N

Novak Wu



Thank you for your update on this case and I"m glad to hear that Exchange server is working fine after reinstalling it.

Regards,

Novak


 
Status
Not open for further replies.
Thread starter Similar threads Forum Replies Date
C Exchange 2010 OWA Sub Folders Access Denied ( also cannot create Rules with move to folder ) Exchange Server Administration 3
O The page that you are trying to access cannot be loaded. Using Outlook 0
T Cannot access outlook.com accounts in Outlook 2016 Using Outlook 1
M Cannot access the Form Editor BCM (Business Contact Manager) 1
U Cannot access fields at bottom of Outlook 2013 Contact Rec. Using Outlook 1
P I am getting an error msg = cannot open file access denied Using Outlook 3
H ran scanpst.exe and that fixed most, but cannot access personal folders Using Outlook 1
R Shared Inbox Outlook 2010 - one client cannot access Exchange Server Administration 1
G Cannot access PST file Using Outlook 5
I Re: Windows cannot access the specified device, path, or file. Using Outlook 0
C cannot access hyperlink in Outlook 2007 Using Outlook 1
M Right Click &gt; Send to Mail Recipient, has no effect__Other programs cannot access the email client Using Outlook 3
T Cannot start Microsoft Outlook... Cannot access file... Using Outlook 2
N Re: Windows cannot access the specified device, path, or file. Using Outlook 0
T Re: Windows cannot access the specified device, path, or file. Using Outlook 0
B Outlook 2010. Cannot access my Contacts from clicking 'To' butto to find an email send address. Using Outlook 2
J I can no longer access my Address Book. I get the message"The folders cannot be opened. It may be mo Using Outlook 2
J Windows 7. I cannot access some 'attachments' emails via MS Outlook. Using Outlook 3
A One user cannot access availability or download address book Using Outlook 2
P Cannot access Busines Contact Manager Using Outlook 3
D Cannot Save Assigned Access Rights To Delegates for Allowing Another User To Manage the Calendar and Contacts Using Outlook 2
J Outlook 2010 Access Denied. Cannot open pst file‏ Using Outlook 6
T windows cannot access the specified device path or file. you may not have the appropriate permission Using Outlook 2
J Re: Windows cannot access the specified device, path, or file. Using Outlook 4
N Outlook cannot find users; Web Access works Using Outlook 13
N cannot access outlook.pst Office 2010 Win 7 Using Outlook 2
L Cannot access www.outlook.com Using Outlook 2
D Cannot open Outlook 2003; appears have lost access to the software and data Using Outlook 1
P cannot download access for office2010 in windows7 envoirment Exchange Server Administration 1
S Re: Cannot access signatures in Outlook 2007. Cannot edit existing one or and a new one. Using Outlook 1
B Re: Cannot access signatures in Outlook 2007. Cannot edit existing one or and a new one. Using Outlook 1
2 cannot access links in received email Using Outlook 4
D Cannot access outlook, server not found. Trying to create new email account. Using Outlook 2
J CAN'T WORK WITH OUTLOOK AS I GET 'CANNOT ACCESS OUTLOOK.PST FILE' Using Outlook 3
E 0x800CCC0E CANNOT SYNC WITH EMAIL SO CANNOT GET ON LINE VIA OUTLOOK SAYING NO ACCESS TO SERVER HAVE INTERNET CONNECTION Using Outlook 2
C Cannot access Internet through links embedded in e-mail messages. Error message tells me that Windo Using Outlook 1
T Address book cannot/does not access the contact files Using Outlook 2
C what is my server - tried to set up - chose Microsoft Exchange server - now cannot access Outlook 2010 Using Outlook 1
S Delegate cannot access Contacts folder Using Outlook 1
L Cannot INstall Client Access Role Exchange Server Administration 14
I Cannot access attachments in shared Public Folders Using Outlook 2
J How can I download this file? Need help urgently on a job search and cannot access my Outlook Using Outlook 2
D Delete email from outbox, error message ' this file cannot be deleted because it has been moved or you have been denied access.' Using Outlook 1
J I open my Windows 7 outlook. I just get a message saying it cannot open. I have had it running for 5 months already and do not know how to access E- Using Outlook 1
Y Scanpst.exe Where can I download this file it is missing and I cannot access Outlook Using Outlook 5
W Accidently typed in wrong Windows Live ID during Outlook setup, now cannot change to the correct Live ID and unable to have any access to Microsoft Ou Using Outlook 2
S Cannot access emails, been out of action over a week!__ Using Outlook 8
J Re: Unable to access Mailbox after Remote move (Cannot open mailbox, Get-CalendarProcessing error) Exchange Server Administration 8
L Unable to access hyperlinks..."General Failure: URL was unable to open....The system cannot find the Using Outlook 2
C Cannot access macro menu in OL2003 Outlook VBA and Custom Forms 2
Similar threads


















































Top