New-MoveRequest: Cannot find recipient that has mailbox GUID

Status
Not open for further replies.
F

FlodNar

I'm doing a cross forest migration including a move from Exchange 2007 to 2010. I did succesfully run Prepare-MoveRequest to create a new disabled mail enabled account in the target domain. Afterwards I did a ADMT move for that account to take SID history and password to the new domain. I did leave out all the MSEXCH fields.

Now the New-MoveRequest for that user fails with the message:

VERBOSE: [14:55:00.985 GMT] New-MoveRequest : Cannot find a recipient that has mailbox GUID '38c27423-bf00-4255-9122-f221f2b19e88'.
VERBOSE: [14:55:00.985 GMT] New-MoveRequest : Admin Audit Log: Entered Handler:OnComplete.
Cannot find a recipient that has mailbox GUID '38c27423-bf00-4255-9122-f221f2b19e88'.
+ CategoryInfo : NotSpecified: (0:Int32) [New-MoveRequest], RemotePermanentException
+ FullyQualifiedErrorId : 36C68430,Microsoft.Exchange.Management.RecipientTasks.NewMoveRequest

Do I need to exclude more fields using ADMT? Or what else do I miss?
 
M

Michel de Rooij

I assume you did ADMT first - excluding Exch attribs - and then ran Prepare-MoveRequest.ps1 to sync/update the account in the target domain with the proper exchange attributes?

What is the exact new-MoveRequest command you're using?

Michel de Rooij,
MCITP Ent.Msg 2007+2010| MCTS W2008, Ex2007+2010 Conf, OCS2007 Conf | MCSE+Msg2k3 | MCSE+Inet2k3 | Prince2 Fnd | ITIL
I blog on http://eightwone.wordpress.com/ and tweet on http://twitter.com/mderooij
 
F

FlodNar

Hi Michel,

Initially I did use ADMT first (with only one account). But then I read that I needed to run the Prepare command first, so I deleted the account. I ran the following command in a .ps1 file:

$LocalCredentials = Get-Credential DomainTarget\administrator
$RemoteCredentials = Get-Credential DomainSource\administrator
" abc@test.domainsource.nl" | ./Prepare-MoveRequest.ps1 -RemoteForestDomainController test-dc.test.domainsource.nl -RemoteForestCredential $RemoteCredentials -LocalForestDomainController test2-dc.test2.domaintarget.nl -LocalForestCredential $LocalCredentials

Afterwards I did use ADMT, but I left the user in the user OU where the Prepare command placed the user, not where I wanted it to be.

Last I tested the Move with the following command:

New-MoveRequest -Identity " abc@test.domainsource.nl" -Remotelegacy -TargetDatabase " Mailbox Database 1854922471" -RemoteCredential (Get-Credential domainsource\administrator) -TargetDeliveryDomain " test2.domaintarget.nl" -RemoteGlobalCatalog " test-dc.test.domainsource.nl" -WhatIf

which left me with the error message I mentioned in my first post.
 
F

FlodNar

I also tried to create new user, create mailbox, send mail, transfer with ADMT, run invoke-moverequest. Same result, different GUID.

What is wrong? Now I cannot move a mailbox at all!
 
M

Michel de Rooij

That Prepare-MoveRequest.ps1 should copy the MsExchangeMailboxGUID, so it goes wrong at that stage. Now, the script can create users for you but you'd had to do the ADMT excercise anyway (SIdhistory) so I'd use ADMT first and let the script do only the mapping and adding the necessary attributes.
http://technet.microsoft.com/en-us/library/ee861103.aspx

What's the output of the Prepare-MoveRequest.ps1 script?

One important note, when running these kinds of scripts in large(r) environments, be advised scripts might not work immediately because of replication, i.e. attributes set at one DC may not have been replicated to the DC which your script is talking to.

Michel de Rooij,
MCITP Ent.Msg 2007+2010| MCTS W2008, Ex2007+2010 Conf, OCS2007 Conf | MCSE+Msg2k3 | MCSE+Inet2k3 | Prince2 Fnd | ITIL
I blog on http://eightwone.wordpress.com/ and tweet on http://twitter.com/mderooij
 
F

FlodNar

I ran ADMT for another user, including all msEXCH fields.

The Prepare script says:
Preparation for abc@domain.nl done.
1 mailbox(s) ready to move.

After this I end up with 2 users. The second one disabled and having the same name with numbers added. When I now run MoveRequest I get the error about the GUID.

When I take a look in EMC I also see 2 users. No difference with added numbers or so. But the Recipient Type Details differ: one is User Mailbox, the other Mail User. When I take a look at the properties of the user with the User Mailbox type, I get the message:

The properties on this object have invalid data. If you click OK, default values will be used instead and will be saved if you do not change them before hitting Apply or OK on the property page. If you click cancel, the object will be displayed read-only and corrupted values will be retained.

When I click Cancel and browse the grayed-out tabs, I get another error at the Calendar Settings tab: " The user does not have an Exchange mailbox. It was running the command 'Get-CalendarProcessing ....."

When I run ADMT excluding the Exchange fields, the Prepare script says the same. And again I end up with 2 users. First running the Prepare script and then ADMT leaves me with one user.
 
G

Gen Lin

Hi,

Please follow these steps to move the mailbox:

1. On source server, create a mailbox user, test01.

2. On target server, run the following command to move the AD account:

Prepare-MoveRequest.Ps1 -Identity test01@source.com -RemoteForestDomainController FQDN.source.com -RemoteForestCredential $Remote -LocalForestDomainController FQDN.target.com -LocalForestCredential $Local -UseLocalObject -Verbose"

3. Run the ADMT to migrate the password and SID history.

4. Run the following command to move the mailbox:

New-MoveRequest -Identity " CN=test01,CN=Users,DC=target,DC=com" -TargetDatabase 'MSC-DB01' -remoteGlobalCatalog " gc.source.com" -remoteCredential $remote -TargetDeliveryDomain target.com' -RemoteLegacy

Note: The identity should be the user object in the target domain.

What's result?



 
F

FlodNar

Hi Gen,

Do you want me to exclude the msExch fields in ADMT or leave all in?
 
M

Michel de Rooij

Don't or you'll have issues (eg you'll overwrite the legacyExchangeDN and proxyAddresses on the target account, where that x500 proxyAddress needs to identical to the source legacyExchangeDN value).

Michel de Rooij,
MCITP Ent.Msg 2007+2010| MCTS W2008, Ex2007+2010 Conf, OCS2007 Conf | MCSE+Msg2k3 | MCSE+Inet2k3 | Prince2 Fnd | ITIL
I blog on http://eightwone.wordpress.com/ and tweet on http://twitter.com/mderooij
 
Status
Not open for further replies.
Thread starter Similar threads Forum Replies Date
C Email Success or failure of new-moverequest Exchange Server Administration 5
Z New-MoveRequest makes Outlook 2010 disconnect? Exchange Server Administration 3
S Prevent Cross-Forest New-MoveRequest from deleting the source mailbox Exchange Server Administration 10
R New-MoveRequest errors with a The critical property 'ExchangeGuid' is missing in the MailUser object Exchange Server Administration 4
R New-MoveRequest -RemoteLegacy results in "Mailbox database doesn't exist" Exchange Server Administration 3
D New-MoveRequest generates error: Unable to determine the AD site for mailbox database Exchange Server Administration 1
J New-moverequest fails. Exchange Server Administration 11
P Re: New-MoveRequest -RemoteLegacy succeeds, but mailbox is unusable... Exchange Server Administration 9
rubaboo The vew cannot be found Outlook VBA and Custom Forms 0
A Cannot copy this folder because it may contain private items Using Outlook 0
L Cannot open PST file for first session each day Using Outlook 6
David in Mississippi New (Feb 2020) install of Outlook 365 - Cannot specify PST for different accounts Using Outlook 0
Marc2019 Need help please! Cannot Setup my outlook email account on my Mac Outlook 2011 Using Outlook.com accounts in Outlook 2
noshairwan Registry cannot be found, Outlook Security Using Outlook 2
Marc2019 Cannot input Vietnamese Characters on my MSOutlook 2016 in Windows 7 Using Outlook 0
T Cannot remove needless PST Using Outlook 1
Marc2019 Cannot setup Outlook Account on Mac Os 10.6.8 Using Outlook 3
N pst files are recreating automaticaly and cannot be deleted Using Outlook 6
Mark Foley Cannot enable add-in in outlook 2010 Using Outlook 0
T "cannot find the calendar folder for this item" - calendar items stuck in outbox Using Outlook 0
A Created a new user account and the local account cannot see email Using Outlook 3
iwshim outlook 2013 - I cannot see the "Manage Add-ins" Using Outlook 2
T Cannot connect to main BT email account, sub accts okay Using Outlook 0
O The page that you are trying to access cannot be loaded. Using Outlook 0
M Daily Task List Minimized Cannot Display Using Outlook 2
geofferyh Cannot get Macro to SAVE more than one message attachment??? Outlook VBA and Custom Forms 5
DariTrevino MIcrosoft Outlook PST file cannot repair Using Outlook 1
B One email cannot be sent or received (but leaves outbox!) Using Outlook 1
C Outlook 2016 cannot delete, email showing in root Exchange Server Administration 5
S Outlook.com cannot edit some contacts Using Outlook.com accounts in Outlook 5
B Search: Cannot find which Folder Contains a Message Using Outlook 3
C Outlook - cannot save subject line changes Using Outlook 2
M cannot change delivery folders with IMAP accounts Using Outlook 0
S Appointment-Cannot set Categories because ConversationID is not set Outlook VBA and Custom Forms 1
Fozzie Bear Cannot post "Sneaky URL"!! Using Outlook.com accounts in Outlook 2
Commodore Search cannot complete the indexing of your Outlook data Using Outlook 6
S Outlook 2010 Cannot Open Attachments Using Outlook 14
A Cannot Figure Out This VBA Outlook VBA and Custom Forms 2
A Cannot Figure Out One Thing on VBA Outlook VBA and Custom Forms 2
Brian Murphy Exchange Online Everything a Transport Rule should do and cannot Exchange Server Administration 1
A Error: The name cannot be matched to a name in the address list Using Outlook.com accounts in Outlook 0
K Other Shared Calendar on Outlook cannot change items Using Outlook.com accounts in Outlook 7
T Outlook 2016 cannot connect after transition to Outlook Mail Using Outlook.com accounts in Outlook 4
L Cannot Connect to BCM database BCM (Business Contact Manager) 9
A Cannot connect to BCM database BCM (Business Contact Manager) 3
Diane Poremsky The custom form cannot be opened. Outlook will use an Outlook form instead. New Slipstick.com Articles 0
T Cannot access outlook.com accounts in Outlook 2016 Using Outlook 1
T Outlook 2016 mp3 attach "this file cannot be preview because there is no previewer installed for it" Using Outlook 1
S Outlook data file cannot be accessed message Using Outlook 5
O Cannot open or save calendar items Using Outlook 0
Similar threads


















































Top