Blank body when replying with an Outlook Form.

Status
Not open for further replies.

SteveC

Member
Outlook version
Outlook 2010 64 bit
Email Account
Exchange Server
Hi, I've used my google-fu powers but I have come up empty thus far.




I have an outlook form. It's pretty simple in that it's a few fields and a message body. In my testing, I open the form, fill it out, make a comment in the body and send it to myself. When I receive it, I can see all of my data including that in the message body. I then reply or reply all with a second message leaving all other data. When I receive the reply, all data remains except for the body. The body is simply blank. I can't figure out why my message body is blank! Any ideas?




I'm using Outlook 2007. I've played with the settings in the 'When Responding' column on the '(Actions)' pane. In my reading, I've read that it could be the antivirus. I am using McAfee and cannot disable it. I've also read that I can't reply to an email to myself. It seems to work with other data except for the message body so that doesn't make sense.




Any help would be appreciated.
 

Diane Poremsky

Senior Member
Outlook version
Outlook 2016 32 bit
Email Account
Office 365 Exchange
Are you using Exchange or an internet account? Is the form published? If not, how are you opening the template?




First guess: the message is RTF and the data is encoded in a winmail.dat file and its getting deleted or corrupted on the resend. The presense of a winmail.dat file can be confirmed by looking at the message header or message source.




You should be able to reply to yourself... unless you have rules or antispam filters that prevent it.




You can mostly rule out the antivirus by running outlook in safe mode and see if works as desired. If it does work as expected, its definitely the antivrus integration with Outlook. If its still a problem, its less likely the antivirus integration, but not 100% since some antivirus hooks in deeper - the only way to confirm this is by starting windows in safe mode. (Hold Ctrl as you click on the Outlook icon to start in Safe mode.)
 

SteveC

Member
Outlook version
Outlook 2010 64 bit
Email Account
Exchange Server
Thanks for your reply!




I'm using Exchange. I have one copy of the form that is published into my company's organizational form library. The form that I am playing with is a copy that I am developing with. I use the 'Run This form' button. hmmm, now that I think about it, is this a possible problem? Publishing is a two day process for my company (ouch, I know) but I can try that.




I looked at how to view the source and I found that winmail.dat is present.


I have run outlook in safe mode and the problem still exists. I restarted my system into safe mode and the problem still exists. So I'm ruling out antivirus as the problem.
 

Diane Poremsky

Senior Member
Outlook version
Outlook 2016 32 bit
Email Account
Office 365 Exchange
I mostly had antivirus ruled out before... I don't think its the problem.




Does the published form work correctly?


Are you including form definitions in your test form?
 

SteveC

Member
Outlook version
Outlook 2010 64 bit
Email Account
Exchange Server
The published form does not work properly. In my current published form, the 'when responding' setting is to 'respect user's default'. My reply setting is set to 'Include original message'. The message is not being included.




I have no idea if I am including form definitions. How do I know?
 

Diane Poremsky

Senior Member
Outlook version
Outlook 2016 32 bit
Email Account
Office 365 Exchange
Form defs are not needed when you use the org library, but will be if you are just testing and its not published.




It sounds like the problem is not the forms defs (although it will be when you test an unpublished form).
 

SteveC

Member
Outlook version
Outlook 2010 64 bit
Email Account
Exchange Server
The published for form the same behavior. So if from defs are not the problem, what else could the problem be?
 

Mel

Member
Outlook version
Outlook 2007
Email Account
Exchange Server
I AM HAVING THE SAME PROBLEM. :mad:

I too am using Outlook 2007. I created a form with three additional fields (all text fields). I sent it to myself, clicked reply, added text to the body and hit send. When I receive the replied email the fields are still populated but the body of the message is completely empty. I have noticed that if I set the "Creates form of type" under the Action tab to Message the body of the text carries forward but the field informaion drops out. If I set the "Creates form of type" under the Action tab to to form I have created the fields stay but the body drops out.

Please help, I have been trying to find a solution for months now and am getting very frustrated. If you tell me how I am more then willing to send you the .oft file I have created.
 

Diane Poremsky

Senior Member
Outlook version
Outlook 2016 32 bit
Email Account
Office 365 Exchange
You either need to publish the form to the organizational forms library or include form definitions for custom fields to work correctly.
 

Mel

Member
Outlook version
Outlook 2007
Email Account
Exchange Server
You either need to publish the form to the organizational forms library or include form definitions for custom fields to work correctly.
I'm sorry, I'm not at all familiar with this type of work, took a while to get as far as I did actually. Could you please provide instruction on how to include form definitions for custom fields or at the very least direct me to a site that would help? I do not have the rights to publish to the org library.

If I am able to figure it out would I then leave the "Creates form of type" set to message then?
 

CraigCal

Member
Outlook version
Outlook 2010 64 bit
Email Account
Exchange Server
I created a custom form and published it as "MyForm" in the Organizational Forms Library. We have been using it for years without any problems. I had to build some new Windows 7 PC's and installed Outlook 07 on one and Outlook 2010 on another. Both machines would not get the form when launching a new E-Mail. So next steps in Microsoft Support and they have me download a tool called "FormsAdmin" I basicly took the default "IPM.Note" and changed it to "IPM.Note.MyForm" Exported the Reg Key and with notepad changed the version from 9.0 to 12.0 for Outlook 07 and 14.0 for Outlook 2010. I then merged the Reg Key and the form worked to send a new message. What happened next was everyone in the organization started complaining that their email reply and forward sends blank messages. I dug into the problem and found that it only happens when replying to HTML, Text only worked fine. I decided to try running FormsAdmin again and set the settings back to default. Now when I send a message it does not use MyForm, however the message is sent with the MyForm fields unpopulated. So when using MyForm to reply or forward, it looks like MyForm is doubled up which may cause the HTML code to be unreadable by Exchange so it drops it. Anyone have any Idea's on how to fix this?
 

CraigCal

Member
Outlook version
Outlook 2010 64 bit
Email Account
Exchange Server
I have selected the check box on "Send form definition with item" under the Properties tab. I have also tried changing "Creates form of type" under the Actions tab to "Message" from the Standard Forms Library. I then republished the form and still have the same problem with all users.
 

CraigCal

Member
Outlook version
Outlook 2010 64 bit
Email Account
Exchange Server
I am using Exchange 2007 and Outlook 2007 and Outlook 2010.
 

Diane Poremsky

Senior Member
Outlook version
Outlook 2016 32 bit
Email Account
Office 365 Exchange
Hmmm. I'll have to look into that one - it should work just fine if you are sending through the server.


Are you sending the form to internal users? If it works inhouse but not when sent to internet addresses it's an Exchange configuration issue.
 

CraigCal

Member
Outlook version
Outlook 2010 64 bit
Email Account
Exchange Server
The form is simple, it is only meant to work inhouse and it does, it use to work sending new, replying, and forwarding. The reply and forward are broken now and I can't figure out why. It takes any HTML email and basicly drops everything whenever we reply or forward. The only workaround I have found so far is to send in PlainText only.
 

CraigCal

Member
Outlook version
Outlook 2010 64 bit
Email Account
Exchange Server
How to reproduce the blank mail body received when Replying or Forwarding?

1. Open the custom form from where you published it.

2. Click Developer tab | Design this form

3. Click Actions tab

4. Next to Reply, Reply All, and Forward in the table grid is the column “Creates forms of type” and it is by default set to “Message”.

5. Double-click on Message. Click dropdown to right of “Form name” and select Forms | Go to Personal Forms Library | Select “TEST1” from the list.

6. Click Publish | Publish Form -àClick OK to replace form, if prompted.

7. Open the custom form from Personal Forms Library.

8. Address the message to yourself. Fill in the user-defined fields. Write into the message’s body.

9. Send message

10. Open message

11. Click Reply ---address to yourself and type text into body. Click Send

12. Click Forward –address to yourself and type text into body. Click Send

13. Open RE and FW messages and message body is blank.

Why?

For whatever reason, unless you call Save before you Send the Reply\Reply All\Forward, the body is not written\saved to the item.
 

CraigCal

Member
Outlook version
Outlook 2010 64 bit
Email Account
Exchange Server
WORKAROUNDS:

1. Click Save, then click Send when you Reply\Reply All\Forward

2. Use VBScript in the form to call save on Reply\Reply All\Forward messages.

- Open the custom form from where you published it.

- Click Developer tab | Design this form

- Click “View Code” button

- Copy the following into the Script Editor

sub item_send()

if instr(item.subject, "RE:") then

item.save

end if

if instr(item.subject, "FW:") then

item.save

end if

end sub

- Click Publish | Publish Form -àClick OK to replace form, if prompted.

- Open the custom form from Personal Forms Library.

- Address the message to yourself. Fill in the user-defined fields. Write into the message’s body.

- Send message

- Open message

- Click Reply ---address to yourself and type text into body. Click Send

- Click Forward –address to yourself and type text into body. Click Send

- Open RE and FW messages and message body are present and displayed.

RESOLUTION:

This is an issue with Outlook 2010. We have submitted a hotfix request to our Product Group. If our Product Group accepts this request, a fix will be released in a future update for Outlook 2010. At this time a workaround listed above will help resolve the issue until a permanent fix is released.

From CraigCal:

I have found that the problem exists in any combination of Outlook 2007, Outlook 2010, Exchange 2007, and Exchange 2010. I also found that the Script given above does not work for me. Does anyone know how to force the form to save prior to send??? Still waiting to hear back from Microsoft but if anyone has any idea's let me know.
 

CraigCal

Member
Outlook version
Outlook 2010 64 bit
Email Account
Exchange Server
From Microsoft:

We did have another customer report a similar problem in the past and that issue was debugged. However, the customer wound up going another route and didn’t pursue getting a hotfix for this issue, so it was not fixed. At this point, we really have two options:
  1. Pursue getting a fix in Outlook. Of course, we still need to verify that this issue you are seeing is the same as the one that was previously reported. I just spoke to the engineer who worked on this previously and he said he can take a look at a debug trace in a couple of days. Since there clearly seems to be an issue here, I’d ideally like to get down to root cause and get this fixed if possible.
  2. Since there seems to be a workaround of saving the item via code in the form, I can help you with that if that is the route you want to go, even if only as a temporary measure until a fix is done. Fixes typically take at least a couple of months to be completed, so I presume the workaround approach is what you’d like to do, at least for now.

For #2, I see you had re-typed the VBScript code and after that there doesn’t seem to be a difference (the body was still blank). However, are you sure that you had the “Send form definition with item” disabled when the form was re-published? If not, the form will become what we call a one-off form, and Outlook does not run VBScript code in one-off forms by default. That could explain why it didn’t seem to work. For testing purposes, it’s usually good to add a line of code like:

MsgBox “here!”

This would be right after the line: sub item_send(). This way you would get a dialog popping up to indicate that the code is actually running.
 

CraigCal

Member
Outlook version
Outlook 2010 64 bit
Email Account
Exchange Server
Ok, so after several hours of testing this is what I found. The code:
sub item_send()

MsgBox "Message should not be blank"

if instr(item.subject, "RE:") then

item.save

end if

if instr(item.subject, "FW:") then

item.save

end if

end sub

Did work the first time I tried it. Outlook 2010 worked, no blank message. Outlook 2007 worked, no blank message. However the popup was annoying! So I republished without the (MsgBox "Message should not be blank") in the code and Outlook 2010 still worked. Outlook 2007 sent blank messages. Because most of my users are on 2007, I readded the MsgBox code, republished and Outlook 2007 still sends blank messages. Can't get it to work!!! Very frustrated right now...:mad:
 
Status
Not open for further replies.
Top