Signature changes font of last line of template

Status
Not open for further replies.

EmmyButt

Member
Outlook version
Outlook 2010 64 bit
Email Account
Exchange Server
Hi,

I have recently been moved from Outlook 2003 to Outlook 2010 and have been spending time re-setting up my templates.

One difference I am having problems with is that my default signature is being added when I open my templates - this didn't happen in Outlook 2003. I have searched on lots of forums and see that there is a way of changing this but it requires a change to the registry - something I am not allowed to do, unfortunately.

So, I have changed my templates so that they don't include a signature or a sign-off so that when I open a template my signature is added - this is fine except this changes the last line of my template to an incorrect font - Times New Roman 12 instead of Arial 10. I have played around with this for quite some time and have noticed the following:

- This only occurs when opening templates if I open a new mail message I have two blank lines in Arial 10 and then my signature.

- If I add an extra blank line at the end of my template and then open it I get all my template text in the correct font, two blank lines (both in Times New Roman 12) and then my signature.

Having searched on multiple forums I have learnt that on blank e-mails the signature will have two blank lines before it, this is fine I just need to know why the font is changing - I have tried changing as many font default options to Arial 10 but suspect I may have forgotten one which is causing this issue?!?

Sorry if I haven't explained this very clearly but if anyone could help I'd be most grateful!

Also, FYI I have posted on PC review and someone suggested using QuickParts instead of templates. I don't think this will work for me as I use Outlook VBA with the templates.

http://www.pcreview.co.uk/forums/signature-changes-font-last-line-template-t4044256.html

Thanks,

Emmy
 

EmmyButt

Member
Outlook version
Outlook 2010 64 bit
Email Account
Exchange Server
Please can someone help - I would be most grateful!
 

EmmyButt

Member
Outlook version
Outlook 2010 64 bit
Email Account
Exchange Server
Hi,

Thanks so much for taking the trouble to help me.

I had already looked at the link you gave me and followed the steps it describes but I still get the same problem.

I've changed all my fonts and when I open a new message I get 2 lines of my default font, then my signature and then a blank line in my default font with Body in brackets - as you would expect. However when I save an Outlook template ending with sign off text, and then open the template I get the template text in my default font, the last sign off line in Times New Roman, a blank line in Times New Roman, my signature in my signature font and then a blank line in my default font with Body in brackets.

I don't know where the problem lies, but I think it's with some hidden font default rather than signatures. If I turn off signatures and then open a template I still get the last line in Times New Roman which leads me to think that there is a secret Times New Roman setting somewhere.

I did find a work around for this by using the Replace function in VBA to replace Times New Roman within the HTML code to my default font. This does work well for me but I would love to figure out why this is happening...

Emmy
 

Diane Poremsky

Senior Member
Outlook version
Outlook 2016 32 bit
Email Account
Office 365 Exchange
Open a new message form. Go to Format Text tab, Change Styles button. Expand it and then Fonts command. What font is highlighted in the list? The font in the larger name is used for headings, the lower one for text.

Is Times selected? If so, select a different font then re-open the change fonts button and select Set as Default. (Cursor needs to be in the message body to activate Set as Default.)
 

Diane Poremsky

Senior Member
Outlook version
Outlook 2016 32 bit
Email Account
Office 365 Exchange
oh, and one more thing - edit the signatire to remove the last line and save. Outlook will add it back, but this insures it's not hard-coded to TNR.
 

EmmyButt

Member
Outlook version
Outlook 2010 64 bit
Email Account
Exchange Server
Hi Diane,

Thanks for taking the time to respond to my query.

I did as you said and Times New Roman is not selected - Calibri and Calibri is selected. I also did as you said for the signature but there has been no change.

Emmy
 

Diane Poremsky

Senior Member
Outlook version
Outlook 2016 32 bit
Email Account
Office 365 Exchange
Gp to File, Options, Stationerty and Fonts (it's on the Mail page) - what Theme is set in the top field?

Is Calibri your preferred font? If so, is it set as the font (same dialog as above) for new mail and replies or do you have +Body set as the font (and Calibri set as the Body font)? It should be set to +Body, with calibri set as the body font.
 

EmmyButt

Member
Outlook version
Outlook 2010 64 bit
Email Account
Exchange Server
Ok, sorry if I haven't been clear or if I've been confusing. My company has changed its default font from Arial to Calibri today - this is why I allude to Arial in my first post and Calibri in my posts from today.

Under Stationary and Fonts - I have no Theme selected.

Under the three font options I had Calibri selected but I have now changed these to +Body and can confirm Calibri is set as the Body font under Format Text, Change Styles etc...

Even after all this though I still get the same experience when I open an Outlook template rather than a new message (where I don't get any TNR).
 

Diane Poremsky

Senior Member
Outlook version
Outlook 2016 32 bit
Email Account
Office 365 Exchange
So it works as expected when you use a new message - that means the template has the font assigned. Stationery/Themes and templates can have their own fonts assigned that override the user settings- that's why i had you check the Theme setting. ("No theme" is the best setting IMHO.)

I'd copy the template to a new message form - being careful not to get that last line (or paste as plain text only) - then save it as a template.
 

EmmyButt

Member
Outlook version
Outlook 2010 64 bit
Email Account
Exchange Server
That is so weird - if I do that it works - no more TNR but if I open an existing template, delete the signature and extra lines, select all, change font to Calibri and then save as over existing template I get TNR when I open it - crazy! At least I've got it working now though - it will just take an age to recreate all my templates from scratch! But thanks so much!!!
 

Diane Poremsky

Senior Member
Outlook version
Outlook 2016 32 bit
Email Account
Office 365 Exchange
That is weird. In a quickie test, when you save a template, the font is 'hardcoded', rather than saved as +Body. Just another reason why the +Body font implementation is so lame - done right it could solve a lot of problems.

In your case - try this:

Open the template, press Ctrl+Shift+8 to show all marks. Make sure that last para mark is selected before changing the font. That worked for me in another quickie test. Select all (Ctrl+A) should have picked it up though - so i'm not sure why it didn't work for you.
 

EmmyButt

Member
Outlook version
Outlook 2010 64 bit
Email Account
Exchange Server
Unfortunately I still get the same thing. Not to worry I'll just recreate my templates and after that I should be all sorted - thanks again for helping resolve this issue.
 

the_neatener

Member
Outlook version
Outlook 2010 64 bit
Email Account
Exchange Server
Open the template, press Ctrl+Shift+8 to show all marks. Make sure that last para mark is selected before changing the font. That worked for me in another quickie test. Select all (Ctrl+A) should have picked it up though - so i'm not sure why it didn't work for you.
Diane, I also have this issue. I moved from Outlook 2003 to 2010 and copied over my templates folder. When I open the templates in Outlook 2010, the last few lines of the template (my signature, but not the signature Outlook appends), for example:

With regards,

The Neatener




have changed from my default font (Candara) to Times New Roman, inlcuding the para. marks above and below it.

As I open each template, I've been fixing this (being sure to select all para. marks), but when I resave it and reopen it, I get the same problem—only now it's just "The Neatener" (not "With regards,") that's showing up in Times New Roman.

Is there any solution for this? It somewhat defeats the purpose of having templates.

Thanks,

The Neatener
 

the_neatener

Member
Outlook version
Outlook 2010 64 bit
Email Account
Exchange Server
Yes, I've done all of that. The problem is the two hard returns Outlook inserts before a signature—they default to Times New Roman (and I'm not sure where or if I can change that) and that's what changes my font.

The workaround I've come up with is to insert an extra hard return after my name in my templates. That allows my font to stay intact.
 

the_neatener

Member
Outlook version
Outlook 2010 64 bit
Email Account
Exchange Server
Okay, it seems that the problem lies with my templates; if I recreate them from scratch, I don't have the TNR problem. It's only when I try to resave/overwrite and existing template with an updated version that I get the TNR problem.
 

Diane Poremsky

Senior Member
Outlook version
Outlook 2016 32 bit
Email Account
Office 365 Exchange
That's interesting. It sounds like they were created when TNR was set as the default font.
 
Status
Not open for further replies.
Top