Shared Contacts in Outlook 2010 and Exchange Server 2010

Inflammo

Member
Outlook version
Outlook 2010 32 bit
Email Account
Exchange Server
We’re running an Exchange 2010 server in our environment,Windows 7 computers with Outlook 2010.



When sharing contacts with a user, the user wishes to addthe shared contacts to their Outlook Address Book. This is done by accessing the Shared ContactsProperties. In Properties there is anOutlook Address Book Tab where the checkbox for Show this folder as an e-mailAddress Book is checked and the Name of the Address Book added.



The problem is this; there is no Outlook Address Booktab. Therefore the Shared Contactscannot be added.



In Outlook 2003 and 2007, the work around is to closeOutlook on the users pc, go into the Mail Setup in Control Panel, AccountSettings, select Change and in Server Settings, then Change the Account to thatof the actual Shared Contact. Aftercompletion, open Outlook, right click Contacts, then in Properties, click OutlookAddress Book Tab where the checkbox for Show this folder as an e-mail AddressBook is checked and the Name of the Address Book added. Close Outlook, revert the Outlook ChangeSettings back to the user.



The Shared Contacts are now in the Outlook Address Book.



In Outlook 2010, this only lasts until the pc iseither logged off or rebooted. Afterrestarting or logging back in, the Shared Contacts have disappeared from theOutlook Address Book.



I’m hoping someone out there can advise me on how to makethis work in Outlook 2010.

 

Diane Poremsky

Senior Member
Outlook version
Outlook 2016 32 bit
Email Account
Office 365 Exchange
I've been meaning to look into this because several people said it did not work and it keeps getting pushed back... made time today and it only took me 45 minutes to set up a profile using the instructions at Display Public Folder and Other Contacts in the Address Book - and now i get the 'your mailbox was moved' error message. :) Will reboot in a bit and see if it sticks. The steps are similar but you are changing the users mailbox to the shared user, then changing it back, where my method starts with the shared mailbox and changes to the user. Also, do you have the shared mailbox in the profile as a secondary mailbox?

I had a heck of a time getting it to accept my account creds when i changed accounts.
 

Inflammo

Member
Outlook version
Outlook 2010 32 bit
Email Account
Exchange Server
HI - no shared mailbox. It doesn't matter, I've tried setting it up with shared and without, still doesn't work. I'm wondering if this is something Microsoft removed from Outlook 2010.
 

Diane Poremsky

Senior Member
Outlook version
Outlook 2016 32 bit
Email Account
Office 365 Exchange
I don't think they intentionally removed anything, but adding the ability to open 2 exchange boxes probably broke it. Authentication seems to be my major problem - i think that is why i get the mailbox moved error.

I had the address book after a reboot but decided to try a new ost - and lost it at that point. I don't know if restoring a registry file after a reboot will work - it seems to be stored in the ost, not the registry. I'm going to test it on my next reboot.

At this time, i don't have a solution -
 

tryeager

Member
On Win 7 boxes using OL 2010 and Exchange 2013 (Office 365, in my case), many days of experimenting lead to the following method to get shared contacts into other user's address books. It is similar to the OL2007 method that Diane published a few years ago. After being told many times by MS support and reading in MS forums that this method (or the OL2007 method) is not possible, I finally got MS's OL support team to test and confirm that it works.




From the point of view that you are trying to get someone else's shared contacts in your address book, and assuming that the other person has already sent you an email invitation that you have accepted:




1.) In your Control Panel | Mail, create a profile pointing to your own Exchange mailbox. Then, as a 2nd account using "Add Account", add the mailbox of the person owning the contacts you need access to. [Not as an added address as in 2007 and as will be done later. This is a 2nd full account parallel in authority although not the default account, since not first].


2.) Launch OL, and right-click the other user’s Contacts folder, choose Properties, then switch to the Outlook Address Book tab. Make sure that the "Show this folder as an e-mail Address Book box" is checked. Optionally, under "Name of the address book", change the display name to something other than Contacts (the default name).


3.) Close OL! This is important, and some people skipped this and complained in the OL2007 thread.


4.) In Control Panel | Mail, open the properties of the profile. Click Email Accounts, then remove the 2nd account because you don't want to get their mail. On your own account, click "Change", then "More Settings", then "Advanced". Add the 2nd account in as an "additional address".


5.) Restart OL using this profile. The other person’s contacts will now be included in your Address Book.
 
Top