OL2003 Public Folder Sync Errors w/ Exchange 2010

Status
Not open for further replies.

JackPollack

Senior Member
Outlook version
Email Account
Exchange Server
Using a hosted Exchange server 2010 just to "sync" email, contacts and cal between work, home and my phone (I am then only user and I am not sharing anything in the public folder).

My home computer is OL2010 and is working fine.

My office computer has OL2003 SP3 (cached mode). I dont want to/cant upgrade for several reasons including customized integration with my billing software that does not work in Office 2010.

Everything looks like it is working fine except I keep logging errors every few minutes about problems connecting to the public folder (see end of this post for log).

Doing a little research I do find post about this (eg Cannot access public folders from Outlook 2003/2007 after moving users mailboxes to Exchange 2010. - Theo Browning - Site Home - TechNet Blogs). Some of the solutions involve server side changes that I obviously cant make. I think it is related to encryption and have tried turning it on and off in Outlook without success.

Any ideas on how to fix this error? I dont think I even need the public folder synced. Is there a way to turn off syncing this folder?

Also, entering editing items is a bit slow. Any way to speed this up?

Thanks

8:21:16 Synchronizer Version 11.0.8161

8:21:26 Could not connect to public folder server.

8:21:26 [8004011D-526-80040115-0]

8:21:26 The Microsoft Exchange Server computer is not available. Either there are network problems or the Microsoft Exchange Server computer is down for maintenance.

8:21:26 Microsoft Exchange Server Information Store

8:21:26 For more information on this failure, click the URL below:

8:21:26
http://www.microsoft.com/support/prodredirect/outlook2000_us.asp?err=8004011d-526-80040115-0

8:21:26 Not downloading Offline address book files (stored on public folder server).


8:21:26 Synchronizing Mailbox 'XXXXXX'

8:21:26 Done
 

Diane Poremsky

Senior Member
Outlook version
Outlook 2016 32 bit
Email Account
Office 365 Exchange
Who is your hosted provider? Do you have public folders showing in the Folder list? (Ctrl+6 to jump to the folder list) Many hosted providers (like office 365) do not support public folders in Exchange 2010 (it's optional since Exchange 2007) and I suspect Outlook is looking for a server that does not exist.

Public folders are used for things like Free/busy in older versions of Outlook and that may be what Outlook is trying to link to. Since it's only you, set Free/Busy publishing to 0 (Tools, Options, Calendar options, free/busy).

Are you using cached mode or online mode? Editing should be speedy if using cached mode. If using online mode it can be slow if the network is slow.
 

Diane Poremsky

Senior Member
Outlook version
Outlook 2016 32 bit
Email Account
Office 365 Exchange
Actually, in thinking about it, if the server does not have public folders enabled, outlook 2003 won't connect to it at all. (It's one of the questions Exchange's setup wizard asks.) So that is not your problem.

Because you aren't using public folders, and as long as you aren't getting annoying popups interrupting work, I'd configure autoarchive to delete the sync messages as they age.
 

JackPollack

Senior Member
Outlook version
Email Account
Exchange Server
Thanks for your reply.

I do have public folders showing in the list.

Public Folders\Favorites does open (it is empty), but Public Folders\All Public Folders displays:

"Unable to open the folder. MS Outlook could not access the specified folder location. Could not open the item"

This happens both on OL2003 and OL2010 which is not reporting errors

I set Publish Free/Busy info to '0" but it did not help.

FYI: Clicking on Resource Scheduling button returns "Connection to MS Exchange Server is unavailable"

I agree that I could set auto archive to delete after 1 day but would rather get rid of the message if possible.

Any other ideas? Registry hack or something to stop it check those folders?
 

JackPollack

Senior Member
Outlook version
Email Account
Exchange Server
There is a web config page for the Exchange account. Not sure what the technical name for this page is but I do some basic Exchange management.

If I go to Services\Exchange\Public Folders it does say that Public folders are not enabled. I assume enabling them would also fix my problem. Is this something I can do from the elsewhere in the web config? If you think this will correct my problem I can also check with the hosting co.
 

JackPollack

Senior Member
Outlook version
Email Account
Exchange Server
I checked with the hosting co (LunarPages) and they :

"We are running Exchange 2010 SP1 and Public Folders are not supported in our environment. Public Folders is also planned on being removed by Microsoft from their exchange package"

So enabling is not an option.
> if the server does not have public folders enabled, outlook 2003 won't connect to it at all. (It's one of the questions Exchange's setup wizard asks.) So that is not your problem.

Are you talking about the outlook setup for exchange, or the actual exchange setup. If you are talking about OL maybe I answered the question wrong when setting up the account. Where would I check this/How would I change?

Any other ideas as I am logging errors every time OL does a send/receive (every 10 min)
 

Diane Poremsky

Senior Member
Outlook version
Outlook 2016 32 bit
Email Account
Office 365 Exchange
No, its not an outlook setup issue. Outlook 2003 needs public folders for some support files, like address book and free/busy. When the admin installs exchange the dialog asks if older clients will be connecting to the server, if so, public folders are installed.

Are all the sync errors the same? If we knew why outlook needed to connect, we might be able to do something.
 

JackPollack

Senior Member
Outlook version
Email Account
Exchange Server
All the errors are the same. Think they are being caused by the inability to connect to the public address book.

8:21:16 Synchronizer Version 11.0.8161

8:21:26 Could not connect to public folder server.

8:21:26 [8004011D-526-80040115-0]

8:21:26 The Microsoft Exchange Server computer is not available. Either there are network problems or the Microsoft Exchange Server computer is down for maintenance.

8:21:26 Microsoft Exchange Server Information Store

8:21:26 For more information on this failure, click the URL below:

8:21:26
http://www.microsoft.com/support/prodredirect/outlook2000_us.asp?err=8004011d-526-80040115-0

8:21:26 Not downloading Offline address book files (stored on public folder server).
 

Diane Poremsky

Senior Member
Outlook version
Outlook 2016 32 bit
Email Account
Office 365 Exchange
Hmm. Somehow I missed that in the earlier post. It is because it can't connect to the address book outlook 2003 expects.

Try this registry key - if it doesn't stop the errors, you'll probably have to live with them.

HKEY_CURRENT_USER\Software\Microsoft\Office\11.0\Outlook\Cached Mode

Parameter: DownloadOAB

Type: REG_DWORD

Value: 0

0 = The Offline Address Book does not download automatically.

1 = The Offline Address Book uses the Download Full Items download mode. This is the default setting.

2 = Download the Offline Address Book in any download mode, but download a differential update in the Header only download mode.

3 = Always download the Offline Address Book and a differential update in one of the following download modes:
 

JackPollack

Senior Member
Outlook version
Email Account
Exchange Server
Thanks for your post. I was away and didn't have a chance to try the reg setting until a few days ago. Unfortunately it did not help.
Someone suggested that I try changing the connection settings to "Connect to my exchange mailbox using HTTP" (on fast networks use HTTP, on slow networks use HTTP, Basic Authentication). THIS APPEARS TO HAVE DONE THE TRICK :) I'm so happy.

Do you know what the ramifications of changing this setting are?

Thanks again for all your help
 

JackPollack

Senior Member
Outlook version
Email Account
Exchange Server
oops, starting to be a little less happy. Still not logging any errors, but I just found out if I use basic authentication I need to enter my exchange password every time I launch Outlook.

Anyway around this? Or, since this fixed the problem, maybe there is something else I can tweak and go back to original NTLM Authentication without proxy settings (I did try proxy with NTLM, but could not log in)
 

larry

Senior Member
Outlook version
Outlook 2010 64 bit
Email Account
Exchange Server
This is a hosted Exchange? I don't think you can tweak anything on the server to avoid that. You can try adding the domain to the IE Trusted interest settings but it may or may not help. (It seems to work for some.)
 
Status
Not open for further replies.
Top