mailto links in browsers don't open up outlook email

Status
Not open for further replies.

mrje1

Senior Member
Outlook version
Outlook 2016 32 bit
Email Account
POP3
Hello everyone,

When ever I click a mailto link in either Chrome, IE, Firefox and Opera it opens up chrome browser. Before I installed windows 8 I had it opening up Outlook 2010 new email, now it opens up a new Chrome browser window.

How do I change it in windows 8 to when I click a link on either browser to open up Outlook 2010 new email as it did before?

Thank you for your help.
 

Diane Poremsky

Senior Member
Outlook version
Outlook 2016 32 bit
Email Account
Office 365 Exchange
In Windows 8, press Windows key to get back to the Start screen then type default - two links should come up on the screen - choose Default Programs. Click Set your default programs and select outlook, then click the Set as default button. If you click the choose defaults button, you can see what it will be default for and confirm mailto in the list - there is a Select all option there.
 

mrje1

Senior Member
Outlook version
Outlook 2016 32 bit
Email Account
POP3
In Windows 8, press Windows key to get back to the Start screen then type default - two links should come up on the screen - choose Default Programs. Click Set your default programs and select outlook, then click the Set as default button. If you click the choose defaults button, you can see what it will be default for and confirm mailto in the list - there is a Select all option there.
Hi Diane,

I did that originally, but I didn't check to see if all of the options were selected and the mailto: happened to still not be checked for some reason. Once I did that, everything was working fine. So, problem is solved. Thank you for your help.
 
Status
Not open for further replies.
Top