large mailbox question using 2010 on exchange 2k3

Status
Not open for further replies.

davehedgehog

Member
Outlook version
Outlook 2010 32 bit
Email Account
Exchange Server
Exchange 2003. User is using outlook 2010.

I have an issue relating to a shared mailbox. When the user (this actually happens to more than one user) tries to move mails or view subfolders in the mailbox they get the error "Cannot display the folder. Microsoft Outlook cannot access the specified folder location. Your server administrator has limited the number of items you can open simultaneously. Try closing messages you have opened or removing attachments and images from unsent messages you are composing"

This does not happen on outlook 2k3.

After a quick Google I have seen something mentioned about the way that outlook 2010 behaves with large mailboxes, and that this errors related to the amount of open connections. If this is true is there more detailed info anyway anyone can point me towards?

I'm trying to find out exactly what this problem is and what the difference between outlook 2k3 and 2010, whether the above is correct and if so more information on it. I've googled but had no luck. Ultimately a fix for this is neede if possible as currently on Windows 7 this mailbox is unusable.

Many thanks for any input, much appreciated.
 

FatToad

Member
Outlook version
Outlook 2010 32 bit
Email Account
Exchange Server
I have seen similar issues with large mailboxes and Outlook 2010 (32bit) running on Win7 (64bit) against a 2003 Exchange server.

The fix for me was to turn off Cached Exchange Mode. It looked like everything was going to crash when reopening Outlook, but all was better. This resolved 2 different issues with 2 different users on the same Exchange server.

Hope this helps,

FatToad
 

Diane Poremsky

Senior Member
Outlook version
Outlook 2016 32 bit
Email Account
Office 365 Exchange
I don't think this is related to the 500 folder limit... because i think was also in outlook 2003, but the error message looks familar. (will check on it.)




The difference may be that cached mode in outlook 2010 caches all shared folders too (by default). Rather than turning off cached mode completely, you can disable it for shared accounts.




Account settings, double click on the account, more settings, second tab in the dialog.
 
Status
Not open for further replies.
Top