Outlook 2016 shows Meeting Organizer in Calendar View

Jeremy87

New Member
Outlook version
Outlook 2013 64 bit
Email Account
Office 365 Exchange
Is there a way to not have the meeting organizer appear in the calendar view in the Outlook 2016 client? When we create a new meeting the organizer appears as if it's part of the subject even though it's not.

I've created a support ticket with Microsoft and they're currently looking into it but thought I'd ask and see if anyone has found a work around. It doesn't appear when viewing through OWA but it does in the Outlook client.

I did try the following Powershell cmdlet but it didn't have any effect.

Set-CalendarProcessing -Identity <RESOURCEMAILBOX> -DeleteSubject $False -AddOrganizerToSubject $False

To give you a picture of what I'm talking about, the test appointment on May 14th shows the subject "Test 8" but it also shows MaStaff Calendar which is the organizer/username of the account.

 

Jeremy87

New Member
Outlook version
Outlook 2013 64 bit
Email Account
Office 365 Exchange
It's a user account that we created just for the use of the calendar. That way it's not tied to a staff member's account.
 

Diane Poremsky

Senior Member
Outlook version
Outlook 2016 32 bit
Email Account
Office 365 Exchange
The admin can try the cmdlet to disable the name, but if it won't work on a shared mailbox, you'll need to convert it to a resource mailbox.
 

Jeremy87

New Member
Outlook version
Outlook 2013 64 bit
Email Account
Office 365 Exchange
I created an equipment mailbox to test and it's experiencing the same symptoms. I don't really want to create it as a "room calendar" because it's a calendar for school events.
 

Diane Poremsky

Senior Member
Outlook version
Outlook 2016 32 bit
Email Account
Office 365 Exchange
the cmdlet should apply to all resource mailboxes - equipment and meetings.
 
Top