How to establish Soap Connection

Status
Not open for further replies.
T

Thomas Weiler

Hello,

Iam trying to connect to a ASP.NET Webservice on another Server via

Outlook 2003 VBA. I´ve linked the "Microsoft Soap Type Library".

When I now go through the following code via debugger, it goes without

any error message. But on the Webserver nothing happens (Ived activate

the debugger on the ASP.NET Application and nothing happens).

What do I make wrong or what is missing in the code to establish a

correct connection?

-------------------------- snip --Dim msxml As New MSXML2.XMLHTTP

strEnvelope = _

"<soap:envelope

xmlns:soap=""urn:schemas-xmlsoap-org:soap.v1"">" & _

"<soap:header></soap:header>" & _

"<soap:body>" & _

"<myFunction xmlns='http://tempuri.org/'>" & _

"<var1>TextTextText</var1>" & _

"<var2>string</var2>" & _

"</myFunction>" & _

"</soap:body>" & _

"</soap:envelope>"

strServ = "http://myserver/myservice.asmx"

msxml.Open "post", strServ, False

msxml.setRequestHeader "Content-Type", "text/xml"

msxml.Send strEnvelope

-------------------------- snap --Thanks for all answers.
 

Michael Bauer

Senior Member
Outlook version
Outlook 2010 32 bit
Email Account
Exchange Server
If your code gets executed at all, Outlook's part is done. For asp.net your

might need to answer in an appropriate newsgroup.

Best regards

Michael Bauer

Am Thu, 16 Jul 2009 15:05:24 +0200 schrieb Thomas Weiler:


> Hello,

> Iam trying to connect to a ASP.NET Webservice on another Server via
> Outlook 2003 VBA. I´ve linked the "Microsoft Soap Type Library".

> When I now go through the following code via debugger, it goes without
> any error message. But on the Webserver nothing happens (Ived activate
> the debugger on the ASP.NET Application and nothing happens).

> What do I make wrong or what is missing in the code to establish a
> correct connection?

> -------------------------- snip --> Dim msxml As New MSXML2.XMLHTTP

> strEnvelope = _
> "<soap:envelope
> xmlns:soap=""urn:schemas-xmlsoap-org:soap.v1"">" & _
> "<soap:header></soap:header>" & _
> "<soap:body>" & _
> "<myFunction xmlns='http://tempuri.org/'>" & _
> "<var1>TextTextText</var1>" & _
> "<var2>string</var2>" & _
> "</myFunction>" & _
> "</soap:body>" & _
> "</soap:envelope>"

> strServ = "http://myserver/myservice.asmx"

> msxml.Open "post", strServ, False
> msxml.setRequestHeader "Content-Type", "text/xml"

> msxml.Send strEnvelope

> -------------------------- snap --> Thanks for all answers.
 
T

Thomas Weiler

Michael Bauer schrieb:
> If your code gets executed at all, Outlook's part is done. For asp.net your
> might need to answer in an appropriate newsgroup.
>


Thats the problem. The Webserver with the asp.net Webservice don`t get

any data (there is no entry in the web server log too). It seems that

the vba code goes through without doing anything.
 

Michael Bauer

Senior Member
Outlook version
Outlook 2010 32 bit
Email Account
Exchange Server
Have you tried to set a breakpoint (f9) at the line:

msxml.Open "post", strServ, False

and seen whether or not the line is called?

Best regards

Michael Bauer

Am Mon, 20 Jul 2009 07:54:56 +0200 schrieb Thomas Weiler:


> Michael Bauer schrieb:
> > If your code gets executed at all, Outlook's part is done. For asp.net


your
> > might need to answer in an appropriate newsgroup.
> >

> Thats the problem. The Webserver with the asp.net Webservice don`t get
> any data (there is no entry in the web server log too). It seems that
> the vba code goes through without doing anything.
 
T

Thomas Weiler

Michael Bauer schrieb:

> Have you tried to set a breakpoint (f9) at the line:

> msxml.Open "post", strServ, False

> and seen whether or not the line is called?
>


Yes it is called and goes through but I get no action on the webservice.
 

Michael Bauer

Senior Member
Outlook version
Outlook 2010 32 bit
Email Account
Exchange Server
Ok, that's what I thought. You need someone who can help with either the xml

library or asp/your webserver. In an appropriate newsgroup the chance for a

helpful answer should be better.

Best regards

Michael Bauer

Am Tue, 21 Jul 2009 15:22:26 +0200 schrieb Thomas Weiler:


> Michael Bauer schrieb:
>

>> Have you tried to set a breakpoint (f9) at the line:
>

>> msxml.Open "post", strServ, False
>

>> and seen whether or not the line is called?
> >

> Yes it is called and goes through but I get no action on the webservice.
 
Status
Not open for further replies.
Similar threads
Thread starter Title Forum Replies Date
B can not establish BCM 2010 connection to Shared DB on SQL 2008 Express BCM (Business Contact Manager) 4
e_a_g_l_e_p_i All of a sudden I lost connection to Gmail servers Using Outlook 8
W Encrypted connection to server refused Using Outlook 0
A Prevent connection to Public Folders on Exchange? Exchange Server Administration 3
D Outlook 2016 IMAP Connection Returns All Email but outlook.com does NOT Using Outlook.com accounts in Outlook 2
O Outlook 2016 0x800CCC0F 'The connection to the server was interrupted' Using Outlook.com accounts in Outlook 1
J Office 365 and Outlook connection issues Using Outlook.com accounts in Outlook 3
M Outlook 2010 Error: Your IMAP server closed the connection Using Outlook.com accounts in Outlook 1
M Outlook Email Connection Error Using Outlook 3
M BCM remote database connection issue BCM (Business Contact Manager) 1
C Last Connection Using Outlook.com accounts in Outlook 1
K Work Email - Calander Connection to Outlook.com Using Outlook 2
R The action cannot be completed. The connection to Microsoft Exchange is unavailable. outlook must be Using Outlook 1
E IMAP server closed the connection Using Outlook 2
P Outlook Connection Issues Using Outlook 3
Z connection to Lotus Notes Using Outlook 4
A Exchange 2003 Outlook 2010 64 Bit- AutoDiscover Connection Err - Certificate Exchange Server Administration 9
M connection to the microsoft exchange server has been lost. outlook 2007 Exchange Server Administration 0
K Intermittent ability to send to single domain. "Connection refused" Exchange Server Administration 1
N Connection Error Using Outlook 2
E intermittent "Your imap server closed the connection" messages Using Outlook 6
M "No database found" but successful connection to SQL server.What am I missing? BCM (Business Contact Manager) 5
0 Outlook 2010 causes computer to lose connection when opening and Send/Receive Using Outlook.com accounts in Outlook 14
N Outlooking not connecting. Connection present Using Outlook 1
S Outlook connector, numerous versions, connection issues Using Outlook.com accounts in Outlook 1
T Outlook keep loosing connection to the exchange server Using Outlook 1
S Remote connection to bcm BCM (Business Contact Manager) 1
D Event on connection mode change? Outlook VBA and Custom Forms 2
P Database connection problems BCM (Business Contact Manager) 1
J BCM connection problem BCM (Business Contact Manager) 3
M Outlook 2007 "Connection Status..." shows 3 "Disconnected" entries of type "Directory" Using Outlook 18
S ClipMate clipboard connection Outlook Wishlist 1
M trouble connection to remote database BCM (Business Contact Manager) 1
M MSO OL sp2 for BCM broke SQL Database connection BCM (Business Contact Manager) 2

Similar threads

Top