Outlook 2010 won't preview Office attachments

Status
Not open for further replies.

boppy2010

Senior Member
I installed Office 2010 on my brand new Win 8 64 bit laptop.

Clicking on Word, Excel PDF or PP attachments in Outlook does not preview them - I just get the continued message "opening (app) previewer". I can save and open them.

In Safe Mode I can preview PDFs but no Office docs.

I have gone into Options/Trust Centre and enabled attachment preview. All previewers have check marks.

In Excel I have un-checked protected view under Trust Centre settings.

From searching on line I see this is a common issue yet I've found no solution. Some users suggested repairing Office but no one reported that to have any effect.

Is there anything anyone here can suggest I try?

Thanks in advance

Jo
 

Diane Poremsky

Senior Member
Outlook version
Outlook 2016 32 bit
Email Account
Office 365 Exchange
I would definitely try repair.

Are only office apps affected?

Did you see this:

Somehow the DCOM permission got changed, so it wouldn't allow certain applications access to simple things like Preview mode on Outlook 2010 / 2007, or opening up attachments without it saying file corrupt. I also was having an issue with Pop ups in IE8, where javascript messages about security tokens were not authenticated.

The solution is as follows, and then you can turn on your protected mode back on in word, excel, and your "Preview mode" in outlook will start working again.

Go to start, then run. Type dcomcnfg and push o.k. Component Services should come up.

Expand Component Services, click on Computers, then "Right click" on My Computer and go to "properties".

Click on Default Properties tab, and make sure the following is set:

Default Authentication Level: Should say Connect, not "None"

And Default Impersonation Level: SHould say Identify.

When those are set properly, hit o.k and turn on your protected mode back on your Office applications. Everything works as expected :)
 

Diane Poremsky

Senior Member
Outlook version
Outlook 2016 32 bit
Email Account
Office 365 Exchange
I would definitely try repair.

What antivirus do you use? What addins are installed? Because it (half) worked in safe mode, an addin could be causing issues.
 
Status
Not open for further replies.
Top