Outlook 2010 Rules: fwd meeting invitation results in winmail.dat not .ics

Status
Not open for further replies.

Divermarv

Member
Outlook version
Outlook 2010 64 bit
Email Account
POP3
I am using Outlook 2010, and have the following need: I need to forward meeting invitations updates to another email address which I use for scheduling. It's not likely that I can get everyone to send meeting requests to my alternate email. If I manually forward meeting requests, then I receive proper calendar .ics files on my alternate account. But when I set up a rule to handle this, the forwarded email has a winmail.dat attachment rather than the calendar .ics in the body.

So I can do this manually and it works, but the rule doesn't work properly.

I appreciate all responses.
 

MamaSamaki

Member
Outlook version
Outlook 2010 32 bit
Email Account
Exchange Server
I am using Outlook 2010, and have the following need: I need to forward meeting invitations updates to another email address which I use for scheduling. It's not likely that I can get everyone to send meeting requests to my alternate email. If I manually forward meeting requests, then I receive proper calendar .ics files on my alternate account. But when I set up a rule to handle this, the forwarded email has a winmail.dat attachment rather than the calendar .ics in the body.

So I can do this manually and it works, but the rule doesn't work properly.

I appreciate all responses.
Hi, did you find a solution to this? I can't sync directly with my work schedule (MS Exchange/Outlook 2010).

The closest I've got is a rather clumsy workaround that relies on me remembering to forward the appointment from Outlook manually - ugly and infinitely fallible. Google apps promised much and failed, fault probably lying at our end rather than Google's.

Be interested to find out if you got anywhere
H
 

Diane Poremsky

Senior Member
Outlook version
Outlook 2016 32 bit
Email Account
Office 365 Exchange
Winmail.dat means it was being forwarded as RTF, which probably means it was being sent as an Outlook item, not as an icalendar in internet format. The other cause is that the address is marked to always get TNEF. This is less likely, because the manual forward uses the same address data. You can try addressing a new message to the affected address and delete it from the autocomplete list.... but I suspect the real cause is that its not being sent in internet format. Oh, also check your settings in File, Options, Calendar - is the option to use icalendars to internet addresses enabled?

A macro that automatically forwards anything added to the calendar might work. It should replicate the manual steps you'd use.

Since it's gmail, you might want to take a look at magneto - it's a web service that syncs exchange and gmail (and more) - you can set it up rules in it to anything on Exchange is sent to the gmail calendar (and/or gmail to exchange, if you want both calendars identical).
 

MamaSamaki

Member
Outlook version
Outlook 2010 32 bit
Email Account
Exchange Server
Thanks Diane - the clue was in the RTF. I switched my email format to HTML and Outlook has just applied my rule and forwarded a meeting invitation as an ics file to my smartphone. Result - hopefully its reliable and not a one off.

Its not ideal - these days we should be able to seamlessly sync but my firm flat refuses to switch on activesync for Android, and I'll no doubt be tarred and feathered for using HTML format by default - but my clumsy ugly workaround is slightly less clumsy and ugly and much less reliant on my failing short term memory. This can only be a good thing ;-)
 

Diane Poremsky

Senior Member
Outlook version
Outlook 2016 32 bit
Email Account
Office 365 Exchange
If that fixed it, it should always work.

FWIW RE: RTF formatting. 1) I'm surprised they don't set the server to convert RTF to html for internet addresses. 2) A security bulletin a couple of weeks ago was about RTF exploits which could (theoretically) be included in email, so not receiving RTF formatted messages is safer. I'm not 100% sure the exploit could work in Email because it's sandboxed, but I also haven't fully tested it. In any event, this week's Office updates address this exploit.
 
Status
Not open for further replies.
Top