Outlook 2007 SSL selfsigned certificate how to stop security popup everytime?

Status
Not open for further replies.

tf35lightning

Member
Outlook version
Outlook 2007
Email Account
IMAP
Hi all,






I have a SSL IMAP email account that I just setup in Outlook 2007.






Everytime I run the program I get a popup Screen shot here: http://gyazo.com/a394a09ca212897730c5b5c0f791be81.png?1362620546










"Internet Secuirty Warning"


The server you are connected to is using a security certificate that cannot be verified. The target principle name is incorrect. View Certificate.






Do you want to continue using this server, Yes or No. View certificate screenshot http://gyazo.com/722e280565a62d8c6b4bfe841c4e9ffc.png






I expect to see a popup because the certificate is self signed so I always just click Yes to continue using the server/email account, but how do I get Outlook 2007 to remember this?, so every time I run the program I don't get this annoying Internet Security Warning popup?


Other email clients just have a simple remember action button or something along those lines.










Any help or tutorials would be much appreciated
 

Diane Poremsky

Senior Member
Outlook version
Outlook 2016 32 bit
Email Account
Office 365 Exchange
Re: Outlook 2007 SSL selfsigned certificate how to stop security popup everyti

Try saving it as a trusted certificate - since it's a self signed one, putting it in Trusted root should be safe. Some of the other certificate stores should work too, although I have not tried them.
 

tf35lightning

Member
Outlook version
Outlook 2007
Email Account
IMAP
Re: Outlook 2007 SSL selfsigned certificate how to stop security popup everyti

Hello Diane thanks so much for responding to my question it's REALLY appreciated. Do you have any tutorials I can run through on how to save/install these certificates etc as I have never had to do this before, and all the ones I find through Google seem to lead me of track or involved exchange in someway.

I'll just quickly run through the screens I am seeing to make sure we are on the same page.

1. Internet Security Warning pop I'm trying to get rid of

1.PNG

2. If I click on view certificate the screens I can see

21.png

3. If I click on copy to file I get the "Export wizard"

31.png

I'm really not sure where to go from here. I'm guessing I export it out as a file and install it back into the Outlook Program somehow or somewhere in the Windows Control panel?

Any extra help would be great

Kind regards
 

Diane Poremsky

Senior Member
Outlook version
Outlook 2016 32 bit
Email Account
Office 365 Exchange
Re: Outlook 2007 SSL selfsigned certificate how to stop security popup everyti

Export as a file then import it in the Certificate manager (its in control panel) Make sure you put it in the trusted root. If you still have problems, i can record a video for you tomorrow.
 

tf35lightning

Member
Outlook version
Outlook 2007
Email Account
IMAP
Re: Outlook 2007 SSL selfsigned certificate how to stop security popup everyti

Thanks again for the help Diane.

Okay I exported the certificate, then found the Certificate manager by searching for "
certmgr.msc" (I can't see it in my control panel/administration area)

Under the certmgr.msc panel, I clicked on Trusted Root Certification Authorities, then Certificates, then right clicked that folder and clicked All Tasks and then Import.

Which then it successfully installed the Certificate.

I rebooted the system, then tried Outlook 2007 again, but unfortunately I still got the same Popup box (Internet Security Warning) etc which i just click Yes to.

Is there something else I need to do after I install the certificate or?

Thanks again for the assistance
 

Nap

Member
Outlook version
Outlook 2007
Email Account
POP3
Re: Outlook 2007 SSL selfsigned certificate how to stop security popup everyti

Hi,
I have exactly the same inconvenience. I have installed the certificate and still get this dialog box every time I send an email.
I run my own server and don't want to move to a 'well known' to collect BIG data 'free' account.
Has there been any progress on this matter?

Cheers,

Nap
 

tf35lightning

Member
Outlook version
Outlook 2007
Email Account
IMAP
Re: Outlook 2007 SSL selfsigned certificate how to stop security popup everyti

Hi Nap,

Unfortunately I have not found a solution to this and I have to click on the "internet Security Warning" pop up Yes every time still.

If you come across any solutions please let me know, fingers crossed.
 

Nap

Member
Outlook version
Outlook 2007
Email Account
POP3
Re: Outlook 2007 SSL selfsigned certificate how to stop security popup everyti

@tf35lightning, I'll let you know if/when I do.

I've had my own server now for a long time and this has only started happening with a recent update to Office or windows. Probably when MS found some of their certificates compromised?
 

Nap

Member
Outlook version
Outlook 2007
Email Account
POP3
Re: Outlook 2007 SSL selfsigned certificate how to stop security popup everyti

I have fixed the problem in my setup.

Tools > Account Settings > Change Email Account > More Settings > Advanced

In my account settings, I had the "Use the following type of encrypted connection:" set to TLS. Setting it back to none fixed the problem.
 

Nap

Member
Outlook version
Outlook 2007
Email Account
POP3
@tf35lightning
I have found the answer, at last!!


The problem is that the "Common Name" field of the certificate says "Parallels Panel" and NOT the FQDN of the mail server (eg mail.parallelspanel.com).

Outlook is comparing your [Account Settings -> Mail Server name] to the Issued To field of the certificate. You need to create a new certificate, and when you're asked to fill in the "Common Name" field, put in the FQDN of the machine hosting the mail server.

Hope this helps.

Cheers,
Nap
 

Nap

Member
Outlook version
Outlook 2007
Email Account
POP3
@tf35lightning
I have found the answer, at last!!


The problem is that the "Common Name" field of the certificate says "Parallels Panel" and NOT the FQDN of the mail server (eg mail.parallelspanel.com).

Outlook is comparing your [Account Settings -> Mail Server name] to the Issued To field of the certificate. You need to create a new certificate, and when you're asked to fill in the "Common Name" field, put in the FQDN of the machine hosting the mail server.

Hope this helps.

Cheers,
Nap
Another thing, if your account is on a server supplied by a hosting company, the certificate should be Issued To: the FQDN of their server, and your account settings should use that FQDN as the mail server. Outlook will report a warning if those two parameters don't match.

You can still send/receive mail using your domain name, just that you need to use their server name to connect to the mail server.

Nap
 
Status
Not open for further replies.
Top