Revert AutoArchive settings via GPO (Run Autoarchive every...)

kschissler

Member
Outlook version
Outlook 2010 32 bit
Email Account
Exchange Server
Hello Forum:
In our Office 2010 GPOs, we have Enable AutoArchive set to Disabled, and Disable File|Archive set to Disabled, thus allowing our users to manually archive, but turning off the AutoArchive feature in Outlook 2010. In AutoArchive settings, all settings are grayed out, thus preventing the user from turning on AutoArchive, which is acceptable for all users.

We have been asked to revert this for one group of users. They would like total control of this feature, meaning that the Run AutoArchive every ## days option needs to be "un-grayed" and able to be selected.
upload_2014-10-1_13-52-42.png

Easy enough - just change the AutoArchive setting to Enabled in their GPO to "un-do" the setting that we initially made, right? However, this does not work.

While it does allow us admins to enable AutoArchiving, and allows us to set all the settings, it grays out all the items for the end user. (i.e. They cannot check or uncheck Run AutoArchive every xx days.)
Our intention is to wipe this configuration clean, and give the AutoArchive control back to the end user.
Could it be that our decision to disable AutoArchive via GPO is no longer letting us give this control back?
What are we missing?

Thanks for your time!
 

kschissler

Member
Outlook version
Outlook 2010 32 bit
Email Account
Exchange Server
Hi Diane, thanks for the reply! Unfortunately yes, we did try "Not Configured". It had the same results.
Upon logging in as the user, the AutoArchive options were still all grayed ont. :/
 

Diane Poremsky

Senior Member
Outlook version
Outlook 2016 32 bit
Email Account
Office 365 Exchange
Look at the key in the registry on one of the affected machines. Was it removed by the GPO? If not, delete it and restart outlook - if it works, use a logon script to delete the values.
 

kschissler

Member
Outlook version
Outlook 2010 32 bit
Email Account
Exchange Server
Hi again Diane - your suggestion, and another unrelated post regarding GPO behavior sparked something. :)
Since the GPO was a user-based one, I checked the active HKCU hive for the settings. It was the DoAging reg setting, along with a few others that were present, and by their mere presence in the registry, they were controlling the behavior of the AutoArchive settings. I needed to delete these registry settings by adding another GPO linked to a subordinate OU, which deleted these registry keys for the specific group of users requesting AutoArchive control. I was then able to check/uncheck the Run AutoArchive every xx days checkbox, and select other configuration options.
From what I have observed, the GPO put these reg settings in, effectively "tatooing" this configuration for the user. Simply flipping the bits to either "1" or "0" did not reverse the changes that the GPO made.
SOLVED!
 
Top