outlook 2007 - opening a contact from the search results doesn't use the custom form

zdoe

Member
up to like 2 months ago i was using lookout, which then for some reason stopped working and i couldn't get it back on.

looken failed to install, and other alternatives seemed bloated. so i thought i'd give a go to bill gates' search. which is better than i thought, but:

when i open a contact from the search results, the custom form that i use doesn't load - instead i get the default contact form that has bad use of real-estate and missing some of the functionality of my form.

so now i'm in the habit of: click on the search result contact, alter it, save it, then go to contacts reverse chronological sort and it'll be on the top and i can open it.

obviously a bit laborious...

is there a way to make ol2007 honor the custom form?
 

zdoe

Member
What type of email account are you using? Where is the form published? I think this is a known issue but will double check on it.
email - no exchange server, just a bunch of locally set up pop3/smtp mail accounts.

published - Outlook:\\Contacts - this is what i see when i go to publish a form the way i believe i had published this. though not sure if this is the answer to your question. i've been using this form for a decade, don't remember the exact steps back then. also, the same dialogue says: Message Class: IPM.Contact - not sure if that's relevant.
 

Forum Admin

Senior Member
Try publishing it to the personal forms library - it's more global than the contacts folder, whereas the contacts is just in contacts - instant search creates a temporary search folder and may not be able to use the form. There is no guarantee this will fix it though. Also, when you publish it, update the version number on the properties tab of the form so outlook uses it.

Was that the lookout that microsoft purchased? I'm guessing an update (either windows or office) probably affected it.
 

zdoe

Member
dear admin - you're golden, publishing the form in personal forms library DOES make the right form open in searches.

but now there's another matter to reckon with - the custom form has existed under two different names on the system(s) over the years, though they're the same. is there a way to change the "underlying" form of an existing contact?

and if so, can this be done without altering the "modified date" attribute?

yes, indeed that WAS lookout that bill bought & killed. i gather its existence was too much of a loss of face for him. the latest on that is here:
http://vlad.bailescu.ro/articles/2008/07/01/outlook-2007-vista-spam-protection-and-lightning-fast-search/comment-page-1/?wpc=dlc#comment-595566

yes, it's bizarre, but automatic updates are off, and i don't know that i would've done any manual updates at the time when it stopped working - though perhaps something changed in the super-brittle .NET realm that lookout uses. so that inspired me to try other things, but i'd still go back if i knew how to - it's better than the bill-search, for one because it gives you confidence rankings on the results.

anyone here have lookeen working?
 

zdoe

Member
ms. poremsky, you're golden, too. just ran DocMessageClass and sorted it out.

it DOES change the date-modified attribute, but turned out that there was not THAT many entries to alter so the damage is not devastating.

now - is there a way "unpublish" a previously published form so that i could remove the redundant duplicate entries from the published forms -list(s)?
 

Diane Poremsky

Senior Member
Outlook version
Outlook 2016 32 bit
Email Account
Office 365 Exchange
You can remove forms in Tools, Options.. somewhere. I think on the Other tab - look for a Manage Forms button. If you can't find it. I'll bring up a virtual machine with Outlook 2007 and get the correct location.... or I can look on my website and find the path. :)

I was close -

In Outlook 2007, 2003 or 2002 choose Tools > Options > Other tab > Advanced Options > Custom Forms > Manage Forms and use the Forms Manager that pops up.
 

zdoe

Member
yes, that's where it's at. only:

"Cannot display the dialog box. No pages in the property sheet because of low memory. Close some windows or programs."

as i suspected, this persists also after reboot / nothing else running. win7/64, 16Gb of memory on the system. is there a registry key i could alter to unpublish? or some other remedy, perhaps?
 

zdoe

Member
yes, that worked. due to frequent out-of-memory msgs i had disabled everything i could on some previous round.
 
Top