Database is mandatory on UserMailbox error during install of Hub Transport

Not open for further replies.

Sandy Harvey

I have one Exchange 2010 RC server up and running and able to login 2 user accounts. I am ready to setup the 2nd Exchange server in the test lab. This server is the same name as the one I created in Beta. But now when I try to install this server, it fails on the hub transport with this database error. I'm not sure what database it means as it is not specific. Most of the posts I find refer to a specific database, which in this case it does not. Any help would be appreciated.
Summary: 5 item(s). 1 succeeded, 1 failed.

Elapsed time: 00:00:09

Preparing Setup


Elapsed Time: 00:00:06

Hub Transport Role



The following error was generated when " $error.Clear(); if ( ($server -eq $null) -and ($RoleIsDatacenter -ne $true) ) { Update-RmsSharedIdentity -ServerName $RoleNetBIOSName }" was run: " Database is mandatory on UserMailbox. Property Name: Database" .

Database is mandatory on UserMailbox. Property Name: Database

Elapsed Time: 00:00:03

Client Access Role


Mailbox Role


Finalizing Setup

Found a very strange situation with this one, but resolved it. It appears that one user account, which I enabled the mailbox on through the EMC and assigned to the specific database on the one server I had up and running was causing the issue. I have no idea why. Once we removed that user, then the install of the hub transport on the 2nd server went fine. We then readded the user and enabled his mailbox in the same again to see if it would do the same thing to the database properties.

So, after bringing up the 2nd server, we used ADSI Edit to look at the properties of the mailbox databases. The homeMDBBL attribute that says CN=SystemMailbox.

But the 1st server, after adding the user back and specifically assigning him to the 1st server's mailbox database changed this attribute to point to his CN, not the SystemMailbox, which is odd since there are 3 total users on that mailbox database now and because I used the wizard to enable his mailbox and assign him to this database, it changed the homeMDBBL attribute to his CN. This is the way it was prior to deleting him from EMC and out of AD, so I think this is what caused the 2nd server not to install the hub transport correctly.
Since I don't know enough about Exchange to know if it should be this way or not, I'm just posting this finding out here in case anyone else runs into this problem. But it sure would be nice to know why this is and why it would prevent you from installing the hub transport role on another server. Thanks.

Hi Sandy same issue here ... how did you identify the user that made the problems and did you find away other then completely removing the user?

CU Daniel
We used ADSI Edit and went to the mailbox database and looked at the object's attributes for the homeMDBBL attribute. In that attribute it showed the CN= of the user that seemed to be our issue. We had to remove the user completely and then we were able to continue with the install. We put the user back after the install was completed, but it did change the attribute back, so I'm not sure that we'd be able to install another server if we needed to without removing the user again. But since this is in our lab environment, we were able to do so. If we were in production, we'd have a major problem with this type of solution, thus why I'm hoping Microsoft is monitoring these threads to know what they need to fix before RTM.
Hi Sandy,

I would like to share, what I did to get around the problem.

I guess I came into this issue because I installed Exchange 2010 beta in a VM and then simply deleted the VM without uninstalling Exchange 2010 beta or cleaning my AD that sits on my lab server. When I installed the RC I got the above error message.

What I did to resolve this:

1) I downloaded the AD cmdlets for powershell from Quest here:

2) I played around with it and started to delete Exchange attributes on all accounts in my AD (I just have a couple of test user accounts in it so I didn't mind much, if something breaks). Using the AD cmdlets by Quest I used the following script to delete all Exchange attributes, that were attached to the users I had joined to the old Exchange 2010 beta. The script runs on ALL users and deletes attributes, so BEWARE.

Here is the script:

$userlist = Get-QADUser -IncludeAllProperties

$userlist | ForEach { Set-QADUser $_ -ObjectAttributes @{msexchmailboxguid=''; msexchhomeservername=''; legacyexchangedn=''; mail=''; mailnickname=''; msexchmailboxsecuritydescriptor=''; msexchpoliciesincluded=''; msexchrecipientdisplaytype=''; msexchrecipienttypedetails=''; msexchumdtmfmap=''; msexchuseraccountcontrol=''; msexchversion='' } }

msexchmailboxguid, msexchhomeservername and legacyexchangedn alone did not do the trick, so I added the rest that looked obviously like exchange and then the hub installation went through.

Hope this helps. Maybe somebody from MSFT can comment which exact attribute caused the problem, and inform the product group to fix the issue.

@Sandy, thx for your answer.

CU Daniel
Thanks for your information too. I did the same thing with VM and just wiped the server instead of cleaning up AD. I do hope that Microsoft can comment on this issue because it will keep us from installing additional servers. Once I added the user back and assigned them to a specific database, the issue was back on the attribute showing their CN, so I know it's not fixed by just deleting the attributes or the user.
it did this to me without any mailboxes. I wiped my beta config out of AD (had to use ADSI to get rid of it because I tried to migrate my mbx to a new server running the RC and it didn't like that hehe), installed Exchange 2010, realized I messed up something (forgot to delete the old Exchange 2010 beta security groups), uninstalled it, then did a reinstall and got this error the first time when i was installing the mailbox role, so i rebooted went into programs and features readded the mbx role and everything was fine. I haven't tested adding the hub transport or cas roles yet.
I think the cleanup in AD when you don't do a proper uninstall of a server is not documented very well. I think you end up with remnants that cause these kinds of issues.
I receive the same error " Database is mandatory on UserMailbox. Property Name: Database" when attempting to install additional Exchange 2010 RC mailbox server roles. I have one 2010 RC HUB/CAS/MAILBOX running just fine. I wanted to add more mailbox roles to setup a Database Availibility Group, kind of hard to do with one mailbox server! I'm attempting this install into an existing Exchange 2007 org with all servers running Exchange SP2. I was able to set this up in a completely new environment just to see if Exchange 2010 wasn't " broken" but in reality I need it to co-exist with 2007 & 2003 for migration purposes. I would think maybe something in AD is messed up but I'm not sure what. Any ideas & advise would be appreciated. Thanks!
I ran into the exact same issue under similar circumstances with Exchange 2010 RC. I was using a VM to host Exchange 2010 and lost access to the Exchange Management Console. Once you lose access you can't move mailboxes. If you can't move mailboxes you can't do a clean uninstall of Exchange 2010. If you delete the VM and Exchange 2010 Active Directory becomes a mess and won't allow any instance of Exchange 2010 to be installed.
Does anyone have a definitive answer as to how to fix this?
Not sure if this is a 100% fix but I had exchange 2007 install, uninstalled and then installed 2010 on one server it would never mount a database, so I uninstalled it and created another server and it failed on the Hub Transport. I did the install over leaving ou the hub transport and everything worked once I got mailbox's setup I was able to reinstall the Hub Transport
Lets bring this one back to the top. Could really use some more info on how to handle this.
Take a look at this article I had a very similar problem and this fixed it quickly

Mitch Roberson |MCITP:Enterprise Server Admin, Messaging |MCTS:OCS with Voice Achievement |MCT |MCSE 2000\2003 |MCSE Messaging 2000\2003
I was able to get the Hub Transport installed with the same error by just installing all the other components first then going back and installing the Hub. I did follow but it did not seem to resolve the issue but may have helped.
I had the same error installing Exchange Server 2010 on Server 2008 R2.

The article did not do anything for me. In fact if Exchange doesn't install you cannot add the mailbox back that it tells you to delete. As it turns out, although it's not mentioned anywhere, you have to use the Exchange Console which doesn't get installed if Exchange is not installed.

The process to install Exchange 2010 is rediculous. I can't belive how many problems there are with the installation process.

Now I'm left with a failed installation and an additional problem of the missing required Federated mailbox.

Thanks a lot!
I had this issue:


The following error was generated when " $error.Clear(); if ( ($server -eq $null) -and ($RoleIsDatacenter -ne $true) ) { Update-RmsSharedIdentity -ServerName $RoleNetBIOSName }" was run: " Database is mandatory on UserMailbox. Property Name: Database" .

Database is mandatory on UserMailbox. Property Name: Database

I also followed this article:

when I ran " get-mailbox -arbitration" it showed me the two offending mailboxes, eg:

SystemMailbox{1f05a927... SystemMailbox{1f0... <server name> unlimited

WARNING: The object <domain>/Users/SystemMailbox{1f05a927-f066-4323-953b-aae6bdc4460d} has been corrupted, and it's in an inconsistent state. The following validation errors happened:
WARNING: Database is mandatory on UserMailbox.

the solution was to delete both system mailboxes via ADSIedit, and when I ran setup again, it complained the mailbox didnt exist, so unlike in the article, I recreated it before running setup again, with the following command:

New-Mailbox -Arbitration -Name FederatedEmail.4c1f4d8b-8179-4148-93bf-00a95fa1e042 -UserPrincipalName FederatedEmail.4c1f4d8b-8179-4148-93bf-00a95fa1e042@<Default_Accepted_Domain>

the setup then ran fine.

the original problem was we couldn't mount any databases on the original Exchange 2010 server, so installed a second server, restored all data to it and then removed the first server and then readded it. the above error occured when trying to reinstalling Exchange on it.

all sorted now. (also sorted out small problems with MSFTE.msi versioning (full text indexing / search engine) caused by Update 4 rollup)

not very chuffed with Exchange 2010 installation steps failing left right and center. setup routines are very fragile it seems, especially with RTM / Update rollup changes.
HI Guys, I had the same issue trying to install EXCH2010,
I first tried to install in on a Windows Server 2012R2 but had issues with that apparently it is not supported. I did not uninstall the VM properly, like most of you.
In the end I manually deleted the Exchange Administrative group, ran Setup /PrepapareAD, which recreated the new Administrative group and solved my problem.

Hope this helps.
Not open for further replies.
Similar threads
Thread starter Title Forum Replies Date
A Moving Public Folders to New Database Exchange Server Administration 3
J No access to a Database BCM BCM (Business Contact Manager) 3
G Windows Update Causes BCM Database Access Problem? BCM (Business Contact Manager) 4
T Lost access to remote BCM database BCM (Business Contact Manager) 4
L Cannot Connect to BCM database BCM (Business Contact Manager) 9
A Cannot connect to BCM database BCM (Business Contact Manager) 3
Diane Poremsky Restoring BCM Database After Upgrading Windows Using Outlook 0
wallisellener "The database name cannot exceed 50 characters" BCM (Business Contact Manager) 2
S Encrypting Exchange Database Exchange Server Administration 0
R Outlook Database to a non-Outlook PC Using Outlook 10
M Modifying BCM Database using Access BCM (Business Contact Manager) 1
crazyboy Copying BCM database from backed up mounted image to new drive BCM (Business Contact Manager) 2
A use database in other office BCM (Business Contact Manager) 1
K Recover/preserve space in database BCM (Business Contact Manager) 0
P Restoring old sbb database in existing one BCM (Business Contact Manager) 4
J Install BCM Client without an local SQl Database BCM (Business Contact Manager) 6
M Sharing of BCM database across the internet BCM (Business Contact Manager) 2
Chris Grew Sharing BCM Database BCM (Business Contact Manager) 6
M BCM remote database connection issue BCM (Business Contact Manager) 1
S Updating the database based on received task Outlook VBA and Custom Forms 3
J What exactly does the BCM Database tool actually do? BCM (Business Contact Manager) 3
J How do I get the database tool to recognize my data file? BCM (Business Contact Manager) 2
C Moving BCM Database to Server Share BCM (Business Contact Manager) 1
D Open attached CSV, copy newdata and paste it to database CSV Outlook VBA and Custom Forms 2
K BCM - Connecting to Shared Database BCM (Business Contact Manager) 0
B Can't see database in multiuser BCM (Business Contact Manager) 1
S Passive Mailbox database Resynchronization issue Exchange Server Administration 1
J Can the BCM Database tool be used over VPN? BCM (Business Contact Manager) 6
D can you share a bcm database with 2 different versions of windows? BCM (Business Contact Manager) 0
T BCM database scheme BCM (Business Contact Manager) 5
E BCM Database Tool Using Outlook 2
G "database is not compatible with BCM for Outlook 2013" & more BCM (Business Contact Manager) 0
L BCM database not listed BCM (Business Contact Manager) 0
wallisellener database creation failed BCM (Business Contact Manager) 0
J No errors from BCM 2007 but can't see database BCM (Business Contact Manager) 0
P BCM 2013, Microsoft SQL Server 2008 R2 (SP2), attachment issue n database size BCM (Business Contact Manager) 2
T BCM Cannot See Existing Database BCM (Business Contact Manager) 2
R catalog Content Index failed-Unable to mount database.(hr=0x80004005,ec=-501) Exchange Server Administration 0
T Shared BCM database on remote server BCM (Business Contact Manager) 1
C My BCM Database is no longer available to be shared with the Database Tool BCM (Business Contact Manager) 3
wallisellener Server configuration for BCM 2013 shared database BCM (Business Contact Manager) 15
S Cannot Find Shared Database on Remote Computer BCM (Business Contact Manager) 13
M BCM in Outlook reports maximum database size to 4GB despite SQL Server 2008 R2 BCM (Business Contact Manager) 1
M "No database found" but successful connection to SQL server.What am I missing? BCM (Business Contact Manager) 5
A delete database --> record remnants ?? BCM (Business Contact Manager) 3
D BCM Database Protection BCM (Business Contact Manager) 3
U Exchange 2010 & mailbox database Quotas Exchange Server Administration 1
M BCM 2010 Cannot Connect to Remote Database BCM (Business Contact Manager) 1
J Unable to view History items in BCM 2007 shared database BCM (Business Contact Manager) 3
E Accessing User Defined Fields in BCM Database part 2 BCM (Business Contact Manager) 0

Similar threads