Exchange 2010 unknown error

Not open for further replies.


I have created a test setup for exchnage 2010 before going for a live server for organisation. The whole setup is running on VMWARE servers, (One AD, Two Exchange server (for testing DAG) and one windows 7 cleint. Everything was working fine.

Now i moved the whole VM setup to another Host (high capacity server) . but the when accessing mails i can login, but can not read any mail or create a mail. I tried to create anotehr user. same issue. This is the error which i copied from OWA



User host address:

User: jinesh

EX Address: /o=First Organization/ou=Exchange Administrative Group (FYDIBOHF23SPDLT)/cn=Recipients/cn=jinesh

SMTP Address: Jinesh@mydomain.local

OWA version: 14.0.639.21

Mailbox server: MAILSERVER.mydomain.local


Exception type: Microsoft.Exchange.Data.Storage.RightsManagementPermanentException

Exception message: Rights management operation failed.

Call stack


Microsoft.Exchange.Clients.Owa.Premium.EditMessage.OnLoad(EventArgs e)


System.Web.UI.Page.ProcessRequestMain(Boolean includeStagesBeforeAsyncPoint, Boolean includeStagesAfterAsyncPoint)

Inner Exception

Exception type: Microsoft.Exchange.Security.RightsManagement.RightsManagementException

Exception message: BindValidityTimeViolated

Call stack

Microsoft.Exchange.Security.RightsManagement.Errors.ThrowOnErrorCode(Int32 hr, LocalizedString contextMessage)

Microsoft.Exchange.Security.RightsManagement.Errors.ThrowOnErrorCode(Int32 hr)






Please to help me...i dont want reinstall the setup, just wanna diagonise and rectify this errot

Elie Bou Issa

Not sure about that but you seem to have some issues with IRM. Do you have IRM enabled for users? If you do, please try to disable it for a user and check if your issues would be solved.Elie B. MCITP: EMEA|EA|SA; MCTS: Microsoft Exchange Server 2010: Configuration; Blog:

Sathish Kumar Elango

Hi Jinesh,
Please try the following steps to fix the issue.
1. Goto Exchange 2010 Management shell ( Run As Administrator)
2. Execute the following commands. You may find IRM is True.
Get-OWAVirtualDirectory | FL *IRM*
3. We may have to turn it False , by the following command.
Set-OWAVirtualDirectory -IRMEnabled $False
4. Execute the following commands.You may find IRM is True for OWA.
Get-IRMConfiguration | FL *OWA*
5. We may see the We may have to turn it off by the following command.
Set-IRMConfiguration -OWAEnabled $False
6. Execute the following command to Reset the IIS.
7. Try the OWA again.
Ref to:
Understanding Information Rights Management in Outlook Web App
Enable or Disable Information Rights Management on Client Access Servers: Exchange 2013 Help
Enable or Disable Information Rights Management in Outlook Web App
Enable or Disable Information Rights Management on Client Access Servers: Exchange 2013 Help
Set-OwaVirtualDirectory: Exchange 2010 Help
Set-IRMConfiguration: Exchange 2010 Help
Last edited by a moderator:


problem has been solved by makind the dates was wrong on host and vm machines


New Member
Outlook version
Outlook 2010 64 bit
Email Account
Exchange Server
reviving an old post if someone can help.
I have just set up a new exhange 2010 multitenant server with all roles installed. When logging into the outlook web access and trying to create a email i get the error "Rights management operation failed."screenshot showing error with additional details I have tried disabling IRMenabled to false as can be seen in the next screenshot and restarted IIS but still get the error screenshot showingIRMEnabled disabled

I have rebuilt ther exchange server twice but on both occassions got this error any help would be much appreciated.

the screenshots can be seen in the stackoverflow forum i have posted this on
Rights management operation failed


Rehan Miah

Diane Poremsky

Senior Member
Outlook version
Outlook 2016 32 bit
Email Account
Office 365 Exchange
The instructions above should work...

Open exchange powershell
Log on to the exchange server and open (as Administrator) the Exchange Management Shell (EMS)
Run "Get-OWAVirtualDirectory | FL" and search for IRM; you'll probably see that it's enabled.
Run "Set-OWAVirtualDirectory -IRMEnabled $false" owa (Default Web Site)
Now reset IIS and try OWA again.
Not open for further replies.