wrong body .msg coding

Status
Not open for further replies.
G

giovanni

Hello everyone, I'm developing an add-in that uses redemption to save a

received mailitem.

This happens:

on an Outlook2000 test machine when I use MAPIUtils to reload .msg file and

then resave it to set correct message body, if original message contains

character like:

é, €, à, In the saved message I find them or changed with a triplet of

chars, for example:

"à" becomes "ÃÂ"

"€" becomes "€"

the message is saved as olMsg, but I saw PR_INTERNET_CPID = 65001

Any suggestion?!!

Many Thanks in Advance Giovanni
 
D

Dmitry Streblechenko

What version off Redemption are you using?

Dmitry Streblechenko (MVP)

-

"giovanni" <giovanni> wrote in message

news:7FAA358A-47B2-4B99-B474-3501C7E58C21@microsoft.com...
> Hello everyone, I'm developing an add-in that uses redemption to save a
> received mailitem.
> This happens:
> on an Outlook2000 test machine when I use MAPIUtils to reload .msg file
> and
> then resave it to set correct message body, if original message contains
> character like:
> e, ?, a, In the saved message I find them or changed with a triplet of
> chars, for example:
> "a" becomes "A?A"
> "?" becomes "A?a?sAƒ"
> the message is saved as olMsg, but I saw PR_INTERNET_CPID = 65001
> Any suggestion?!!

> > Many Thanks in Advance Giovanni
 
G

giovanni

Hi, I use 4.6.0.924

TIA Giovanni

"Dmitry Streblechenko" wrote:


> What version off Redemption are you using?

> > Dmitry Streblechenko (MVP)
>

>

>

> -
> "giovanni" <giovanni> wrote in message
> news:7FAA358A-47B2-4B99-B474-3501C7E58C21@microsoft.com...
> > Hello everyone, I'm developing an add-in that uses redemption to save a
> > received mailitem.
> > This happens:
> > on an Outlook2000 test machine when I use MAPIUtils to reload .msg file
> > and
> > then resave it to set correct message body, if original message contains
> > character like:
> > e, ?, a, In the saved message I find them or changed with a triplet of
> > chars, for example:
> > "a" becomes "A?A"
> > "?" becomes "A?a?sAÆ’"
> > the message is saved as olMsg, but I saw PR_INTERNET_CPID = 65001
> > Any suggestion?!!
> > > > Many Thanks in Advance Giovanni


>
 
D

Dmitry Streblechenko

Have you tried the latest (4.7)?

Dmitry Streblechenko (MVP)

-

"giovanni" <giovanni> wrote in message

news:109D6341-0C0E-4696-98DE-84AD140D22E9@microsoft.com...
> Hi, I use 4.6.0.924
> > TIA Giovanni

> "Dmitry Streblechenko" wrote:
>
> > What version off Redemption are you using?
>

>
>> > > Dmitry Streblechenko (MVP)
> >

> >

> >

> > -
> > "giovanni" <giovanni> wrote in message
> > news:7FAA358A-47B2-4B99-B474-3501C7E58C21@microsoft.com...
> > > Hello everyone, I'm developing an add-in that uses redemption to save a
> > > received mailitem.
> > > This happens:
> > > on an Outlook2000 test machine when I use MAPIUtils to reload .msg file
> > > and
> > > then resave it to set correct message body, if original message
> > > contains
> > > character like:
> > > e, ?, a, In the saved message I find them or changed with a triplet of
> > > chars, for example:
> > > "a" becomes "A?A"
> > > "?" becomes "A?a?sA?"
> > > the message is saved as olMsg, but I saw PR_INTERNET_CPID = 65001
> > > Any suggestion?!!
> >> > > > > Many Thanks in Advance Giovanni

>

>
>>
 
G

giovanni

Hi, no I'll manage and then I'll report, are there known issues about

> .htmlbody encoding on 4.6?

TIA Giovanni

"Dmitry Streblechenko" wrote:


> Have you tried the latest (4.7)?

> > Dmitry Streblechenko (MVP)
>

>

>

> -
> "giovanni" <giovanni> wrote in message
> news:109D6341-0C0E-4696-98DE-84AD140D22E9@microsoft.com...
> > Hi, I use 4.6.0.924
> > > > TIA Giovanni
> > "Dmitry Streblechenko" wrote:
> >
> >> What version off Redemption are you using?
> >
> >
> >> > >> Dmitry Streblechenko (MVP)
> >>

> >>

> >>

> >> -
> >> "giovanni" <giovanni> wrote in message
> >> news:7FAA358A-47B2-4B99-B474-3501C7E58C21@microsoft.com...
> >> > Hello everyone, I'm developing an add-in that uses redemption to save a
> >> > received mailitem.
> >> > This happens:
> >> > on an Outlook2000 test machine when I use MAPIUtils to reload .msg file
> >> > and
> >> > then resave it to set correct message body, if original message
> >> > contains
> >> > character like:
> >> > e, ?, a, In the saved message I find them or changed with a triplet of
> >> > chars, for example:
> >> > "a" becomes "A?A"
> >> > "?" becomes "A?a?sA?"
> >> > the message is saved as olMsg, but I saw PR_INTERNET_CPID = 65001
> >> > Any suggestion?!!
> >> >> > > >> > Many Thanks in Advance Giovanni
> >
> >
> >>


>
 
D

Dmitry Streblechenko

There were a few changes related to HTMLBody in version 4.7...

Dmitry Streblechenko (MVP)

-

"giovanni" <giovanni> wrote in message

news:ABA8A1B8-C37E-4C8A-8883-F087807959F7@microsoft.com...
> Hi, no I'll manage and then I'll report, are there known issues about
> .htmlbody encoding on 4.6?
> > TIA Giovanni

> "Dmitry Streblechenko" wrote:
>
> > Have you tried the latest (4.7)?
>

>> > > Dmitry Streblechenko (MVP)
> >

> >

> >

> > -
> > "giovanni" <giovanni> wrote in message
> > news:109D6341-0C0E-4696-98DE-84AD140D22E9@microsoft.com...
> > > Hi, I use 4.6.0.924
> > > > > > TIA Giovanni
> >>> > "Dmitry Streblechenko" wrote:
> >> >> What version off Redemption are you using?
> > >
>> >
>> >> > > >> Dmitry Streblechenko (MVP)
> > >>

> > >>

> > >>

> > >> -
> > >> "giovanni" <giovanni> wrote in message
> > >> news:7FAA358A-47B2-4B99-B474-3501C7E58C21@microsoft.com...
> > >> > Hello everyone, I'm developing an add-in that uses redemption to
> > >> > save a
> > >> > received mailitem.
> > >> > This happens:
> > >> > on an Outlook2000 test machine when I use MAPIUtils to reload .msg
> > >> > file
> > >> > and
> > >> > then resave it to set correct message body, if original message
> > >> > contains
> > >> > character like:
> > >> > e, ?, a, In the saved message I find them or changed with a triplet
> > >> > of
> > >> > chars, for example:
> > >> > "a" becomes "A?A"
> > >> > "?" becomes "A?a?sA?"
> > >> > the message is saved as olMsg, but I saw PR_INTERNET_CPID = 65001
> > >> > Any suggestion?!!
> > >>> >> > > > >> > Many Thanks in Advance Giovanni
> > >
>> >
>> >>

>

>
>>
 
G

giovanni

Hi, I've made a try with 4.7, but it still makes wrong .Html body, but in a

different way (I mean it changhes the wrong chars than the previous version

with other wrong chars), I tried setting and non setting .InternetCodepage

before and after setting .html body but result is still wrong.

Any idea?

TIA Giovanni

"Dmitry Streblechenko" wrote:


> There were a few changes related to HTMLBody in version 4.7...

> > Dmitry Streblechenko (MVP)
>

>

>

> -
> "giovanni" <giovanni> wrote in message
> news:ABA8A1B8-C37E-4C8A-8883-F087807959F7@microsoft.com...
> > Hi, no I'll manage and then I'll report, are there known issues about
> > .htmlbody encoding on 4.6?
> > > > TIA Giovanni
> > "Dmitry Streblechenko" wrote:
> >
> >> Have you tried the latest (4.7)?
> >
> >> > >> Dmitry Streblechenko (MVP)
> >>

> >>

> >>

> >> -
> >> "giovanni" <giovanni> wrote in message
> >> news:109D6341-0C0E-4696-98DE-84AD140D22E9@microsoft.com...
> >> > Hi, I use 4.6.0.924
> >> > > >> > TIA Giovanni
> >> >> >> > "Dmitry Streblechenko" wrote:
> >> >> >> What version off Redemption are you using?
> >> >
> >> >
> >> >> > >> >> Dmitry Streblechenko (MVP)
> >> >>

> >> >>

> >> >>

> >> >> -
> >> >> "giovanni" <giovanni> wrote in message
> >> >> news:7FAA358A-47B2-4B99-B474-3501C7E58C21@microsoft.com...
> >> >> > Hello everyone, I'm developing an add-in that uses redemption to
> >> >> > save a
> >> >> > received mailitem.
> >> >> > This happens:
> >> >> > on an Outlook2000 test machine when I use MAPIUtils to reload .msg
> >> >> > file
> >> >> > and
> >> >> > then resave it to set correct message body, if original message
> >> >> > contains
> >> >> > character like:
> >> >> > e, ?, a, In the saved message I find them or changed with a triplet
> >> >> > of
> >> >> > chars, for example:
> >> >> > "a" becomes "A?A"
> >> >> > "?" becomes "A?a?sA?"
> >> >> > the message is saved as olMsg, but I saw PR_INTERNET_CPID = 65001
> >> >> > Any suggestion?!!
> >> >> >> >> > > >> >> > Many Thanks in Advance Giovanni
> >> >
> >> >
> >> >
> >
> >
> >>


>
 
Status
Not open for further replies.
Similar threads
Thread starter Title Forum Replies Date
D Wrong email address in Outlook 2003 "From" tab in new outgoing emails Using Outlook 4
M Something went wrong and your search couldn't be completed Using Outlook 1
L Correct E-Mail Pulling Wrong Mail Using Outlook 5
C Outlook Autocomplete suggestions showing wrong person's name against an email address Using Outlook 0
B Sharing Outlook calendars gone wrong Using Outlook 0
S Outlook 2007 printing wrong email address at top of page Using Outlook 8
S Meeting Invite arrives from Wrong ("send-as") Sender Using Outlook 1
N Copies of emails from rules have wrong from: account Using Outlook 0
A Replies being sent from wrong account Using Outlook 8
W Sending To Wrong Account Using Outlook 15
icacream Rule based on sender / wrong sender sent to folder Using Outlook 7
Z Outlook for G Suite emails showing wrong dates Using Outlook 4
C How to avoid sending mail to the wrong contact person Using Outlook 1
Diane Poremsky Warn before sending messages to the wrong email address Using Outlook 1
M Messages in Outbox reminder is wrong Using Outlook 4
R Correct a wrong csv export file from WLM 2012 Using Outlook 0
J BCM 2013 displays wrong form for account and business contact BCM (Business Contact Manager) 1
R OL2010 - Send to Mail Recipient going to wrong account Using Outlook 1
B you are not responding to the latest message - wrong email Using Outlook 1
E Recurred tasks are created with a wrong due date Using Outlook 0
Diane Poremsky The calendar shows the wrong day at the beginning or end of the month Using Outlook 0
J Calendar search failing & wrong indexlocation showing..OL2010 Using Outlook 3
e_a_g_l_e_p_i Is something wrong with my themes Using Outlook 3
G Wrong display name in from column when removing pf replication Exchange Server Administration 1
Commodore Wrapping and wrong encoding Using Outlook 2
MattC Some fonts the wrong size in incoming emails in Outlook 2007 Using Outlook 6
G Onding e-mail with wrong signature Using Outlook 0
O BCM Dbase Issues (both not seeing dbase & not allowing restore for wrong owner BCM (Business Contact Manager) 2
P Outlook 2013 rules -- not working reliably -- moving messages to wrong boxes Using Outlook 0
L Schedule Assistant shows wrong working hours Using Outlook 1
C Outlook 2003 displays wrong account in IMAP Using Outlook 5
G Outlook 2013 display the wrong font Using Outlook 7
S Wrong email account displayed in folders Using Outlook 3
J Incoming emails going to wrong sub-folder Using Outlook 4
T Change from exchange server to pop when I set up outlook wrong Exchange Server Administration 1
S Outlook 2003 - showing meeting on wrong day and time Using Outlook 1
G appointment times are wrong Using Outlook 3
V What is wrong with Outlook Connector - it still errors out on an EMPTY Hotmail Using Outlook.com accounts in Outlook 3
D Outlook sends e-mails using the wrong account Using Outlook 0
V Wrong Address List being used (or Resolved by ALT + K) Using Outlook 1
R How to configure outlook to avoid sending emails from the wrong account Using Outlook 24
V meeting displayed at wrong time Using Outlook 4
K Quick Print shows wrong date on Occurrences Using Outlook 1
K Business account window is wrong BCM (Business Contact Manager) 1
S Restrict method question on email. What am I doing wrong? Outlook VBA and Custom Forms 2
L wrong icon displayed for outlook custom form Outlook VBA and Custom Forms 8
D Application.ActiveInspector().CurrentItem Returns Wrong(Old) Value Outlook VBA and Custom Forms 3
D Exporting reports to Excel gives wrong numbers BCM (Business Contact Manager) 1
D Wrong Form view in "Developer" Tab for "Accounts" BCM (Business Contact Manager) 4
J prevent user from installing wrong version of add-in Outlook VBA and Custom Forms 2

Similar threads

Top